aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2001-12-13 19:24:30 +0800
committerijliao <ijliao@FreeBSD.org>2001-12-13 19:24:30 +0800
commit48e3e18e7c730019c74eeb46c66d023c36ab1a82 (patch)
treec7510785a9cb3841fe4ac3dba9526b2ab9f1dcc0 /net
parenta302383e8e861152532aecfa9acd1b516fd0d780 (diff)
downloadfreebsd-ports-graphics-48e3e18e7c730019c74eeb46c66d023c36ab1a82.tar.gz
freebsd-ports-graphics-48e3e18e7c730019c74eeb46c66d023c36ab1a82.tar.zst
freebsd-ports-graphics-48e3e18e7c730019c74eeb46c66d023c36ab1a82.zip
add p5-Net-Pcap
Interface to pcap(3) LBL packet capture library PR: 32775 Submitted by: Sergey Skvortsov <skv@protey.ru>
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/p5-Net-Pcap/Makefile22
-rw-r--r--net/p5-Net-Pcap/distinfo1
-rw-r--r--net/p5-Net-Pcap/pkg-comment1
-rw-r--r--net/p5-Net-Pcap/pkg-descr6
-rw-r--r--net/p5-Net-Pcap/pkg-plist7
6 files changed, 38 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index b3a8aa3f900..aaaf9c01d30 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -293,6 +293,7 @@
SUBDIR += p5-Net-Netmask
SUBDIR += p5-Net-ParseWhois
SUBDIR += p5-Net-Patricia
+ SUBDIR += p5-Net-Pcap
SUBDIR += p5-Net-RawIP
SUBDIR += p5-Net-SNMP
SUBDIR += p5-Net-SSH
diff --git a/net/p5-Net-Pcap/Makefile b/net/p5-Net-Pcap/Makefile
new file mode 100644
index 00000000000..852d1d16126
--- /dev/null
+++ b/net/p5-Net-Pcap/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: Net-Pcap
+# Date created: 10 Dec 2001
+# Whom: Sergey Skvortsov <skv@protey.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-Pcap
+PORTVERSION= 0.04
+CATEGORIES= net perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Net
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= skv@protey.ru
+
+PERL_CONFIGURE= yes
+
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= Net::Pcap.3
+
+.include <bsd.port.mk>
diff --git a/net/p5-Net-Pcap/distinfo b/net/p5-Net-Pcap/distinfo
new file mode 100644
index 00000000000..2c3edf28886
--- /dev/null
+++ b/net/p5-Net-Pcap/distinfo
@@ -0,0 +1 @@
+MD5 (Net-Pcap-0.04.tar.gz) = 3456934b09598122fea6a553cdf42a91
diff --git a/net/p5-Net-Pcap/pkg-comment b/net/p5-Net-Pcap/pkg-comment
new file mode 100644
index 00000000000..ad2a466327e
--- /dev/null
+++ b/net/p5-Net-Pcap/pkg-comment
@@ -0,0 +1 @@
+Interface to pcap(3) LBL packet capture library
diff --git a/net/p5-Net-Pcap/pkg-descr b/net/p5-Net-Pcap/pkg-descr
new file mode 100644
index 00000000000..8b2617209d0
--- /dev/null
+++ b/net/p5-Net-Pcap/pkg-descr
@@ -0,0 +1,6 @@
+Interface to pcap(3) LBL packet capture library
+
+WWW: http://search.cpan.org/search?dist=Net-Pcap
+
+-- Sergey Skvortsov
+skv@protey.ru
diff --git a/net/p5-Net-Pcap/pkg-plist b/net/p5-Net-Pcap/pkg-plist
new file mode 100644
index 00000000000..b3783c3972d
--- /dev/null
+++ b/net/p5-Net-Pcap/pkg-plist
@@ -0,0 +1,7 @@
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Net/Pcap.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Net/Pcap/.packlist
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Net/Pcap/Pcap.bs
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Net/Pcap/Pcap.so
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Net/Pcap
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Net 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Net 2>/dev/null || true