aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2014-03-18 00:37:19 +0800
committerehaupt <ehaupt@FreeBSD.org>2014-03-18 00:37:19 +0800
commit5301b4d8aadbb8739c0feb185cff2726d68c7929 (patch)
tree8110be01de5d32e3dd5e2f04eb405208ba4e76d4 /net
parent69c3308593296b82226002ef40ba85e7e07d04b6 (diff)
downloadfreebsd-ports-graphics-5301b4d8aadbb8739c0feb185cff2726d68c7929.tar.gz
freebsd-ports-graphics-5301b4d8aadbb8739c0feb185cff2726d68c7929.tar.zst
freebsd-ports-graphics-5301b4d8aadbb8739c0feb185cff2726d68c7929.zip
- Support staging
- Define DOCS option
Diffstat (limited to 'net')
-rw-r--r--net/lambdamoo/Makefile30
1 files changed, 13 insertions, 17 deletions
diff --git a/net/lambdamoo/Makefile b/net/lambdamoo/Makefile
index a62c5927ec4..76020197526 100644
--- a/net/lambdamoo/Makefile
+++ b/net/lambdamoo/Makefile
@@ -11,29 +11,25 @@ DISTNAME= LambdaMOO-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= The most commonly used program to run MOOs
-WRKSRC= ${WRKDIR}/MOO-${PORTVERSION}
+USES= bison
GNU_CONFIGURE= yes
-ALL_TARGET=
+
CONFIGURE_ENV= YACC=${YACC}
-USES= bison
-PLIST_FILES= sbin/moo
+WRKSRC= ${WRKDIR}/MOO-${PORTVERSION}
+PLIST_FILES= sbin/moo
PORTDOCS= *
-NO_STAGE= yes
+ALL_TARGET=
+
+OPTIONS_DEFINE= DOCS
+
do-install:
- @${INSTALL_PROGRAM} ${WRKSRC}/moo ${PREFIX}/sbin
-
-post-install:
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
- @(cd ${WRKSRC};\
- ${INSTALL_MAN} Minimal.db README README.Minimal \
- ${DOCSDIR}; \
- )
- @${INSTALL_DATA} ${FILESDIR}/README.FreeBSD \
- ${DOCSDIR}
-.endif
+ ${INSTALL_PROGRAM} ${WRKSRC}/moo ${STAGEDIR}${PREFIX}/sbin
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ (cd ${WRKSRC}; ${INSTALL_MAN} Minimal.db README README.Minimal \
+ ${STAGEDIR}${DOCSDIR})
+ ${INSTALL_DATA} ${FILESDIR}/README.FreeBSD ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>