aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorgabor <gabor@FreeBSD.org>2007-04-20 05:20:48 +0800
committergabor <gabor@FreeBSD.org>2007-04-20 05:20:48 +0800
commit53dddc2be9f0f0ae838011f3410a14c8c72d1747 (patch)
tree73ae0002704600e4718b450eb2c2004762b5be6c /net
parent8715172b5618fc67a4e8f9fd9a86d4a65e39e4ee (diff)
downloadfreebsd-ports-graphics-53dddc2be9f0f0ae838011f3410a14c8c72d1747.tar.gz
freebsd-ports-graphics-53dddc2be9f0f0ae838011f3410a14c8c72d1747.tar.zst
freebsd-ports-graphics-53dddc2be9f0f0ae838011f3410a14c8c72d1747.zip
- Remove FreeBSD 4.X support from unmaintained ports in categories starting
with letter n-p
Diffstat (limited to 'net')
-rw-r--r--net/gq/Makefile4
-rw-r--r--net/libnet-devel/Makefile12
-rw-r--r--net/libunp/Makefile8
-rw-r--r--net/mpich/Makefile2
-rw-r--r--net/nvnet/Makefile4
-rw-r--r--net/rdist6/Makefile7
-rw-r--r--net/tintin++-devel/Makefile11
-rw-r--r--net/vls/Makefile4
8 files changed, 5 insertions, 47 deletions
diff --git a/net/gq/Makefile b/net/gq/Makefile
index 660cf818392..696359bcb7a 100644
--- a/net/gq/Makefile
+++ b/net/gq/Makefile
@@ -39,10 +39,6 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 500000
-BROKEN= does not compile
-.endif
-
.if !defined(WITHOUT_JPEG)
USE_GNOME+= gdkpixbuf
.endif
diff --git a/net/libnet-devel/Makefile b/net/libnet-devel/Makefile
index e7a4c24e60e..76cac44ab6b 100644
--- a/net/libnet-devel/Makefile
+++ b/net/libnet-devel/Makefile
@@ -32,16 +32,6 @@ EXAMPLES= sample/*.c
SHORT_VER= 113
-.include <bsd.port.pre.mk>
-
-post-patch:
-.if ${OSVERSION} < 500000
- ${REINPLACE_CMD} -e "s|stdint\.h|inttypes.h|g" \
- ${WRKSRC}/include/libnet/libnet-types.h
-.else
- ${DO_NADA}
-.endif
-
post-install:
${INSTALL_SCRIPT} ${WRKSRC}/libnet-config \
${PREFIX}/bin/libnet${SHORT_VER}-config
@@ -55,4 +45,4 @@ post-install:
cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${DOCSDIR}
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/libunp/Makefile b/net/libunp/Makefile
index 95428628884..c72d88ef0ed 100644
--- a/net/libunp/Makefile
+++ b/net/libunp/Makefile
@@ -18,12 +18,6 @@ COMMENT= The networking library used in UNIX Network Programming Volume 1 2e
GNU_CONFIGURE= yes
USE_GMAKE= yes
-.include <bsd.port.pre.mk>
-
-.if ${ARCH} == "alpha" && ${OSVERSION} < 500000
-BROKEN= "Does not compile on alpha 4.x"
-.endif
-
pre-patch:
@ ${CP} ${WRKSRC}/lib/wrapsock.c ${WRKSRC}/lib/wrapsock_r.c
@@ -40,4 +34,4 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/lib/addrinfo.h ${PREFIX}/include/unp
${INSTALL_DATA} ${WRKSRC}/config.h ${PREFIX}/include/unp
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/mpich/Makefile b/net/mpich/Makefile
index 6d4ad43384c..e4d81bfd558 100644
--- a/net/mpich/Makefile
+++ b/net/mpich/Makefile
@@ -185,7 +185,7 @@ MAN4= CLOG_Init.4 CLOG_commtype.4 CLOG_cput.4 CLOG_csync.4 \
# Use ssh instead of rsh
.if !defined(WITHOUT_SSH)
-.if ${OSVERSION} >= 400016 && exists(/usr/bin/ssh)
+.if exists(/usr/bin/ssh)
CONFIGURE_ENV+= RSHCOMMAND="/usr/bin/ssh"
.elif defined(WITH_SSH) || exists(${LOCALBASE}/bin/ssh)
RUN_DEPENDS+= ${LOCALBASE}/bin/ssh:${PORTSDIR}/security/ssh
diff --git a/net/nvnet/Makefile b/net/nvnet/Makefile
index 8b8efb53b58..4295ee90952 100644
--- a/net/nvnet/Makefile
+++ b/net/nvnet/Makefile
@@ -26,10 +26,6 @@ MAKE_ENV= OSTYPE=${OPSYS}
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 480100 || ${OSVERSION} >= 500000 && ${OSVERSION} < 501000
-IGNORE= Systems prior to FreeBSD 4.9 & 5.1 are not supported
-.endif
-
.if ${OSVERSION} >= 600021
IGNORE= nve support already exists in base
.endif
diff --git a/net/rdist6/Makefile b/net/rdist6/Makefile
index a80f407134a..1c3d6d57b4b 100644
--- a/net/rdist6/Makefile
+++ b/net/rdist6/Makefile
@@ -15,11 +15,6 @@ MASTER_SITES= http://www.magnicomp.com/download/rdist/ \
MAINTAINER= ports@FreeBSD.org
COMMENT= A network file distribution/synchronisation utility
-.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 400000
-BROKEN= Not supported for pre-4.0 FreeBSD
-.endif
-
# To avoid confusion with /usr/bin/rdist, you may prefer otherwise.
RDIST_NAME?= rdist6
@@ -33,4 +28,4 @@ post-install:
@${STRIP_CMD} ${PREFIX}/bin/${RDIST_NAME}
@${STRIP_CMD} ${PREFIX}/bin/rdistd
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/tintin++-devel/Makefile b/net/tintin++-devel/Makefile
index 919dc77c2b2..3f4fc91f205 100644
--- a/net/tintin++-devel/Makefile
+++ b/net/tintin++-devel/Makefile
@@ -25,15 +25,6 @@ USE_GCC= 3.2+
PLIST_FILES= bin/tt++
PORTDOCS= BUGS CREDITS FAQ README TODO tintin19.txt chat_protocol.txt
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 500000
-LIB_DEPENDS+= readline.5:${PORTSDIR}/devel/readline
-CFLAGS+= -I ${LOCALBASE}/include
-MAKE_ENV+= LIBS="-L${LOCALBASE}/lib"
-MAKE_ARGS+= LDFLAGS=${PTHREAD_LIBS}
-.endif
-
post-patch:
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|' ${WRKSRC}/Makefile.in
@@ -46,4 +37,4 @@ do-install:
.endfor
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/vls/Makefile b/net/vls/Makefile
index 7700c87fc79..da575fcd326 100644
--- a/net/vls/Makefile
+++ b/net/vls/Makefile
@@ -53,10 +53,6 @@ post-install:
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 500000
-BROKEN= Does not build
-.endif
-
.if ${OSVERSION} >= 502122
# allow nonconforming code to compile
CFLAGS+= -fpermissive