aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorroger <roger@FreeBSD.org>2000-08-19 02:48:15 +0800
committerroger <roger@FreeBSD.org>2000-08-19 02:48:15 +0800
commit5689a9fa818bf52308dd1f62f37cc6e40e238494 (patch)
tree628fc5bd162d744c942e34393cf3a8ebd915a298 /net
parent63019aa21d055bd8db1024a4ff962505dbc62843 (diff)
downloadfreebsd-ports-graphics-5689a9fa818bf52308dd1f62f37cc6e40e238494.tar.gz
freebsd-ports-graphics-5689a9fa818bf52308dd1f62f37cc6e40e238494.tar.zst
freebsd-ports-graphics-5689a9fa818bf52308dd1f62f37cc6e40e238494.zip
Import OhPhone, an OpenH323 Video Conferencing program
used with the OpenH323 library
Diffstat (limited to 'net')
-rw-r--r--net/ohphone/Makefile38
-rw-r--r--net/ohphone/distinfo1
-rw-r--r--net/ohphone/pkg-comment1
-rw-r--r--net/ohphone/pkg-descr10
-rw-r--r--net/ohphone/pkg-plist1
5 files changed, 51 insertions, 0 deletions
diff --git a/net/ohphone/Makefile b/net/ohphone/Makefile
new file mode 100644
index 00000000000..c12b875f611
--- /dev/null
+++ b/net/ohphone/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: ohphone
+# Date created: Fri Aug 18 19:29:00 BST 2000
+# Whom: Roger Hardiman <roger@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ohphone
+PORTVERSION= 1.1b3
+CATEGORIES= net
+MASTER_SITES= http://www.openh323.org/bin/ \
+ http://www.de.openh323.org/bin/ \
+ http://www.ru.openh323.org/bin/
+DISTNAME= ohphone_1.1beta3
+
+MAINTAINER= roger@FreeBSD.org
+
+BUILD_DEPENDS= /nonexistent:${PORTSDIR}/net/openh323:build
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+NOCLEANDEPENDS= yes
+
+USE_NEWGCC= yes
+USE_BISON= yes
+USE_GMAKE= yes
+ALL_TARGET= opt
+MAKE_ENV= PWLIBDIR=${WRKDIRPREFIX}${.CURDIR}/../openh323/work/pwlib \
+ OPENH323DIR=${WRKDIRPREFIX}${.CURDIR}/../openh323/work/openh323
+THE_MACHTYPE= ${ARCH:S/i386/x86/}
+MAKE_ARGS= OSTYPE=${OPSYS} MACHTYPE=${THE_MACHTYPE} OSRELEASE=${OSVERSION} CPLUS=${CXX}
+MAN1= ohphone.1
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/obj_${OPSYS}_${THE_MACHTYPE}_r/ohphone ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/ohphone.1 ${PREFIX}/man/man1
+
+.include <bsd.port.mk>
diff --git a/net/ohphone/distinfo b/net/ohphone/distinfo
new file mode 100644
index 00000000000..53711dea097
--- /dev/null
+++ b/net/ohphone/distinfo
@@ -0,0 +1 @@
+MD5 (ohphone_1.1beta3.tar.gz) = b0c0c64a710108b976c81c31cc40aa78
diff --git a/net/ohphone/pkg-comment b/net/ohphone/pkg-comment
new file mode 100644
index 00000000000..1b66c062a97
--- /dev/null
+++ b/net/ohphone/pkg-comment
@@ -0,0 +1 @@
+H323 Video Conferencing Program, compatible with NetMeeting
diff --git a/net/ohphone/pkg-descr b/net/ohphone/pkg-descr
new file mode 100644
index 00000000000..830c12028d9
--- /dev/null
+++ b/net/ohphone/pkg-descr
@@ -0,0 +1,10 @@
+OhPhone is a H323 Video Conferencing Program compatible with other
+H323 video conferencing programs including Microsoft NetMeeting.
+
+OhPhone supports full duplex audio and bi-directional video.
+It requires a full duplex sound card for audio support
+and a Bt848/878 based video card (using the bktr driver) for video capture.
+
+It uses the OpenH323 and PWLib libraries, developed by Equivalence Pty.
+
+WWW: http://www.openh323.org
diff --git a/net/ohphone/pkg-plist b/net/ohphone/pkg-plist
new file mode 100644
index 00000000000..3dc0b2a593b
--- /dev/null
+++ b/net/ohphone/pkg-plist
@@ -0,0 +1 @@
+bin/ohphone