aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2003-08-30 08:39:09 +0800
committeredwin <edwin@FreeBSD.org>2003-08-30 08:39:09 +0800
commit56b5a486562e590b74e585b5304d1d245caec28e (patch)
tree019a7ca611d2a40ca7ee31955da3a0d7f8741ae9 /net
parent7c39fc4f81bf5983ef9be8fcce74e18d9fd18bd3 (diff)
downloadfreebsd-ports-graphics-56b5a486562e590b74e585b5304d1d245caec28e.tar.gz
freebsd-ports-graphics-56b5a486562e590b74e585b5304d1d245caec28e.tar.zst
freebsd-ports-graphics-56b5a486562e590b74e585b5304d1d245caec28e.zip
new port: net/weedns_sc
This is a new port of the Perl WeedNS skeleton_client that can be use to update your yi.org/whyi.org dynamic DNS entries. PR: ports/52582 Submitted by: Matthias Andree <matthias.andree@gmx.de>
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/weedns_sc/Makefile47
-rw-r--r--net/weedns_sc/distinfo1
-rw-r--r--net/weedns_sc/pkg-descr1
-rw-r--r--net/weedns_sc/pkg-plist6
5 files changed, 56 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 6cd453bf7f0..c9cb65e6e06 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -723,6 +723,7 @@
SUBDIR += wais
SUBDIR += wakeonlan
SUBDIR += walker
+ SUBDIR += weedns_sc
SUBDIR += whatmask
SUBDIR += wide-dhcp
SUBDIR += wmlj
diff --git a/net/weedns_sc/Makefile b/net/weedns_sc/Makefile
new file mode 100644
index 00000000000..66058415f00
--- /dev/null
+++ b/net/weedns_sc/Makefile
@@ -0,0 +1,47 @@
+# ports collection Makefile for: weedns_sc
+# Whom: Matthias Andree <matthias.andree@gmx.de>
+# Date created: 2003-05-22
+#
+# $FreeBSD$
+#
+
+PORTNAME= weedns_sc
+PORTVERSION= 1.19
+CATEGORIES= net perl5
+MASTER_SITES= http://www.weedns.com/clients/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= matthias.andree@gmx.de
+COMMENT= Client to update whyi.org dynamic DNS service
+
+RUN_DEPENDS= ${SITE_PERL}/HTTP/Request/Common.pm:${PORTSDIR}/www/p5-libwww \
+ ${SITE_PERL}/${PERL_ARCH}/Storable.pm:${PORTSDIR}/devel/p5-Storable \
+ ${SITE_PERL}/URI/Escape.pm:${PORTSDIR}/net/p5-URI
+
+USE_PERL5= yes
+USE_REINPLACE= yes
+NO_BUILD= yes
+
+post-patch:
+ ${REINPLACE_CMD} "s|^#!/usr/bin/perl|#!${PERL}|" ${WRKSRC}/bin/skeleton_client.pl
+ ${REINPLACE_CMD} "s|^#!/usr/bin/perl|#!${PERL}|" ${WRKSRC}/bin/smtp_ip.pl
+
+do-install:
+ ${MKDIR} ${PREFIX}/bin
+ ${MKDIR} ${PREFIX}/etc
+ ${MKDIR} ${SITE_PERL}/WeedNS
+ ${INSTALL_SCRIPT} ${WRKSRC}/bin/skeleton_client.pl ${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/bin/smtp_ip.pl ${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/lib/WeedNS/Client.pm ${SITE_PERL}/WeedNS
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_MAN} ${WRKSRC}/skeleton_client.html ${DOCSDIR}
+.endif
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= "requires Perl 5.6+. Install lang/perl5, run use.perl port, retry"
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/net/weedns_sc/distinfo b/net/weedns_sc/distinfo
new file mode 100644
index 00000000000..6c9b0737b6f
--- /dev/null
+++ b/net/weedns_sc/distinfo
@@ -0,0 +1 @@
+MD5 (weedns_sc-1.19.tgz) = 8a9ee8b11e34d7820f37704ba3bb6fcc
diff --git a/net/weedns_sc/pkg-descr b/net/weedns_sc/pkg-descr
new file mode 100644
index 00000000000..8b137891791
--- /dev/null
+++ b/net/weedns_sc/pkg-descr
@@ -0,0 +1 @@
+
diff --git a/net/weedns_sc/pkg-plist b/net/weedns_sc/pkg-plist
new file mode 100644
index 00000000000..88f1cd77e7e
--- /dev/null
+++ b/net/weedns_sc/pkg-plist
@@ -0,0 +1,6 @@
+bin/skeleton_client.pl
+bin/smtp_ip.pl
+%%SITE_PERL%%/WeedNS/Client.pm
+%%PORTDOCS%%%%DOCSDIR%%/skeleton_client.html
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@dirrm %%SITE_PERL%%/WeedNS