aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorsuz <suz@FreeBSD.org>2005-11-22 06:33:50 +0800
committersuz <suz@FreeBSD.org>2005-11-22 06:33:50 +0800
commit5d9ccd63bbf7294b01f62a73e09e4381a22d3406 (patch)
tree1d9a57918705e3445a59731e61ae21f975234d04 /net
parente7aaa0b3515c433f5a3dcc915b59475d9ddc9754 (diff)
downloadfreebsd-ports-graphics-5d9ccd63bbf7294b01f62a73e09e4381a22d3406.tar.gz
freebsd-ports-graphics-5d9ccd63bbf7294b01f62a73e09e4381a22d3406.tar.zst
freebsd-ports-graphics-5d9ccd63bbf7294b01f62a73e09e4381a22d3406.zip
pim6dd and pim6sd are succeeded by mcast-tools
Diffstat (limited to 'net')
-rw-r--r--net/Makefile3
-rw-r--r--net/mcast-tools/Makefile31
-rw-r--r--net/mcast-tools/distinfo2
-rw-r--r--net/mcast-tools/files/patch-configure19
-rw-r--r--net/mcast-tools/files/pim6dd.conf.sample3
-rw-r--r--net/mcast-tools/pkg-descr21
-rw-r--r--net/mcast-tools/pkg-plist8
-rw-r--r--net/pim6dd/Makefile44
-rw-r--r--net/pim6dd/distinfo2
-rw-r--r--net/pim6dd/files/pim6dd.conf3
-rw-r--r--net/pim6dd/pkg-descr2
-rw-r--r--net/pim6dd/pkg-plist2
-rw-r--r--net/pim6sd/files/patch-Makefile17
-rw-r--r--net/pim6sd/files/patch-Makefile.inc7
-rw-r--r--net/pim6sd/files/patch-pim6sd-Makefile11
-rw-r--r--net/pim6sd/files/patch-pim6sd-routesock.h11
-rw-r--r--net/pim6sd/files/pim6sd.conf4
17 files changed, 85 insertions, 105 deletions
diff --git a/net/Makefile b/net/Makefile
index 43876f5ef79..02b3c4b3019 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -316,6 +316,7 @@
SUBDIR += mad_fcl
SUBDIR += magictun
SUBDIR += mars_nwe
+ SUBDIR += mcast-tools
SUBDIR += merlinmon
SUBDIR += mgen
SUBDIR += micro_proxy
@@ -561,8 +562,6 @@
SUBDIR += php5-xmlrpc
SUBDIR += php5-yp
SUBDIR += phpldapadmin
- SUBDIR += pim6dd
- SUBDIR += pim6sd
SUBDIR += pipsecd
SUBDIR += plb
SUBDIR += pload
diff --git a/net/mcast-tools/Makefile b/net/mcast-tools/Makefile
new file mode 100644
index 00000000000..243496e075b
--- /dev/null
+++ b/net/mcast-tools/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: mcast-tools
+# Date created: 15 Sep 2005
+# Whom: suz
+#
+# $FreeBSD$
+#
+
+PORTNAME= mcast-tools
+PORTVERSION= 20050926
+PORTREVISION= 0
+CATEGORIES= net ipv6
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= mcast-tools
+
+MAINTAINER= suz@FreeBSD.org
+COMMENT= IPv6 multicast routing daemons and tools
+
+GNU_CONFIGURE= yes
+
+CONFIGURE_ARGS=
+CONFIGURE_ENV=
+
+MAN1= mcastread.1 mcastsend.1
+MAN5= pim6dd.conf.5 pim6sd.conf.5
+MAN8= mfc.8 mtrace6.8 pim6dd.8 pim6sd.8
+
+post-install:
+ ${INSTALL_DATA} ${WRKSRC}/pim6sd/pim6sd.conf.sample ${PREFIX}/etc
+ ${INSTALL_DATA} ${FILESDIR}/pim6dd.conf.sample ${PREFIX}/etc
+
+.include <bsd.port.mk>
diff --git a/net/mcast-tools/distinfo b/net/mcast-tools/distinfo
new file mode 100644
index 00000000000..d06d778caf2
--- /dev/null
+++ b/net/mcast-tools/distinfo
@@ -0,0 +1,2 @@
+MD5 (mcast-tools-20050926.tar.gz) = b02dc7f0842cf38df771d2aefd54ecc6
+SIZE (mcast-tools-20050926.tar.gz) = 457037
diff --git a/net/mcast-tools/files/patch-configure b/net/mcast-tools/files/patch-configure
new file mode 100644
index 00000000000..68b747aa01f
--- /dev/null
+++ b/net/mcast-tools/files/patch-configure
@@ -0,0 +1,19 @@
+--- configure.orig Tue Nov 22 00:31:28 2005
++++ configure Tue Nov 22 00:31:40 2005
+@@ -7357,7 +7357,7 @@
+ fi
+
+
+- ac_config_files="$ac_config_files Makefile mcastread/Makefile mcastsend/Makefile mfc/Makefile mtrace6/Makefile pim6dd/Makefile pim6sd/Makefile pmsft/Makefile"
++ ac_config_files="$ac_config_files Makefile mcastread/Makefile mcastsend/Makefile mfc/Makefile mtrace6/Makefile pim6dd/Makefile pim6sd/Makefile"
+
+ cat >confcache <<\_ACEOF
+ # This file is a shell script that caches the results of configure
+@@ -7915,7 +7915,6 @@
+ "mtrace6/Makefile" ) CONFIG_FILES="$CONFIG_FILES mtrace6/Makefile" ;;
+ "pim6dd/Makefile" ) CONFIG_FILES="$CONFIG_FILES pim6dd/Makefile" ;;
+ "pim6sd/Makefile" ) CONFIG_FILES="$CONFIG_FILES pim6sd/Makefile" ;;
+- "pmsft/Makefile" ) CONFIG_FILES="$CONFIG_FILES pmsft/Makefile" ;;
+ "depfiles" ) CONFIG_COMMANDS="$CONFIG_COMMANDS depfiles" ;;
+ "include/config.h" ) CONFIG_HEADERS="$CONFIG_HEADERS include/config.h" ;;
+ *) { { echo "$as_me:$LINENO: error: invalid argument: $ac_config_target" >&5
diff --git a/net/mcast-tools/files/pim6dd.conf.sample b/net/mcast-tools/files/pim6dd.conf.sample
new file mode 100644
index 00000000000..48bb588e51a
--- /dev/null
+++ b/net/mcast-tools/files/pim6dd.conf.sample
@@ -0,0 +1,3 @@
+# $FreeBSD: /tmp/pcvs/ports/net/mcast-tools/files/pim6dd.conf.sample,v 1.1 2005-11-21 22:33:50 suz Exp $
+#
+phyint stf0 disable
diff --git a/net/mcast-tools/pkg-descr b/net/mcast-tools/pkg-descr
new file mode 100644
index 00000000000..4caa185eb82
--- /dev/null
+++ b/net/mcast-tools/pkg-descr
@@ -0,0 +1,21 @@
+mcast-tools is a package containing IPv6-multicast routing daemons and tools,
+comprising the following programs.
+
+ - mcastread
+ an IPv6 multicast receiver
+
+ - mcastsend
+ an IPv6 multicast sender
+
+ - mfc
+ an IPv6 multicast routing daemon, which only supports static
+ multicast routing.
+
+ - pim6sd
+ an IPv6 multicast routing daemon, which supports PIM-SM
+ (Protocol Independent Multicast Sparse-Mode Version 2), and
+ PIM-SSM (Source-Specific Multicast using PIM-SM)
+
+ - pim6dd
+ an IPv6 multicast routing daemon, which supports PIM-DM
+ (Protocol Independent Multicast Dense-Mode Version 2)
diff --git a/net/mcast-tools/pkg-plist b/net/mcast-tools/pkg-plist
new file mode 100644
index 00000000000..6c788337cc3
--- /dev/null
+++ b/net/mcast-tools/pkg-plist
@@ -0,0 +1,8 @@
+etc/pim6sd.conf.sample
+etc/pim6dd.conf.sample
+bin/mtrace6
+bin/mcastread
+bin/mcastsend
+sbin/pim6dd
+sbin/pim6sd
+sbin/pim6stat
diff --git a/net/pim6dd/Makefile b/net/pim6dd/Makefile
deleted file mode 100644
index 1afced78d89..00000000000
--- a/net/pim6dd/Makefile
+++ /dev/null
@@ -1,44 +0,0 @@
-# New ports collection makefile for: pim6-sd
-# Date created: 2 Jun 2001
-# Whom: dwcjr
-#
-# $FreeBSD$
-#
-
-PORTNAME= pim6dd
-PORTVERSION= 20040819a
-PORTREVISION= 0
-CATEGORIES= net ipv6
-MASTER_SITES= ftp://ftp.kame.net/pub/kame/misc/
-
-MAINTAINER= suz@FreeBSD.org
-COMMENT= PIM for IPv6 dense mode daemon
-
-USE_REINPLACE= yes
-
-MAN5= pim6dd.conf.5
-MAN8= pim6dd.8
-MANCOMPRESSED= yes
-
-DOCS= LICENSE.mrouted LICENSE.pimd
-
-BUILD_WRKSRC= ${WRKSRC}/${PORTNAME}
-INSTALL_WRKSRC= ${BUILD_WRKSRC}
-
-post-patch:
-.for file in Makefile.inc pim6dd/pathnames.h pim6dd/pim6dd.8
- @${REINPLACE_CMD} -e 's./usr/local/v6.${PREFIX}.g' ${WRKSRC}/${file}
-.endfor
-
-post-install:
- ${INSTALL_DATA} ${FILESDIR}/pim6dd.conf ${PREFIX}/etc
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${PREFIX}/share/doc/${PORTNAME}
-.for file in ${DOCS}
- ${INSTALL_DATA} ${BUILD_WRKSRC}/${file} ${PREFIX}/share/doc/${PORTNAME}
- @${ECHO_CMD} share/doc/${PORTNAME}/${file} >>${TMPPLIST}
-.endfor
- @${ECHO_CMD} "@dirrm share/doc/${PORTNAME}" >>${TMPPLIST}
-.endif
-
-.include <bsd.port.mk>
diff --git a/net/pim6dd/distinfo b/net/pim6dd/distinfo
deleted file mode 100644
index d1599d855cc..00000000000
--- a/net/pim6dd/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-MD5 (pim6dd-20040819a.tar.gz) = c4dc74bdf9becc2fdc45a7241a48c706
-SIZE (pim6dd-20040819a.tar.gz) = 84580
diff --git a/net/pim6dd/files/pim6dd.conf b/net/pim6dd/files/pim6dd.conf
deleted file mode 100644
index 4a286173f6f..00000000000
--- a/net/pim6dd/files/pim6dd.conf
+++ /dev/null
@@ -1,3 +0,0 @@
-# $FreeBSD$
-#
-phyint stf0 disable
diff --git a/net/pim6dd/pkg-descr b/net/pim6dd/pkg-descr
deleted file mode 100644
index 004a9bac113..00000000000
--- a/net/pim6dd/pkg-descr
+++ /dev/null
@@ -1,2 +0,0 @@
-Pim6dd is an IPv6 multicast routing daemon, which supports PIMv2
-(Protocol Independent Multicast Version 2) dense mode for IPv6.
diff --git a/net/pim6dd/pkg-plist b/net/pim6dd/pkg-plist
deleted file mode 100644
index 2f29910d354..00000000000
--- a/net/pim6dd/pkg-plist
+++ /dev/null
@@ -1,2 +0,0 @@
-etc/pim6dd.conf
-sbin/pim6dd
diff --git a/net/pim6sd/files/patch-Makefile b/net/pim6sd/files/patch-Makefile
deleted file mode 100644
index e2e5f3aed86..00000000000
--- a/net/pim6sd/files/patch-Makefile
+++ /dev/null
@@ -1,17 +0,0 @@
---- pim6sd/mtrace6/Makefile.orig Tue Sep 23 20:09:10 2003
-+++ pim6sd/mtrace6/Makefile Wed Nov 24 19:00:05 2004
-@@ -77,8 +77,13 @@
- .if exists(${.CURDIR}/../../Makefile.opsys)
- .include "${.CURDIR}/../../Makefile.opsys"
- .endif
--
-+PREFIX=/usr/local
- BINDIR= $(PREFIX)/sbin
-+.if (${OPSYS} != NetBSD)
-+MANDIR= $(PREFIX)/man/man
-+.else
-+MANDIR= $(PREFIX)/man
-+.endif
- PROG= mtrace6
-
- BINOWN = root
diff --git a/net/pim6sd/files/patch-Makefile.inc b/net/pim6sd/files/patch-Makefile.inc
deleted file mode 100644
index 47162482b53..00000000000
--- a/net/pim6sd/files/patch-Makefile.inc
+++ /dev/null
@@ -1,7 +0,0 @@
---- Makefile.inc.orig Thu Aug 19 22:50:39 2004
-+++ Makefile.inc Thu Aug 19 22:50:47 2004
-@@ -6,3 +6,4 @@
- .else
- MANDIR= $(PREFIX)/man
- .endif
-+SUBDIR+= mtrace6
diff --git a/net/pim6sd/files/patch-pim6sd-Makefile b/net/pim6sd/files/patch-pim6sd-Makefile
deleted file mode 100644
index 5de80bde3e0..00000000000
--- a/net/pim6sd/files/patch-pim6sd-Makefile
+++ /dev/null
@@ -1,11 +0,0 @@
---- pim6sd/Makefile.orig Mon Jul 18 11:26:30 2005
-+++ pim6sd/Makefile Mon Jul 18 11:26:39 2005
-@@ -80,7 +80,7 @@
-
- BINDIR= $(PREFIX)/sbin
- PROG= pim6sd
--CFLAGS+=-DHAVE_STDARG_H -DHAVE_MLDV2
-+CFLAGS+=-DHAVE_STDARG_H
- LDADD+=-ly -ll
- SRCS= mld6.c mld6_proto.c\
- mld6v2.c mld6v2_proto.c\
diff --git a/net/pim6sd/files/patch-pim6sd-routesock.h b/net/pim6sd/files/patch-pim6sd-routesock.h
deleted file mode 100644
index 7087d7c0a75..00000000000
--- a/net/pim6sd/files/patch-pim6sd-routesock.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- pim6sd/routesock.h.orig Mon Jul 18 11:33:42 2005
-+++ pim6sd/routesock.h Mon Jul 18 11:33:54 2005
-@@ -49,6 +49,8 @@
- #ifndef ROUTESOCK_H
- #define ROUTESOCK_H
-
-+#include <sys/queue.h>
-+
- struct staticrt {
- struct sockaddr_in6 paddr;
- u_int8 plen;
diff --git a/net/pim6sd/files/pim6sd.conf b/net/pim6sd/files/pim6sd.conf
deleted file mode 100644
index b16525186ee..00000000000
--- a/net/pim6sd/files/pim6sd.conf
+++ /dev/null
@@ -1,4 +0,0 @@
-# $FreeBSD$
-#
-# Please comment out the following line, if you uses stf0
-#phyint stf0 disable;