aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorpgollucci <pgollucci@FreeBSD.org>2010-12-09 09:50:15 +0800
committerpgollucci <pgollucci@FreeBSD.org>2010-12-09 09:50:15 +0800
commit66b909c43ccb2641dafc306c5fbec083160eece3 (patch)
tree073459094556c0a431da576d17171d43b7dbc44c /net
parent3030624ac0647176df756ba268765f8604f5cbcc (diff)
downloadfreebsd-ports-graphics-66b909c43ccb2641dafc306c5fbec083160eece3.tar.gz
freebsd-ports-graphics-66b909c43ccb2641dafc306c5fbec083160eece3.tar.zst
freebsd-ports-graphics-66b909c43ccb2641dafc306c5fbec083160eece3.zip
When using nss_ldapd, the prompt of sshd will be "LDAP Password: "
instead of original "Password: ", which sometimes confuses some user who don't know what LDAP is. This patch adds an option to solve the problem. PR: ports/151261 Submitted by: Tz-Huan Huang <tzhuan@gmail.com> Approved by: maintainer timeout (melifaro@ipfw.ru ; 64 days)
Diffstat (limited to 'net')
-rw-r--r--net/nss_ldapd/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/net/nss_ldapd/Makefile b/net/nss_ldapd/Makefile
index aafc9e8305c..275e0d17cb2 100644
--- a/net/nss_ldapd/Makefile
+++ b/net/nss_ldapd/Makefile
@@ -26,7 +26,8 @@ NSLCD_SOCKET?= /var/run/nslcd.ctl
OPTIONS= NSS_COMPAT "Enable nss_ldap compatibility" on \
SASL "Enable SASL" off \
- PAM "Build pam_ldap" on
+ PAM "Build pam_ldap" on \
+ PROMPT "Display only Password: instaed of LDAP Password:" off
USERS= nslcd
GROUPS= nslcd
@@ -92,6 +93,11 @@ MAN5+= nslcd.conf.5
MAN8+= nslcd.8
.endif
+.if defined(WITH_PROMPT)
+post-patch:
+ @${REINPLACE_CMD} -e 's|i==0?"Password: ":"LDAP Password: "|"Password: "|' ${WRKSRC}/pam/pam.c
+.endif
+
post-extract:
@${REINPLACE_CMD} -e 's/\(INSTALL_\)\(.*\)) -D /\1\2) /' ${WRKSRC}/Makefile.in ${WRKSRC}/nss/Makefile.in
@${REINPLACE_CMD} -e 's/shadow.$$(OBJEXT)/shadow.$$(OBJEXT) bsdnss.$$(OBJEXT)/;s/shadow\.c/shadow.c bsdnss.c/;s/exports\.linux/exports.freebsd/' ${WRKSRC}/nss/Makefile.in