aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2016-11-16 08:35:05 +0800
committerlinimon <linimon@FreeBSD.org>2016-11-16 08:35:05 +0800
commit6cb8f21dd49f7c144b72549ca145499738b53733 (patch)
tree1cfdd475086643c630cf73b39b72125a1e117670 /net
parentda9429c2e6b224b4f4dbf9aa80bd25f64a65a4d3 (diff)
downloadfreebsd-ports-graphics-6cb8f21dd49f7c144b72549ca145499738b53733.tar.gz
freebsd-ports-graphics-6cb8f21dd49f7c144b72549ca145499738b53733.tar.zst
freebsd-ports-graphics-6cb8f21dd49f7c144b72549ca145499738b53733.zip
Mark as broken on various tier-2 archs.
While here, pet portlint. Approved by: portmgr (tier-2 blanket)
Diffstat (limited to 'net')
-rw-r--r--net/aoe/Makefile3
-rw-r--r--net/py-libnet/Makefile5
2 files changed, 6 insertions, 2 deletions
diff --git a/net/aoe/Makefile b/net/aoe/Makefile
index ddde1d024d4..95ca7cfb31b 100644
--- a/net/aoe/Makefile
+++ b/net/aoe/Makefile
@@ -18,6 +18,9 @@ KMODDIR= ${PREFIX}/lib/aoe
USE_RC_SUBR= aoe
+BROKEN_aarch64= Fails to compile: error: redefinition of frame
+BROKEN_sparc64= Fails to compile: error: redefinition of frame
+
do-install:
${INSTALL_KLD} ${WRKSRC}/aoe.ko ${STAGEDIR}${PREFIX}/lib/aoe
${INSTALL_MAN} ${WRKDIR}/aoe.4 ${STAGEDIR}${PREFIX}/man/man4/
diff --git a/net/py-libnet/Makefile b/net/py-libnet/Makefile
index cbdd057ff65..0a6e6d05b30 100644
--- a/net/py-libnet/Makefile
+++ b/net/py-libnet/Makefile
@@ -13,8 +13,6 @@ COMMENT= Python module for the libnet packet construction library
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/COPYING
-BROKEN_powerpc64= Does not build
-
LIB_DEPENDS= libnet.so:net/libnet
USES= python
@@ -30,6 +28,9 @@ EXAMPLESDIR= ${PREFIX}/share/examples/py-${PORTNAME}
OPTIONS_DEFINE= EXAMPLES
OSVER= uname -r
+BROKEN_aarch64= Fails to install: lib.freebsd-11.0-RELEASE-p1-aarch64-2.7/libnet.so: No such file or directory
+BROKEN_powerpc64= Does not build
+
post-patch:
@${REINPLACE_CMD} 's|/usr/local|${LOCALBASE}|' ${WRKSRC}/setup.py