aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2007-04-16 06:02:20 +0800
committermarcus <marcus@FreeBSD.org>2007-04-16 06:02:20 +0800
commit7de73bfc7b6de3e63f72b0a42ee88c3a146c9861 (patch)
treee7a605618d8247a787c531e1b85456ef04ccd95f /net
parent00e0671c2e01684b1f3aa339b6580822d9feb736 (diff)
downloadfreebsd-ports-graphics-7de73bfc7b6de3e63f72b0a42ee88c3a146c9861.tar.gz
freebsd-ports-graphics-7de73bfc7b6de3e63f72b0a42ee88c3a146c9861.tar.zst
freebsd-ports-graphics-7de73bfc7b6de3e63f72b0a42ee88c3a146c9861.zip
Add avahi-qt3, the Qt3 bindings to the avahi mDNS system.
Requested by: bms
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/avahi-qt3/Makefile48
-rw-r--r--net/avahi-qt3/pkg-descr3
-rw-r--r--net/avahi-qt3/pkg-plist7
4 files changed, 59 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 62e9df5543e..324e951dc0d 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -38,6 +38,7 @@
SUBDIR += astfax
SUBDIR += atmsupport
SUBDIR += avahi
+ SUBDIR += avahi-qt3
SUBDIR += avahi-sharp
SUBDIR += b2bua
SUBDIR += balance
diff --git a/net/avahi-qt3/Makefile b/net/avahi-qt3/Makefile
new file mode 100644
index 00000000000..45e0bf2904b
--- /dev/null
+++ b/net/avahi-qt3/Makefile
@@ -0,0 +1,48 @@
+# New ports collection makefile for: avahi-qt3
+# Date created: 12 April 2007
+# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTREVISION= 0
+CATEGORIES= net
+PKGNAMESUFFIX= -qt3
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= Qt 3 bindings to the Avahi mDNS system
+
+LIB_DEPENDS= avahi-common.3:${PORTSDIR}/net/avahi
+
+MASTERDIR= ${.CURDIR}/../avahi
+BUILD_WRKSRC= ${WRKSRC}/avahi-qt
+INSTALL_WRKSRC= ${BUILD_WRKSRC}
+DESCR= ${.CURDIR}/pkg-descr
+PLIST= ${.CURDIR}/pkg-plist
+
+AVAHI_SLAVE= yes
+
+USE_GNOME= gnomehack gnometarget ltverhack
+USE_QT_VER= 3
+CONFIGURE_ARGS= --disable-python \
+ --disable-mono \
+ --disable-monodoc \
+ --disable-gtk \
+ --enable-qt3 \
+ --disable-qt4 \
+ --localstatedir=/var \
+ --disable-doxygen-docs \
+ --disable-xml-docs \
+ --disable-doxygen-dot \
+ --with-dbus-system-address=unix:path=/var/run/dbus/system_bus_socket \
+ --with-distro=freebsd
+
+post-build:
+ @cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${GMAKE} \
+ ${MAKE_FLAGS} Makefile ${MAKE_ARGS} avahi-qt3.pc
+
+post-install:
+ ${MKDIR} ${PREFIX}/libdata/pkgconfig
+ ${INSTALL_DATA} ${WRKSRC}/avahi-qt3.pc ${PREFIX}/libdata/pkgconfig
+
+.include "${MASTERDIR}/Makefile"
diff --git a/net/avahi-qt3/pkg-descr b/net/avahi-qt3/pkg-descr
new file mode 100644
index 00000000000..5ed735799b0
--- /dev/null
+++ b/net/avahi-qt3/pkg-descr
@@ -0,0 +1,3 @@
+Qt 3 bindings to the avahi mDNS service discovery system.
+
+WWW: http://www.avahi.org/
diff --git a/net/avahi-qt3/pkg-plist b/net/avahi-qt3/pkg-plist
new file mode 100644
index 00000000000..3025b57c0c9
--- /dev/null
+++ b/net/avahi-qt3/pkg-plist
@@ -0,0 +1,7 @@
+include/avahi-qt3/qt-watch.h
+lib/libavahi-qt3.a
+lib/libavahi-qt3.la
+lib/libavahi-qt3.so
+lib/libavahi-qt3.so.1
+libdata/pkgconfig/avahi-qt3.pc
+@dirrm include/avahi-qt3