aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorkuriyama <kuriyama@FreeBSD.org>2003-07-06 21:19:36 +0800
committerkuriyama <kuriyama@FreeBSD.org>2003-07-06 21:19:36 +0800
commit81d817d35efa8c7c866900a9e955a6b9dbb2f994 (patch)
treee481158354733d67d94b138b5188f0fcc75ef46c /net
parente0d9e142a9b2d07b3db9f3727fa1fc724d22619c (diff)
downloadfreebsd-ports-graphics-81d817d35efa8c7c866900a9e955a6b9dbb2f994.tar.gz
freebsd-ports-graphics-81d817d35efa8c7c866900a9e955a6b9dbb2f994.tar.zst
freebsd-ports-graphics-81d817d35efa8c7c866900a9e955a6b9dbb2f994.zip
Make this port working on old perls.
Submitted by: Mathieu Arnold <m@absolight.net> PR: ports/52330 Approved by: Clement Laforet <sheepkiller@cultdeadsheep.org> (maintainer)
Diffstat (limited to 'net')
-rw-r--r--net/p5-DNS-Zone/Makefile13
-rw-r--r--net/p5-DNS-Zone/pkg-descr3
-rw-r--r--net/p5-DNS-Zone/pkg-plist24
3 files changed, 19 insertions, 21 deletions
diff --git a/net/p5-DNS-Zone/Makefile b/net/p5-DNS-Zone/Makefile
index dc597ec254e..fa5672fca68 100644
--- a/net/p5-DNS-Zone/Makefile
+++ b/net/p5-DNS-Zone/Makefile
@@ -18,7 +18,10 @@ COMMENT= DNS::Zone is set of perl modules for name service zone files
PERL_CONFIGURE= yes
-DOCSDIR= ${PREFIX}/share/doc/p5-DNS-Zone
+post-patch:
+ ${FIND} ${WRKSRC} -name '*.pm' -o -name '*.t' -o -name '*.PL' | \
+ ${XARGS} ${PERL} -pi -e '$$_="" if /^use 5/;' \
+ -e '$$_="" if /(use|no) warnings/;'
post-install:
.if !defined(NOPORTDOCS)
@@ -26,10 +29,4 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
.endif
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500600
-IGNORE= "Perl 5.6 or newer required. Install lang/perl5 or lang/perl5.8 and try again."
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/p5-DNS-Zone/pkg-descr b/net/p5-DNS-Zone/pkg-descr
index 305d1af4de1..19c3780bbd8 100644
--- a/net/p5-DNS-Zone/pkg-descr
+++ b/net/p5-DNS-Zone/pkg-descr
@@ -5,5 +5,6 @@ The modules origin is the ZoneMaster project which make heavy
use of the module for comprehensive zone file management. Go to
http://www.zonemaster.org for further information.
-WWW: http://search.cpan.org/author/WOLF/
+WWW: http://search.cpan.org/dist/DNS-Zone/
+
Author: Andy Wolf <zonemaster@users.sourceforge.net>
diff --git a/net/p5-DNS-Zone/pkg-plist b/net/p5-DNS-Zone/pkg-plist
index 04e97e8cc68..994ca385091 100644
--- a/net/p5-DNS-Zone/pkg-plist
+++ b/net/p5-DNS-Zone/pkg-plist
@@ -1,12 +1,12 @@
-lib/perl5/site_perl/%%PERL_VER%%/mach/auto/DNS-Zone/.packlist
-lib/perl5/site_perl/%%PERL_VER%%/DNS/Zone.pm
-lib/perl5/site_perl/%%PERL_VER%%/DNS/Zone/File.pm
-lib/perl5/site_perl/%%PERL_VER%%/DNS/Zone/Label.pm
-lib/perl5/site_perl/%%PERL_VER%%/DNS/Zone/Record.pm
-lib/perl5/site_perl/%%PERL_VER%%/DNS/Zone/File/Default.pm
-%%PORTDOCS%%share/doc/p5-DNS-Zone/README
-@dirrm lib/perl5/site_perl/%%PERL_VER%%/mach/auto/DNS-Zone
-@dirrm lib/perl5/site_perl/%%PERL_VER%%/DNS/Zone/File
-@dirrm lib/perl5/site_perl/%%PERL_VER%%/DNS/Zone
-@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/DNS 2>/dev/null || true
-%%PORTDOCS%%@dirrm share/doc/p5-DNS-Zone
+%%SITE_PERL%%/DNS/Zone.pm
+%%SITE_PERL%%/DNS/Zone/File.pm
+%%SITE_PERL%%/DNS/Zone/File/Default.pm
+%%SITE_PERL%%/DNS/Zone/Label.pm
+%%SITE_PERL%%/DNS/Zone/Record.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/DNS-Zone/.packlist
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/DNS-Zone
+@dirrm %%SITE_PERL%%/DNS/Zone/File
+@dirrm %%SITE_PERL%%/DNS/Zone
+@unexec rmdir %D/%%SITE_PERL%%/DNS 2>/dev/null || true