aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorjeh <jeh@FreeBSD.org>2000-10-29 20:23:52 +0800
committerjeh <jeh@FreeBSD.org>2000-10-29 20:23:52 +0800
commit8a2f2be1513eba203137f83b76c0f58ea2e92eae (patch)
tree7668373da9687c45456062a911d2e87fc0be5461 /net
parentf3afb5e287c0faf4c1e1f2e7312125a301211728 (diff)
downloadfreebsd-ports-graphics-8a2f2be1513eba203137f83b76c0f58ea2e92eae.tar.gz
freebsd-ports-graphics-8a2f2be1513eba203137f83b76c0f58ea2e92eae.tar.zst
freebsd-ports-graphics-8a2f2be1513eba203137f83b76c0f58ea2e92eae.zip
New Port: net/tcpcat
A simple utility for sending/receiving data over a TCP or a Unix-domain socket PR: 22081 Submitted by: Peter Pentchev <roam@orbitel.bg>
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/tcpcat/Makefile18
-rw-r--r--net/tcpcat/distinfo1
-rw-r--r--net/tcpcat/pkg-comment1
-rw-r--r--net/tcpcat/pkg-descr17
-rw-r--r--net/tcpcat/pkg-plist1
6 files changed, 39 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 07f2f53c5e6..30ba7707cc8 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -245,6 +245,7 @@
SUBDIR += sup
SUBDIR += svnc
SUBDIR += tac_plus4
+ SUBDIR += tcpcat
SUBDIR += tcpflow
SUBDIR += tcpillust
SUBDIR += tcpmssd
diff --git a/net/tcpcat/Makefile b/net/tcpcat/Makefile
new file mode 100644
index 00000000000..b45667a1ff2
--- /dev/null
+++ b/net/tcpcat/Makefile
@@ -0,0 +1,18 @@
+# New ports collection makefile for: tcpcat
+# Date created: 18 October 2000
+# Whom: roam@orbitel.bg
+#
+# $FreeBSD$
+#
+
+PORTNAME= tcpcat
+PORTVERSION= 1.0.1
+CATEGORIES= net
+MASTER_SITES= http://www.gusnet.cx/proj/tcpcat/
+
+MAINTAINER= roam@orbitel.bg
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+
+.include <bsd.port.mk>
diff --git a/net/tcpcat/distinfo b/net/tcpcat/distinfo
new file mode 100644
index 00000000000..a4c4e13cf97
--- /dev/null
+++ b/net/tcpcat/distinfo
@@ -0,0 +1 @@
+MD5 (tcpcat-1.0.1.tar.gz) = 298a6cfa559b3e13ca87fa13fbd8af28
diff --git a/net/tcpcat/pkg-comment b/net/tcpcat/pkg-comment
new file mode 100644
index 00000000000..008b0491fd8
--- /dev/null
+++ b/net/tcpcat/pkg-comment
@@ -0,0 +1 @@
+A simple utility for sending/receiving data over a TCP or a Unix-domain socket
diff --git a/net/tcpcat/pkg-descr b/net/tcpcat/pkg-descr
new file mode 100644
index 00000000000..dc29abba378
--- /dev/null
+++ b/net/tcpcat/pkg-descr
@@ -0,0 +1,17 @@
+From the tcpcat README:
+
+Tcpcat is a simple program that is like `cat' but it works over tcp streams
+to allow you to cat from one host to another.
+
+The host common way to use this program whould be something like this:
+on host a: $ tcpcat -l 93255 | gzip -dc | tar xvf -
+on host b: $ tcpcat -h hosta:93255 file.tar.gz
+
+Another good use for this program is debugging network stuff. When debugging
+a newtork client or server you can pipe the output of tcpcat to a hex dump
+(I recomend xxd which comes with vim). Also it can act as a crude telnet server
+when invoded with --listen, --input, and --output, this mode is quite useful
+for network program debugging as well.
+
+Author: Angus Mackay <amackay@gusnet.cx>
+WWW: http://www.gusnet.cx/proj/tcpcat/
diff --git a/net/tcpcat/pkg-plist b/net/tcpcat/pkg-plist
new file mode 100644
index 00000000000..429dba6bcf1
--- /dev/null
+++ b/net/tcpcat/pkg-plist
@@ -0,0 +1 @@
+bin/tcpcat