aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorarchie <archie@FreeBSD.org>1999-05-01 03:31:17 +0800
committerarchie <archie@FreeBSD.org>1999-05-01 03:31:17 +0800
commit8f41f49e8c846da6dc2ff174002e232a9a93f690 (patch)
tree263df00ab0beff7f37542a40dbc829b3fdee70e3 /net
parent70132bf60134e6e6d6ffa1785849eeee56946c36 (diff)
downloadfreebsd-ports-graphics-8f41f49e8c846da6dc2ff174002e232a9a93f690.tar.gz
freebsd-ports-graphics-8f41f49e8c846da6dc2ff174002e232a9a93f690.tar.zst
freebsd-ports-graphics-8f41f49e8c846da6dc2ff174002e232a9a93f690.zip
Unbreak egcs compilation by removing -Werror flag instead of fixing all
the warnings (it's easier, and a couple of the fixes were incorrect anyway). The next version of mpd will have these warnings fixed, at which time -Werror may be restored... though doing so is debatable in the first place.
Diffstat (limited to 'net')
-rw-r--r--net/mpd/files/patch-aa11
-rw-r--r--net/mpd/files/patch-ab15
2 files changed, 11 insertions, 15 deletions
diff --git a/net/mpd/files/patch-aa b/net/mpd/files/patch-aa
new file mode 100644
index 00000000000..e98cd987f30
--- /dev/null
+++ b/net/mpd/files/patch-aa
@@ -0,0 +1,11 @@
+--- src/Makefile.orig Thu Feb 25 22:18:47 1999
++++ src/Makefile Fri Apr 30 12:24:58 1999
+@@ -69,7 +69,7 @@
+
+ MPD_VERSION!= echo -n "${VERSION} (`id -un`@`uname -n` `date +'%R %v'`)"
+
+-COPTS+= -g -Wall -Wmissing-prototypes -Wnested-externs -Werror
++COPTS+= -g -Wall -Wmissing-prototypes -Wnested-externs
+ COPTS+= -DPATH_CONF_DIR=\"${MPD_CONF_DIR}\"
+ COPTS+= -DSYSLOG_FACILITY=${SYSLOG_FACILITY}
+ COPTS+= -DMPD_VERSION='"${MPD_VERSION}"'
diff --git a/net/mpd/files/patch-ab b/net/mpd/files/patch-ab
deleted file mode 100644
index 4c9424605c7..00000000000
--- a/net/mpd/files/patch-ab
+++ /dev/null
@@ -1,15 +0,0 @@
---- src/lcp.c.orig Fri Apr 30 22:52:21 1999
-+++ src/lcp.c Sun Apr 25 23:34:35 1999
-@@ -856,10 +856,12 @@
- if (bogus || !supported)
- {
- if (mode == MODE_REQ)
-+ {
- if (Acceptable(&lnk->conf.options, LINK_CONF_CHAP))
- FsmNak(fp, &chapNak);
- else if (Acceptable(&lnk->conf.options, LINK_CONF_PAP))
- FsmNak(fp, &papNak);
-+ }
- else
- FsmRej(fp, opt);
- break;