aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorobrien <obrien@FreeBSD.org>1999-10-25 16:08:32 +0800
committerobrien <obrien@FreeBSD.org>1999-10-25 16:08:32 +0800
commitad23a35cb8e8cfbbcb7d1317b0fa0d87cd4f0184 (patch)
treee4da326f83d9793a584cdd32b214244d288b2213 /net
parent1370463252b94c43e1f97e355a244705735686c1 (diff)
downloadfreebsd-ports-graphics-ad23a35cb8e8cfbbcb7d1317b0fa0d87cd4f0184.tar.gz
freebsd-ports-graphics-ad23a35cb8e8cfbbcb7d1317b0fa0d87cd4f0184.tar.zst
freebsd-ports-graphics-ad23a35cb8e8cfbbcb7d1317b0fa0d87cd4f0184.zip
Use the proper $$ which gives a single literal `$' in a Makefile rather
than `\$' which is proper for a shell script, which this isn't (even it if they are shell commands).
Diffstat (limited to 'net')
-rw-r--r--net/tdetect/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/net/tdetect/Makefile b/net/tdetect/Makefile
index 55bacf9e3d4..72018a1293d 100644
--- a/net/tdetect/Makefile
+++ b/net/tdetect/Makefile
@@ -33,7 +33,7 @@ post-install:
${ECHO} "Installing ${PREFIX}/etc/rc.d/tdetect.sh startup file."; \
${ECHO} "#!/bin/sh" > ${PREFIX}/etc/rc.d/tdetect.sh; \
${ECHO} "ETHERNETDEV=ed0" >> ${PREFIX}/etc/rc.d/tdetect.sh; \
- ${ECHO} '[ -x ${PREFIX}/sbin/tdetect ] && ${PREFIX}/sbin/tdetect \$ETHERNETDEV && ${ECHO} -n " tdetect"' >> ${PREFIX}/etc/rc.d/tdetect.sh; \
+ ${ECHO} '[ -x ${PREFIX}/sbin/tdetect ] && ${PREFIX}/sbin/tdetect $$ETHERNETDEV && ${ECHO} -n " tdetect"' >> ${PREFIX}/etc/rc.d/tdetect.sh; \
${CHMOD} 750 ${PREFIX}/etc/rc.d/tdetect.sh; \
${ECHO} ''; \
${ECHO} 'IMPORTANT edit ${PREFIX}/etc/rc.d/tdetect.sh and set "ETHERNETDEV" to'; \