aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authordwcjr <dwcjr@FreeBSD.org>2001-09-01 04:09:58 +0800
committerdwcjr <dwcjr@FreeBSD.org>2001-09-01 04:09:58 +0800
commitb0c465a7f8afb611021d8624ab17e2a1c27d4b83 (patch)
treef5d25e72be616aed4638f6d3e7df53399ffe051f /net
parent3578267f8ab619186303c9b8fd2e48b03a8859f9 (diff)
downloadfreebsd-ports-graphics-b0c465a7f8afb611021d8624ab17e2a1c27d4b83.tar.gz
freebsd-ports-graphics-b0c465a7f8afb611021d8624ab17e2a1c27d4b83.tar.zst
freebsd-ports-graphics-b0c465a7f8afb611021d8624ab17e2a1c27d4b83.zip
Workaround for FreeBSD > 4.2
Change maintainer's email PR: 30133 Submitted by: maintainer
Diffstat (limited to 'net')
-rw-r--r--net/iplog/Makefile3
-rw-r--r--net/iplog/files/patch-ae24
2 files changed, 26 insertions, 1 deletions
diff --git a/net/iplog/Makefile b/net/iplog/Makefile
index 526fa5e6aad..6994ebcfe0a 100644
--- a/net/iplog/Makefile
+++ b/net/iplog/Makefile
@@ -7,12 +7,13 @@
PORTNAME= iplog
PORTVERSION= 2.2.3
+PORTREVISION= 1
CATEGORIES= net security
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
http://misc.ojnk.net/~odin/stuff/
MASTER_SITE_SUBDIR= ojnk
-MAINTAINER= ust@cert.siemens.de
+MAINTAINER= udo.schweigert@siemens.com
USE_GMAKE= yes
GNU_CONFIGURE= yes
diff --git a/net/iplog/files/patch-ae b/net/iplog/files/patch-ae
new file mode 100644
index 00000000000..4a87bef4a53
--- /dev/null
+++ b/net/iplog/files/patch-ae
@@ -0,0 +1,24 @@
+--- src/iplog_pcap.c.orig Mon Jan 1 17:02:14 2001
++++ src/iplog_pcap.c Mon Aug 27 16:38:50 2001
+@@ -211,6 +211,7 @@
+ u_char fstring[1024], *temp, errbuf[PCAP_ERRBUF_SIZE];
+ struct bpf_program filt;
+ u_int i = 0;
++ int b = 1;
+
+ pdata->pd =
+ pcap_open_live(pdata->name, SNAPLEN, opt_enabled(PROMISC), 0, errbuf);
+@@ -229,6 +230,13 @@
+ pcap_close(pdata->pd);
+ return (-1);
+ }
++
++#ifdef __FreeBSD__
++#include <osreldate.h>
++#if __FreeBSD_version >= 420001
++ ioctl(pcap_fileno(pdata->pd), BIOCIMMEDIATE, &b);
++#endif
++#endif
+
+ #ifdef __linux__
+ /*