aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2006-03-19 19:56:35 +0800
committerpav <pav@FreeBSD.org>2006-03-19 19:56:35 +0800
commitb59224ee3a3ef84257fe8c6b29ecbb9fe0ee51fe (patch)
tree8d047cdc4630ddf5f3b5159d6f8633bb3d3571ec /net
parent5e97016be9d47e40960a3a1ec0a4592e991a34a9 (diff)
downloadfreebsd-ports-graphics-b59224ee3a3ef84257fe8c6b29ecbb9fe0ee51fe.tar.gz
freebsd-ports-graphics-b59224ee3a3ef84257fe8c6b29ecbb9fe0ee51fe.tar.zst
freebsd-ports-graphics-b59224ee3a3ef84257fe8c6b29ecbb9fe0ee51fe.zip
- Do not hardcode -lpthread
Reported by: krismail
Diffstat (limited to 'net')
-rw-r--r--net/tintin++-devel/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/net/tintin++-devel/Makefile b/net/tintin++-devel/Makefile
index 4c07968dfc9..a2bda3b252f 100644
--- a/net/tintin++-devel/Makefile
+++ b/net/tintin++-devel/Makefile
@@ -32,6 +32,9 @@ CFLAGS+= -I ${LOCALBASE}/include
MAKE_ENV+= LIBS="-L${LOCALBASE}/lib"
.endif
+post-patch:
+ @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|' ${WRKSRC}/Makefile.in
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/tt++ ${PREFIX}/bin
.ifndef NOPORTDOCS