aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorobrien <obrien@FreeBSD.org>2000-08-09 17:23:43 +0800
committerobrien <obrien@FreeBSD.org>2000-08-09 17:23:43 +0800
commitbc323c62b07dde4c6a37c0d1cd869191247b357c (patch)
treefbeda47c75299a76bddd5fd8a2cee3086e1a0262 /net
parentdf99232b49f768257c4d7bd6fe278f93b2af4a07 (diff)
downloadfreebsd-ports-graphics-bc323c62b07dde4c6a37c0d1cd869191247b357c.tar.gz
freebsd-ports-graphics-bc323c62b07dde4c6a37c0d1cd869191247b357c.tar.zst
freebsd-ports-graphics-bc323c62b07dde4c6a37c0d1cd869191247b357c.zip
Update to version 1.38.
Reported by: Chris D. Faulhaber <jedgar@fxp.org>
Diffstat (limited to 'net')
-rw-r--r--net/ngrep/Makefile4
-rw-r--r--net/ngrep/distinfo2
-rw-r--r--net/ngrep/files/patch-ngrep.c20
3 files changed, 7 insertions, 19 deletions
diff --git a/net/ngrep/Makefile b/net/ngrep/Makefile
index 276101f485d..facc419788c 100644
--- a/net/ngrep/Makefile
+++ b/net/ngrep/Makefile
@@ -7,9 +7,9 @@
#
PORTNAME= ngrep
-PORTVERSION= 1.35
+PORTVERSION= 1.38
CATEGORIES= net security
-MASTER_SITES= http://www.packetfactory.net/ngrep/
+MASTER_SITES= http://www.packetfactory.net/Projects/ngrep/
MAINTAINER= obrien@FreeBSD.org
diff --git a/net/ngrep/distinfo b/net/ngrep/distinfo
index f3541c1e25d..79f326c89e9 100644
--- a/net/ngrep/distinfo
+++ b/net/ngrep/distinfo
@@ -1 +1 @@
-MD5 (ngrep-1.35.tar.gz) = 61a6312f475a3b7f2ea32b095bc7696c
+MD5 (ngrep-1.38.tar.gz) = adff63845df54eb40ef48f16664e4344
diff --git a/net/ngrep/files/patch-ngrep.c b/net/ngrep/files/patch-ngrep.c
index 1310923e3c8..2840f69190d 100644
--- a/net/ngrep/files/patch-ngrep.c
+++ b/net/ngrep/files/patch-ngrep.c
@@ -1,19 +1,7 @@
---- ngrep.c.orig Fri Oct 22 05:21:26 1999
-+++ ngrep.c Mon Jan 31 12:58:36 2000
-@@ -59,6 +59,7 @@
- int link_offset;
- pcap_t *pd;
-
+--- ngrep.c.orig Mon Jun 26 12:52:50 2000
++++ ngrep.c Wed Aug 9 02:16:59 2000
+@@ -50,0 +51 @@
+extern FILE *yyin;
-
- int main(int argc, char **argv) {
- char c;
-@@ -141,7 +142,7 @@
- free(filter);
- filter = get_filter(&argv[optind-1]);
-
+@@ -199 +200 @@
- PCAP_RESTART();
+ PCAP_RESTART(yyin);
- if (pcap_compile(pd,&pcapfilter,filter,0,mask.s_addr)) {
- pcap_perror(pd,"pcap compile");
- exit(-1);