aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2007-03-19 13:14:07 +0800
committermarcus <marcus@FreeBSD.org>2007-03-19 13:14:07 +0800
commite83248f2b323aa90dfea75471b86ccc444a80f88 (patch)
treef4fc2dbabf96cb67c502479d9fc13f40bf0d0108 /net
parent52dd0c5de1d6a7165dc355ecf161f52bb7dbbfda (diff)
downloadfreebsd-ports-graphics-e83248f2b323aa90dfea75471b86ccc444a80f88.tar.gz
freebsd-ports-graphics-e83248f2b323aa90dfea75471b86ccc444a80f88.tar.zst
freebsd-ports-graphics-e83248f2b323aa90dfea75471b86ccc444a80f88.zip
Presenting GNOME 2.18 for FreeBSD. GNOME 2.18 is a departure from recent GNOME
releases in that it focuses more on stability and functionality than on new features. Not that it doesn't have its share of new and exciting items. See http://www.gnome.org/start/2.18/ for all the goodies in this release. GNOME 2.18 for FreeBSD would not have been possible without the hard work of the FreeBSD GNOME Team and our intrepid band of testers including J. W. Ballantine, Pawel Worach, Yasuda Keisuke, Pascal Hofstee, miwi, Yoshihiro Ota, Vladimir Grebenschikov, Jukka A. Ukkonen, Phillip Neumann, Franz Klammer, and Neal Delmonico.
Diffstat (limited to 'net')
-rw-r--r--net/gnome-nettool/Makefile4
-rw-r--r--net/gnome-nettool/distinfo6
-rw-r--r--net/gnome-nettool/files/patch-src_info.c29
-rw-r--r--net/gnome-nettool/pkg-plist24
-rw-r--r--net/vino/Makefile5
-rw-r--r--net/vino/distinfo6
-rw-r--r--net/vino/files/patch-server_vino-prefs.c15
7 files changed, 37 insertions, 52 deletions
diff --git a/net/gnome-nettool/Makefile b/net/gnome-nettool/Makefile
index 5dbad65a7eb..c4fcab40ffc 100644
--- a/net/gnome-nettool/Makefile
+++ b/net/gnome-nettool/Makefile
@@ -3,11 +3,11 @@
# Whom: Adam Weinberger <adamw@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports/net/gnome-nettool/Makefile,v 1.32 2006/09/05 07:41:18 marcus Exp $
+# $MCom: ports/net/gnome-nettool/Makefile,v 1.35 2007/03/13 12:41:51 ahze Exp $
#
PORTNAME= gnome-nettool
-PORTVERSION= 2.16.0
+PORTVERSION= 2.18.0
PORTEPOCH= 1
CATEGORIES= net gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
diff --git a/net/gnome-nettool/distinfo b/net/gnome-nettool/distinfo
index c310ad7944e..9adbfe2e973 100644
--- a/net/gnome-nettool/distinfo
+++ b/net/gnome-nettool/distinfo
@@ -1,3 +1,3 @@
-MD5 (gnome2/gnome-nettool-2.16.0.tar.bz2) = 58d9171efdf368910934fb71194763eb
-SHA256 (gnome2/gnome-nettool-2.16.0.tar.bz2) = 6e3d1f1ff86622ef4e39c99a470e03ab316a76eb0f66f953eebd12c2621f4be7
-SIZE (gnome2/gnome-nettool-2.16.0.tar.bz2) = 501870
+MD5 (gnome2/gnome-nettool-2.18.0.tar.bz2) = 596616cf631b5bc9ec0c873208ccfce9
+SHA256 (gnome2/gnome-nettool-2.18.0.tar.bz2) = 348b6c0f0c7d58df1514f87956e6987fcccc418d1cfea98a1f3a1b84e4d60e57
+SIZE (gnome2/gnome-nettool-2.18.0.tar.bz2) = 511010
diff --git a/net/gnome-nettool/files/patch-src_info.c b/net/gnome-nettool/files/patch-src_info.c
index 7faf5e433c9..74eb698a466 100644
--- a/net/gnome-nettool/files/patch-src_info.c
+++ b/net/gnome-nettool/files/patch-src_info.c
@@ -1,5 +1,5 @@
---- src/info.c.orig Mon Apr 3 15:41:33 2006
-+++ src/info.c Sun Apr 23 21:57:39 2006
+--- src/info.c.orig Fri Dec 1 10:36:15 2006
++++ src/info.c Mon Dec 18 17:32:19 2006
@@ -20,6 +20,10 @@
#include <gtk/gtk.h>
#include <glib/gi18n.h>
@@ -76,7 +76,7 @@
(*iface) = g_strdup_printf ("%s (%s)", _(info_iface_desc[i].name), dev_name);
if (info_iface_desc[i].pixbuf == NULL) {
path = g_build_filename (PIXMAPS_DIR, info_iface_desc[i].icon, NULL);
-@@ -217,38 +260,87 @@ info_nic_update_stats (gpointer data)
+@@ -218,38 +261,87 @@ info_nic_update_stats (gpointer data)
gchar tx[10], tx_error[10], tx_drop[10], tx_ovr[10];
*/
gchar iface[30]; /*, flags[30]; */
@@ -170,7 +170,7 @@
if (g_ascii_strcasecmp (iface, text) == 0) {
/*
-@@ -276,7 +368,9 @@ info_nic_update_stats (gpointer data)
+@@ -277,7 +369,9 @@ info_nic_update_stats (gpointer data)
}
g_io_channel_unref (io);
@@ -181,10 +181,10 @@
return TRUE;
}
-@@ -405,8 +499,20 @@ info_get_nic_information (const gchar *n
- InfoIpAddr *ip;
- gint flags;
+@@ -425,8 +519,19 @@ info_get_nic_information (const gchar *n
+ #ifdef __linux__
mii_data_result data;
+ #endif
+#ifdef __FreeBSD__
+ gint hwmib[6];
+ size_t hwlen;
@@ -199,21 +199,10 @@
+ g_warning ("getifaddrs failed: %s", g_strerror (errno));
+ goto fail;
+ }
-+ memset (&data, 0, sizeof (data));
for (ifr6 = ifa0; ifr6; ifr6 = ifr6->ifa_next) {
if (strcmp (ifr6->ifa_name, nic) != 0) {
-@@ -452,7 +558,9 @@ info_get_nic_information (const gchar *n
- ifc.ifc_req = (struct ifreq *) buf;
- ioctl (sockfd, SIOCGIFCONF, &ifc);
-
-+#if defined(__linux__)
- data = mii_get_basic (nic);
-+#endif /* defined(__linux__) */
-
- for (ptr = buf; ptr < buf + ifc.ifc_len;) {
- ifr = (struct ifreq *) ptr;
-@@ -483,6 +591,45 @@ info_get_nic_information (const gchar *n
+@@ -510,6 +615,45 @@ info_get_nic_information (const gchar *n
(int) ((guchar *) &ifrcopy.ifr_hwaddr.sa_data)[3],
(int) ((guchar *) &ifrcopy.ifr_hwaddr.sa_data)[4],
(int) ((guchar *) &ifrcopy.ifr_hwaddr.sa_data)[5]);
@@ -259,7 +248,7 @@
#else
g_sprintf (dst, NOT_AVAILABLE);
#endif /* SIOCGIFHWADDR */
-@@ -595,6 +742,8 @@ info_get_nic_information (const gchar *n
+@@ -625,6 +769,8 @@ info_get_nic_information (const gchar *n
}
freeifaddrs (ifa0);
diff --git a/net/gnome-nettool/pkg-plist b/net/gnome-nettool/pkg-plist
index 468d8c45031..c9ab10850c7 100644
--- a/net/gnome-nettool/pkg-plist
+++ b/net/gnome-nettool/pkg-plist
@@ -10,7 +10,13 @@ share/gnome/gnome-nettool/pixmaps/network.png
share/gnome/gnome-nettool/pixmaps/wavelan-16.png
share/gnome/help/gnome-nettool/C/gnome-nettool.xml
share/gnome/help/gnome-nettool/C/legal.xml
+share/gnome/help/gnome-nettool/fr/gnome-nettool.xml
+share/gnome/help/gnome-nettool/pa/gnome-nettool.xml
+share/gnome/help/gnome-nettool/sv/gnome-nettool.xml
share/gnome/omf/gnome-nettool/gnome-nettool-C.omf
+share/gnome/omf/gnome-nettool/gnome-nettool-fr.omf
+share/gnome/omf/gnome-nettool/gnome-nettool-pa.omf
+share/gnome/omf/gnome-nettool/gnome-nettool-sv.omf
share/gnome/pixmaps/gnome-nettool.png
share/icons/hicolor/48x48/apps/gnome-nettool.png
share/locale/ar/LC_MESSAGES/gnome-nettool.mo
@@ -46,6 +52,7 @@ share/locale/it/LC_MESSAGES/gnome-nettool.mo
share/locale/ja/LC_MESSAGES/gnome-nettool.mo
share/locale/ka/LC_MESSAGES/gnome-nettool.mo
share/locale/ko/LC_MESSAGES/gnome-nettool.mo
+share/locale/ku/LC_MESSAGES/gnome-nettool.mo
share/locale/lt/LC_MESSAGES/gnome-nettool.mo
share/locale/lv/LC_MESSAGES/gnome-nettool.mo
share/locale/mg/LC_MESSAGES/gnome-nettool.mo
@@ -80,12 +87,6 @@ share/locale/xh/LC_MESSAGES/gnome-nettool.mo
share/locale/zh_CN/LC_MESSAGES/gnome-nettool.mo
share/locale/zh_HK/LC_MESSAGES/gnome-nettool.mo
share/locale/zh_TW/LC_MESSAGES/gnome-nettool.mo
-@dirrm share/gnome/omf/gnome-nettool
-@dirrm share/gnome/help/gnome-nettool/C
-@dirrm share/gnome/help/gnome-nettool
-@dirrm share/gnome/gnome-nettool/pixmaps
-@dirrm share/gnome/gnome-nettool/dialogs
-@dirrm share/gnome/gnome-nettool
@dirrmtry share/locale/zh_TW/LC_MESSAGES
@dirrmtry share/locale/zh_TW
@dirrmtry share/locale/zh_HK/LC_MESSAGES
@@ -114,6 +115,8 @@ share/locale/zh_TW/LC_MESSAGES/gnome-nettool.mo
@dirrmtry share/locale/ne
@dirrmtry share/locale/mg/LC_MESSAGES
@dirrmtry share/locale/mg
+@dirrmtry share/locale/ku/LC_MESSAGES
+@dirrmtry share/locale/ku
@dirrmtry share/locale/ko/LC_MESSAGES
@dirrmtry share/locale/ko
@dirrmtry share/locale/gl/LC_MESSAGES
@@ -130,3 +133,12 @@ share/locale/zh_TW/LC_MESSAGES/gnome-nettool.mo
@dirrmtry share/locale/ca
@dirrmtry share/locale/bn_IN/LC_MESSAGES
@dirrmtry share/locale/bn_IN
+@dirrm share/gnome/omf/gnome-nettool
+@dirrm share/gnome/help/gnome-nettool/sv
+@dirrm share/gnome/help/gnome-nettool/pa
+@dirrm share/gnome/help/gnome-nettool/fr
+@dirrm share/gnome/help/gnome-nettool/C
+@dirrm share/gnome/help/gnome-nettool
+@dirrm share/gnome/gnome-nettool/pixmaps
+@dirrm share/gnome/gnome-nettool/dialogs
+@dirrm share/gnome/gnome-nettool
diff --git a/net/vino/Makefile b/net/vino/Makefile
index d378c42d3f9..c56835ec6b5 100644
--- a/net/vino/Makefile
+++ b/net/vino/Makefile
@@ -3,12 +3,11 @@
# Whom: Tom McLaughlin <tmclaugh@sdf.lonestar.org>
#
# $FreeBSD$
-# $MCom: ports/net/vino/Makefile,v 1.31 2006/10/05 18:17:10 mezz Exp $
+# $MCom: ports/net/vino/Makefile,v 1.37 2007/03/12 13:41:32 ahze Exp $
#
PORTNAME= vino
-PORTVERSION= 2.16.0
-PORTREVISION= 2
+PORTVERSION= 2.18.0
CATEGORIES= net gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME}/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}
diff --git a/net/vino/distinfo b/net/vino/distinfo
index 351477f49a6..b3939991725 100644
--- a/net/vino/distinfo
+++ b/net/vino/distinfo
@@ -1,3 +1,3 @@
-MD5 (vino-2.16.0.tar.bz2) = 89937e6d6cd8f658d037da0a7cfd3f4e
-SHA256 (vino-2.16.0.tar.bz2) = bcf62f1121fe704a019363467f9182e29931ee6779f3b65e996171f4caa11369
-SIZE (vino-2.16.0.tar.bz2) = 593224
+MD5 (vino-2.18.0.tar.bz2) = 8378156f78289c2f0d3bd5c483101a40
+SHA256 (vino-2.18.0.tar.bz2) = 85b45f5e42f4c8748eff638aeac0b0b8716b382b4f61e03818528851cfde4b0a
+SIZE (vino-2.18.0.tar.bz2) = 632635
diff --git a/net/vino/files/patch-server_vino-prefs.c b/net/vino/files/patch-server_vino-prefs.c
deleted file mode 100644
index 4abd2b39ba0..00000000000
--- a/net/vino/files/patch-server_vino-prefs.c
+++ /dev/null
@@ -1,15 +0,0 @@
-===================================================================
-RCS file: /cvs/gnome/vino/server/vino-prefs.c,v
-retrieving revision 1.2
-retrieving revision 1.2.2.1
-diff -u -r1.2 -r1.2.2.1
---- server/vino-prefs.c 2006/10/05 12:55:37 1.2
-+++ server/vino-prefs.c 2006/10/10 10:42:38 1.2.2.1
-@@ -306,7 +306,6 @@
- VINO_PREFS_VNC_PASSWORD,
- NULL);
- dprintf (PREFS, "Encoded password: %s\n", vino_vnc_password ? vino_vnc_password : "(null)");
-- g_free (vino_vnc_password);
-
- vino_listeners [i] =
- gconf_client_notify_add (vino_client,