aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorsumikawa <sumikawa@FreeBSD.org>2002-09-13 14:50:23 +0800
committersumikawa <sumikawa@FreeBSD.org>2002-09-13 14:50:23 +0800
commitf2705c053252f090dc5c2782de2f33d93dac5ba4 (patch)
tree4811deee506cc2c28f2af95cdb742930e64caedf /net
parent97efab632161b267d3de7afcbe21828183410f0b (diff)
downloadfreebsd-ports-graphics-f2705c053252f090dc5c2782de2f33d93dac5ba4.tar.gz
freebsd-ports-graphics-f2705c053252f090dc5c2782de2f33d93dac5ba4.tar.zst
freebsd-ports-graphics-f2705c053252f090dc5c2782de2f33d93dac5ba4.zip
The 6to4 script can be used to setup IPv6 on your home machine and net-
work for exploring IPv6 without any registrations. 6to4 is a mechanism by which your IPv6 address(es) are derived from an assigned IPv4 address, and which involves automatic tunnelling to one or more remove 6to4 hubs, which will then forward your v6 packets on the 6bone etc. Replies are routed back to you over IPv4 via (possibly) other 6to4 capable remote gateways. As such, IPv6-in-IPv4-encapsulated packets are accepted from all v4-hosts. WWW: http://www.netbsd.org/packages/net/6to4/files/6to4.html PR: ports/40137 Submitted by: Kimura Fuyuki <fuyuki@hadaly.org>
Diffstat (limited to 'net')
-rw-r--r--net/6to4/Makefile44
-rw-r--r--net/6to4/distinfo3
-rw-r--r--net/6to4/pkg-comment1
-rw-r--r--net/6to4/pkg-descr10
-rw-r--r--net/6to4/pkg-message7
-rw-r--r--net/6to4/pkg-plist2
-rw-r--r--net/Makefile1
7 files changed, 68 insertions, 0 deletions
diff --git a/net/6to4/Makefile b/net/6to4/Makefile
new file mode 100644
index 00000000000..1f3ec90916a
--- /dev/null
+++ b/net/6to4/Makefile
@@ -0,0 +1,44 @@
+# New ports collection makefile for: 6to4
+# Date created: 3 July 2002
+# Whom: Kimura Fuyuki <fuyuki@hadaly.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= 6to4
+PORTVERSION= 1.2
+CATEGORIES= net ipv6
+MASTER_SITES= http://cvsweb.netbsd.org/bsdweb.cgi/~checkout~/pkgsrc/net/6to4/files/
+DISTFILES= 6to4\?rev=1.7\&content-type=text%2fplain \
+ 6to4.8\?rev=1.5\&content-type=text%2fplain \
+ 6to4.conf\?rev=1.2\&content-type=text%2fplain
+DIST_SUBDIR= ${PORTNAME}
+
+MAINTAINER= fuyuki@hadaly.org
+
+USE_REINPLACE= yes
+USE_PERL5= yes
+NO_BUILD= yes
+
+MAN8= 6to4.8
+
+do-extract:
+ ${MKDIR} ${WRKSRC}
+.for i in ${DISTFILES}
+ ${CP} ${DISTDIR}/${DIST_SUBDIR}/${i} ${WRKSRC}/${i:C/\?.*$//}
+.endfor
+
+do-patch:
+ ${REINPLACE_CMD} -e 's|\@LOCALBASE\@/bin/perl|${PERL}|; \
+ s|\@PREFIX\@|${PREFIX}|' ${WRKSRC}/6to4
+ ${REINPLACE_CMD} -e 's|/usr/pkg|${PREFIX}|; \
+ s|ip6mode=autohost|ipv6_gateway_enable="NO"|' ${WRKSRC}/6to4.8
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/6to4 ${PREFIX}/sbin
+ ${INSTALL_MAN} ${WRKSRC}/6to4.8 ${PREFIX}/man/man8
+ ${INSTALL_DATA} ${WRKSRC}/6to4.conf ${PREFIX}/etc/6to4.conf.sample
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/net/6to4/distinfo b/net/6to4/distinfo
new file mode 100644
index 00000000000..f2f21d3ddab
--- /dev/null
+++ b/net/6to4/distinfo
@@ -0,0 +1,3 @@
+MD5 (6to4/6to4?rev=1.7&content-type=text%2fplain) = 97d81c3cbc6c026af31c9764e5c74d78
+MD5 (6to4/6to4.8?rev=1.5&content-type=text%2fplain) = 50d63c1abd2db188825eae488cac6acc
+MD5 (6to4/6to4.conf?rev=1.2&content-type=text%2fplain) = 9dd3bde583c529dd6787f378f7b99594
diff --git a/net/6to4/pkg-comment b/net/6to4/pkg-comment
new file mode 100644
index 00000000000..a2c05c0d515
--- /dev/null
+++ b/net/6to4/pkg-comment
@@ -0,0 +1 @@
+Enables 6to4 IPv6 automatic tunnels
diff --git a/net/6to4/pkg-descr b/net/6to4/pkg-descr
new file mode 100644
index 00000000000..b1b8f5072aa
--- /dev/null
+++ b/net/6to4/pkg-descr
@@ -0,0 +1,10 @@
+The 6to4 script can be used to setup IPv6 on your home machine and net-
+work for exploring IPv6 without any registrations. 6to4 is a mechanism by
+which your IPv6 address(es) are derived from an assigned IPv4 address,
+and which involves automatic tunnelling to one or more remove 6to4 hubs,
+which will then forward your v6 packets on the 6bone etc. Replies are
+routed back to you over IPv4 via (possibly) other 6to4 capable remote
+gateways. As such, IPv6-in-IPv4-encapsulated packets are accepted from
+all v4-hosts.
+
+WWW: http://www.netbsd.org/packages/net/6to4/files/6to4.html
diff --git a/net/6to4/pkg-message b/net/6to4/pkg-message
new file mode 100644
index 00000000000..6b6de50f782
--- /dev/null
+++ b/net/6to4/pkg-message
@@ -0,0 +1,7 @@
+===========================================================================
+
+To configure this package, adjust ${PREFIX}/etc/6to4.conf from
+${PREFIX}/etc/6to4.conf.sample, then start "6to4 -v start".
+You should be able to "ping6 www.kame.net" after that.
+
+===========================================================================
diff --git a/net/6to4/pkg-plist b/net/6to4/pkg-plist
new file mode 100644
index 00000000000..1b893cb7693
--- /dev/null
+++ b/net/6to4/pkg-plist
@@ -0,0 +1,2 @@
+sbin/6to4
+etc/6to4.conf.sample
diff --git a/net/Makefile b/net/Makefile
index 619cce3c741..814e93d4a01 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -3,6 +3,7 @@
SUBDIR += 44bsd-rdist
SUBDIR += 6tunnel
+ SUBDIR += 6to4
SUBDIR += NeTraMet
SUBDIR += SSLtelnet
SUBDIR += adasockets