aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2014-02-17 01:15:31 +0800
committertijl <tijl@FreeBSD.org>2014-02-17 01:15:31 +0800
commitf86cbfadd2dbfab1dc1ea72e5084a23c10b1dc6c (patch)
tree49e521faa408bc4bd163bfb0febf91e262772c1c /net
parente04e533cf1bc01e44ad69d14d5c6c205e25bfe3a (diff)
downloadfreebsd-ports-graphics-f86cbfadd2dbfab1dc1ea72e5084a23c10b1dc6c.tar.gz
freebsd-ports-graphics-f86cbfadd2dbfab1dc1ea72e5084a23c10b1dc6c.tar.zst
freebsd-ports-graphics-f86cbfadd2dbfab1dc1ea72e5084a23c10b1dc6c.zip
Convert all USE_FORTRAN=yes to "USES=fortran, USE_GCC=yes". In most cases
USE_GCC=yes has been omitted though. Remove USE_FORTRAN handling from bsd.port.mk and bsd.gcc.mk. Minor cleanups in some ports like USE_GMAKE, NOPORTDOCS,... Exp-run: bdrewery Approved by: portmgr (bdrewery)
Diffstat (limited to 'net')
-rw-r--r--net/mpich2/Makefile4
-rw-r--r--net/openmpi-devel/Makefile4
-rw-r--r--net/openmpi/Makefile3
3 files changed, 5 insertions, 6 deletions
diff --git a/net/mpich2/Makefile b/net/mpich2/Makefile
index f7711726bf0..0a12d6c5e1f 100644
--- a/net/mpich2/Makefile
+++ b/net/mpich2/Makefile
@@ -22,8 +22,8 @@ LIB_DEPENDS= execinfo.1:${PORTSDIR}/devel/libexecinfo
RUN_DEPENDS= bash:${PORTSDIR}/shells/bash
GNU_CONFIGURE= yes
-USE_FORTRAN= yes
-USES= pkgconfig perl5
+USES= fortran perl5 pkgconfig
+USE_GCC= yes
USE_LDCONFIG= yes
USE_PERL5= build
USE_PYTHON= yes
diff --git a/net/openmpi-devel/Makefile b/net/openmpi-devel/Makefile
index 0a9961db0b9..337588158e8 100644
--- a/net/openmpi-devel/Makefile
+++ b/net/openmpi-devel/Makefile
@@ -18,8 +18,7 @@ CONFLICTS= openmpi-1.6.*
USE_BZIP2= yes
HAS_CONFIGURE= yes
-USES= gmake pkgconfig
-USE_FORTRAN= yes
+USES= fortran gmake pkgconfig
MPIBASE?= mpi
MPIDIR?= ${MPIBASE}/${UNIQUENAME}${PKGNAMESUFFIX}
@@ -32,6 +31,7 @@ CONFIGURE_ARGS+= --prefix=${PREFIX}/${MPIDIR} \
--program-prefix= \
--with-hwloc=${LOCALBASE} \
--with-libltdl=${LOCALBASE}
+LDFLAGS+= -L${LOCALBASE}/lib
USE_LDCONFIG= ${PREFIX}/${MPIDIR}/lib \
${PREFIX}/${MPIDIR}/lib/openmpi
diff --git a/net/openmpi/Makefile b/net/openmpi/Makefile
index 55e0eabdd48..fcaebaa5583 100644
--- a/net/openmpi/Makefile
+++ b/net/openmpi/Makefile
@@ -20,8 +20,7 @@ CONFLICTS= openmpi-devel-1.7.*
USE_BZIP2= yes
HAS_CONFIGURE= yes
-USES= gmake pkgconfig
-USE_FORTRAN= yes
+USES= fortran gmake pkgconfig
MPIBASE?= mpi
MPIDIR?= ${MPIBASE}/${UNIQUENAME}