aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorarved <arved@FreeBSD.org>2010-07-03 01:23:30 +0800
committerarved <arved@FreeBSD.org>2010-07-03 01:23:30 +0800
commitfd5157a423bb32a08e3698d518f54bcc222e4395 (patch)
tree2a0542cefa8f8df240452b2708aac97d7a4a02ef /net
parent77b93deda2e11cf2580e6edb48b62c423fa2602b (diff)
downloadfreebsd-ports-graphics-fd5157a423bb32a08e3698d518f54bcc222e4395.tar.gz
freebsd-ports-graphics-fd5157a423bb32a08e3698d518f54bcc222e4395.tar.zst
freebsd-ports-graphics-fd5157a423bb32a08e3698d518f54bcc222e4395.zip
Add x2goclient, A client to connect to an x2go server.
Feature safe: yes
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/x2goclient-cli/Makefile33
-rw-r--r--net/x2goclient-cli/distinfo3
-rw-r--r--net/x2goclient-cli/files/setsid.c7
-rw-r--r--net/x2goclient-cli/pkg-descr3
5 files changed, 47 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 1c1204f5260..e6680ed8702 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -1129,6 +1129,7 @@
SUBDIR += wpa_gui
SUBDIR += wping
SUBDIR += x11vnc
+ SUBDIR += x2goclient-cli
SUBDIR += xbone
SUBDIR += xbone-gui
SUBDIR += xboxproxy
diff --git a/net/x2goclient-cli/Makefile b/net/x2goclient-cli/Makefile
new file mode 100644
index 00000000000..6c371d78b88
--- /dev/null
+++ b/net/x2goclient-cli/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: x2goclient-cli
+# Date created: 2010-06-24
+# Whom: arved
+#
+# $FreeBSD$
+
+PORTNAME= x2goclient-cli
+DISTVERSION= 3.0.1-1.2
+CATEGORIES= net
+MASTER_SITES= http://x2go.obviously-nice.de/deb/pool-lenny/x2goclient-cli/
+DISTNAME= ${PORTNAME}_${DISTVERSION}
+
+MAINTAINER= arved@FreeBSD.org
+COMMENT= The x2go perl client
+
+RUN_DEPENDS= ${SITE_PERL}/Proc/Simple.pm:${PORTSDIR}/devel/p5-Proc-Simple \
+ ${SITE_PERL}/Term/ReadPassword.pm:${PORTSDIR}/devel/p5-Term-ReadPassword \
+ nxproxy:${PORTSDIR}/net/nxproxy
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/LICENSE
+USE_PERL5= yes
+PLIST_FILES= bin/x2goclient-cli bin/setsid
+WRKSRC= ${WRKDIR}/${PORTNAME}-${DISTVERSION:S,-1.2,,}
+
+do-build:
+ cd ${WRKSRC}; ${CC} ${CFLAGS} ${FILESDIR}/setsid.c -o setsid
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/x2goclient-cli ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/setsid ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/net/x2goclient-cli/distinfo b/net/x2goclient-cli/distinfo
new file mode 100644
index 00000000000..ba17215fd5d
--- /dev/null
+++ b/net/x2goclient-cli/distinfo
@@ -0,0 +1,3 @@
+MD5 (x2goclient-cli_3.0.1-1.2.tar.gz) = bbe5c4e31cbfac26a3179d8479c3eca4
+SHA256 (x2goclient-cli_3.0.1-1.2.tar.gz) = ad6b69fffe599102791c96c38f0eb42f7fe2308ef61803f7cbd74b0321e51135
+SIZE (x2goclient-cli_3.0.1-1.2.tar.gz) = 19180
diff --git a/net/x2goclient-cli/files/setsid.c b/net/x2goclient-cli/files/setsid.c
new file mode 100644
index 00000000000..09c711d0e63
--- /dev/null
+++ b/net/x2goclient-cli/files/setsid.c
@@ -0,0 +1,7 @@
+#include <unistd.h>
+int main(int argc,char** argv)
+{
+ setsid();
+ execvp(argv[1], argv+1);
+ return 0;
+}
diff --git a/net/x2goclient-cli/pkg-descr b/net/x2goclient-cli/pkg-descr
new file mode 100644
index 00000000000..dca3d85e2d7
--- /dev/null
+++ b/net/x2goclient-cli/pkg-descr
@@ -0,0 +1,3 @@
+CLI client for x2go
+
+WWW: http://www.x2go.org/