aboutsummaryrefslogtreecommitdiffstats
path: root/news/aub
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2014-02-25 16:50:24 +0800
committerehaupt <ehaupt@FreeBSD.org>2014-02-25 16:50:24 +0800
commit148ed689a2f1caa56cbfea979201d2428e6fc3e6 (patch)
tree3370f4992f77205ee05d017b166d6028815e749b /news/aub
parent1d980b7aae43657be4d0399e3273a1466014b21a (diff)
downloadfreebsd-ports-graphics-148ed689a2f1caa56cbfea979201d2428e6fc3e6.tar.gz
freebsd-ports-graphics-148ed689a2f1caa56cbfea979201d2428e6fc3e6.tar.zst
freebsd-ports-graphics-148ed689a2f1caa56cbfea979201d2428e6fc3e6.zip
- Support staging
- Use shebangfix - Define DOCS
Diffstat (limited to 'news/aub')
-rw-r--r--news/aub/Makefile25
-rw-r--r--news/aub/pkg-plist5
2 files changed, 14 insertions, 16 deletions
diff --git a/news/aub/Makefile b/news/aub/Makefile
index 2aaf85646f6..41afbe5c357 100644
--- a/news/aub/Makefile
+++ b/news/aub/Makefile
@@ -11,23 +11,26 @@ DISTNAME= ${PORTNAME}_${PORTVERSION}
MAINTAINER= obrien@FreeBSD.org
COMMENT= Assemble usenet binaries
+USES= shebangfix
NO_BUILD= yes
-MAN1= aub.1.sgml aubconf.1.sgml
+
+MANPAGE= aub.1.sgml aubconf.1.sgml
+PORTDOCS= COPYING README aubconf.example
+PLIST_FILES= bin/aub man/man1/aub.1.sgml.gz man/man1/aubconf.1.sgml.gz
+SHEBANG_FILES= aub
+
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-DOC_FILES= COPYING README aubconf.example
+OPTIONS_DEFINE= DOCS
-NO_STAGE= yes
do-install:
- ${INSTALL_SCRIPT} ${WRKSRC}/aub ${PREFIX}/bin
-.for manpage in ${MAN1}
- ${INSTALL_MAN} ${WRKSRC}/${manpage} ${MANPREFIX}/man/man1
+ ${INSTALL_SCRIPT} ${WRKSRC}/aub ${STAGEDIR}${PREFIX}/bin
+.for manpage in ${MANPAGE}
+ ${INSTALL_MAN} ${WRKSRC}/${manpage} ${STAGEDIR}${MANPREFIX}/man/man1
.endfor
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
-.for doc in ${DOC_FILES}
- ${INSTALL_MAN} ${WRKSRC}/${doc} ${DOCSDIR}
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+.for doc in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${doc} ${STAGEDIR}${DOCSDIR}
.endfor
-.endif
.include <bsd.port.mk>
diff --git a/news/aub/pkg-plist b/news/aub/pkg-plist
deleted file mode 100644
index aa3ed704bed..00000000000
--- a/news/aub/pkg-plist
+++ /dev/null
@@ -1,5 +0,0 @@
-bin/aub
-%%PORTDOCS%%%%DOCSDIR%%/COPYING
-%%PORTDOCS%%%%DOCSDIR%%/README
-%%PORTDOCS%%%%DOCSDIR%%/aubconf.example
-%%PORTDOCS%%@dirrm %%DOCSDIR%%