aboutsummaryrefslogtreecommitdiffstats
path: root/news/inn-current/Makefile
diff options
context:
space:
mode:
authordes <des@FreeBSD.org>2001-03-07 07:28:17 +0800
committerdes <des@FreeBSD.org>2001-03-07 07:28:17 +0800
commitf68734827bd509f40ed30875b5d3d2a4345befe0 (patch)
tree02e0f90bb73eeaa4e98f7936f4ededdb8c43b2cd /news/inn-current/Makefile
parentdae21a4eb355c38722fe3e6fccf0df84f4327509 (diff)
downloadfreebsd-ports-graphics-f68734827bd509f40ed30875b5d3d2a4345befe0.tar.gz
freebsd-ports-graphics-f68734827bd509f40ed30875b5d3d2a4345befe0.tar.zst
freebsd-ports-graphics-f68734827bd509f40ed30875b5d3d2a4345befe0.zip
Install some header files which third-party utils may need.
Avoid leaving cruft behind in the db directory.
Diffstat (limited to 'news/inn-current/Makefile')
-rw-r--r--news/inn-current/Makefile11
1 files changed, 9 insertions, 2 deletions
diff --git a/news/inn-current/Makefile b/news/inn-current/Makefile
index c939a658530..5ce93fac3bb 100644
--- a/news/inn-current/Makefile
+++ b/news/inn-current/Makefile
@@ -7,6 +7,7 @@
PORTNAME= inn
PORTVERSION= 2.3.1
+PORTREVISION= 1
CATEGORIES= news
MASTER_SITES= ftp://ftp.isc.org/isc/inn/
@@ -59,6 +60,8 @@ MAN8= actsync.8 actsyncd.8 archive.8 batcher.8 buffchan.8 cnfsheadconf.8 \
EXTRA= ${WRKSRC}/HISTORY ${WRKSRC}/INSTALL ${WRKSRC}/LICENSE
+INN_INCLUDES= clibrary.h config.h libinn.h storage.h
+
pre-install:
${MKDIR} ${INN_NEWSSPOOL}
@@ -71,15 +74,19 @@ post-install:
${TOUCH} history ; \
${CHMOD} 644 history ; \
${CHOWN} news:news history ; \
- ../bin/makedbz -i ; \
+ su -fm news -c "../bin/makedbz -i" ; \
for s in dir hash index ; do \
- ${INSTALL} -o news -m 644 history.n.$${s} history.$${s} ; \
+ ${MV} history.n.$${s} history.$${s} ; \
done ; \
fi)
@${SED} <${FILESDIR}/innd.sh >${PREFIX}/etc/rc.d/innd.sh \
s+!!PREFIX!!+${PREFIX}+g && ${CHMOD} +x ${PREFIX}/etc/rc.d/innd.sh
@${MKDIR} ${PREFIX}/share/doc/inn
@${INSTALL_DATA} ${EXTRA} ${PREFIX}/share/doc/inn
+ @${MKDIR} ${PREFIX}/news/include
+.for FILE in ${INN_INCLUDES}
+ @${INSTALL_DATA} ${WRKSRC}/include/${FILE} ${PREFIX}/news/include/
+.endfor
@${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
.include <bsd.port.mk>