aboutsummaryrefslogtreecommitdiffstats
path: root/news/inn-current
diff options
context:
space:
mode:
authorshaun <shaun@FreeBSD.org>2006-08-30 08:39:07 +0800
committershaun <shaun@FreeBSD.org>2006-08-30 08:39:07 +0800
commiteffab6e44691f7407cb6ef3ef8d540b631a264b9 (patch)
treee3632ba3034de69c24d0a0e30f351b219132b4ae /news/inn-current
parent9ceb18ab020a64a23e13b0c6ab998e1df21ef78c (diff)
downloadfreebsd-ports-graphics-effab6e44691f7407cb6ef3ef8d540b631a264b9.tar.gz
freebsd-ports-graphics-effab6e44691f7407cb6ef3ef8d540b631a264b9.tar.zst
freebsd-ports-graphics-effab6e44691f7407cb6ef3ef8d540b631a264b9.zip
For the inn ports:
- Fix build in the case where the host machine has either no DNS, or an incomplete hostname. - Use a generic placeholder in the default config file rather than the build machine's name. - Pet portlint(1) while here.
Diffstat (limited to 'news/inn-current')
-rw-r--r--news/inn-current/Makefile8
-rw-r--r--news/inn-current/files/patch-lib_innconf.c11
2 files changed, 16 insertions, 3 deletions
diff --git a/news/inn-current/Makefile b/news/inn-current/Makefile
index ebcb645f30a..51e4d77c1e8 100644
--- a/news/inn-current/Makefile
+++ b/news/inn-current/Makefile
@@ -58,9 +58,9 @@ WITH_BDB_VER= 41
. if (${WITH_BDB_VER} == 3) || (${WITH_BDB_VER} == 4) || (${WITH_BDB_VER} == 41)
LIB_DEPENDS+= db${WITH_BDB_VER}:${PORTSDIR}/databases/db${WITH_BDB_VER}
. elif ${WITH_BDB_VER} == 2
-BROKEN= "Does not compile with db2"
+BROKEN= does not compile with db2
. else
-BROKEN= "Unknown BerkeleyDB version"
+BROKEN= unknown BerkeleyDB version
. endif
CONFIGURE_ENV+= DB_VER=db${WITH_BDB_VER}
CONFIGURE_ARGS+= --with-berkeleydb=${LOCALBASE}
@@ -129,7 +129,7 @@ MAN8= actsync.8 actsyncd.8 archive.8 auth_smb.8 batcher.8 buffchan.8 \
.include <bsd.port.pre.mk>
.if ${ARCH} == "ia64"
-BROKEN= "Does not compile on ia64"
+BROKEN= does not compile on ${ARCH}
.endif
.if defined(WITH_STANDARD_ETC)
@@ -165,6 +165,8 @@ post-install:
s+!!PREFIX!!+${PREFIX}+g && ${CHMOD} +x ${PREFIX}/etc/rc.d/innd.sh
@${CHOWN} root:news ${PREFIX}/news/bin/auth/passwd/ckpasswd
@${CHMOD} 4755 ${PREFIX}/news/bin/auth/passwd/ckpasswd
+ @${FIND} ${WRKSRC} -name "inn.conf" \
+ | ${XARGS} ${REINPLACE_CMD} -e 's/^pathhost:.*/pathhost: host.example.com/'
@PKG_PREFIX=${PKG_PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} CHECK-CONF ${ETC_DIR}
@(if [ ! -f ${PREFIX}/news/db/history ] ; then \
${ECHO} 'Creating empty history database...' ; \
diff --git a/news/inn-current/files/patch-lib_innconf.c b/news/inn-current/files/patch-lib_innconf.c
new file mode 100644
index 00000000000..05d8eadfb94
--- /dev/null
+++ b/news/inn-current/files/patch-lib_innconf.c
@@ -0,0 +1,11 @@
+--- lib/innconf.c.orig Mon Mar 20 04:14:57 2006
++++ lib/innconf.c Sat Aug 26 00:22:04 2006
+@@ -395,7 +395,7 @@
+
+ if (GetFQDN(innconf->domain) == NULL) {
+ warn("hostname does not resolve or domain not set in inn.conf");
+- okay = false;
++/* okay = false; */
+ }
+ if (innconf->mta == NULL) {
+ warn("must set mta in inn.conf");