aboutsummaryrefslogtreecommitdiffstats
path: root/palm
diff options
context:
space:
mode:
authordima <dima@FreeBSD.org>2001-01-05 22:15:49 +0800
committerdima <dima@FreeBSD.org>2001-01-05 22:15:49 +0800
commit354aeb288356feaffb38eba1766652a8e838e1f3 (patch)
tree86c99c3addefaf46bcb91790546ccbfcc39eb79c /palm
parent290085c10167bc7f548b7018bd75c2d7023cc36b (diff)
downloadfreebsd-ports-graphics-354aeb288356feaffb38eba1766652a8e838e1f3.tar.gz
freebsd-ports-graphics-354aeb288356feaffb38eba1766652a8e838e1f3.tar.zst
freebsd-ports-graphics-354aeb288356feaffb38eba1766652a8e838e1f3.zip
rc script fix (supports start/stop thingie now)
Submitted by: joseph@randomnetworks.com
Diffstat (limited to 'palm')
-rw-r--r--palm/pilot-link-devel/Makefile4
-rw-r--r--palm/pilot-link-devel/files/pilot-link.sh15
-rw-r--r--palm/pilot-link/Makefile4
-rw-r--r--palm/pilot-link/files/pilot-link.sh15
4 files changed, 32 insertions, 6 deletions
diff --git a/palm/pilot-link-devel/Makefile b/palm/pilot-link-devel/Makefile
index 4f6e6dd3bd7..47300857751 100644
--- a/palm/pilot-link-devel/Makefile
+++ b/palm/pilot-link-devel/Makefile
@@ -28,9 +28,7 @@ MAN1= dlpsh.1 ietf2datebook.1 install-datebook.1 \
MAN7= pilot-link.7
post-install:
- @${ECHO} "#!/bin/sh" > ${LOCALBASE}/etc/rc.d/pilot-link.sh
- @${ECHO} "" >> ${LOCALBASE}/etc/rc.d/pilot-link.sh
- @${ECHO} "${LDCONFIG} -m ${PREFIX}/lib" >> ${LOCALBASE}/etc/rc.d/pilot-link.sh
+ @{$SED} "s|%%PREFIX%%|${PREFIX}|g" < ${FILESDIR}/pilot-link.sh > ${PREFIX}/etc/rc.d/pilot-link.sh
@${CHMOD} 750 ${LOCALBASE}/etc/rc.d/pilot-link.sh
.include <bsd.port.mk>
diff --git a/palm/pilot-link-devel/files/pilot-link.sh b/palm/pilot-link-devel/files/pilot-link.sh
new file mode 100644
index 00000000000..1e02019b2f9
--- /dev/null
+++ b/palm/pilot-link-devel/files/pilot-link.sh
@@ -0,0 +1,15 @@
+#!/bin/sh
+
+case "$1" in
+ start)
+ /sbin/ldconfig -m %%PREFIX%%/pilot/lib
+ ;;
+ stop)
+ ;;
+ *)
+ echo ""
+ echo "Usage: `basename $0` { start | stop }"
+ echo ""
+ echo 64
+ ;;
+esac
diff --git a/palm/pilot-link/Makefile b/palm/pilot-link/Makefile
index 4f6e6dd3bd7..47300857751 100644
--- a/palm/pilot-link/Makefile
+++ b/palm/pilot-link/Makefile
@@ -28,9 +28,7 @@ MAN1= dlpsh.1 ietf2datebook.1 install-datebook.1 \
MAN7= pilot-link.7
post-install:
- @${ECHO} "#!/bin/sh" > ${LOCALBASE}/etc/rc.d/pilot-link.sh
- @${ECHO} "" >> ${LOCALBASE}/etc/rc.d/pilot-link.sh
- @${ECHO} "${LDCONFIG} -m ${PREFIX}/lib" >> ${LOCALBASE}/etc/rc.d/pilot-link.sh
+ @{$SED} "s|%%PREFIX%%|${PREFIX}|g" < ${FILESDIR}/pilot-link.sh > ${PREFIX}/etc/rc.d/pilot-link.sh
@${CHMOD} 750 ${LOCALBASE}/etc/rc.d/pilot-link.sh
.include <bsd.port.mk>
diff --git a/palm/pilot-link/files/pilot-link.sh b/palm/pilot-link/files/pilot-link.sh
new file mode 100644
index 00000000000..1e02019b2f9
--- /dev/null
+++ b/palm/pilot-link/files/pilot-link.sh
@@ -0,0 +1,15 @@
+#!/bin/sh
+
+case "$1" in
+ start)
+ /sbin/ldconfig -m %%PREFIX%%/pilot/lib
+ ;;
+ stop)
+ ;;
+ *)
+ echo ""
+ echo "Usage: `basename $0` { start | stop }"
+ echo ""
+ echo 64
+ ;;
+esac