aboutsummaryrefslogtreecommitdiffstats
path: root/palm
diff options
context:
space:
mode:
authoravl <avl@FreeBSD.org>2009-10-12 17:35:22 +0800
committeravl <avl@FreeBSD.org>2009-10-12 17:35:22 +0800
commit5b7896d2ab5eec94aaf7b948b0dfe6d494d3ce1d (patch)
tree5d64d79b683fca72e8c045f8969114439472144d /palm
parent0acedc0d0bfcb42b5c3f1fc9ee0caf04a7620c70 (diff)
downloadfreebsd-ports-graphics-5b7896d2ab5eec94aaf7b948b0dfe6d494d3ce1d.tar.gz
freebsd-ports-graphics-5b7896d2ab5eec94aaf7b948b0dfe6d494d3ce1d.tar.zst
freebsd-ports-graphics-5b7896d2ab5eec94aaf7b948b0dfe6d494d3ce1d.zip
- Update to 0.14
PR: ports/139327 Submitted by: myself Approved by: maintainer, portmgr (miwi)
Diffstat (limited to 'palm')
-rw-r--r--palm/synce-librapi2/Makefile4
-rw-r--r--palm/synce-librapi2/distinfo6
-rw-r--r--palm/synce-librapi2/files/patch-rapi_context.c24
-rw-r--r--palm/synce-librapi2/files/patch-src-rapi2-file_management2.c19
-rw-r--r--palm/synce-librapi2/files/patch-src_rapi_invoke.c10
-rw-r--r--palm/synce-librapi2/files/patch-tests-CeRapiInvoke-Makefile.in10
-rw-r--r--palm/synce-librapi2/pkg-plist1
7 files changed, 40 insertions, 34 deletions
diff --git a/palm/synce-librapi2/Makefile b/palm/synce-librapi2/Makefile
index 41c5e43f0ac..a6f0bcc1041 100644
--- a/palm/synce-librapi2/Makefile
+++ b/palm/synce-librapi2/Makefile
@@ -5,9 +5,9 @@
# $FreeBSD$
PORTNAME= librapi2
-PORTVERSION= 0.13.1
+PORTVERSION= 0.14
CATEGORIES?= palm
-MASTER_SITES= SF/synce/SynCE/0.13
+MASTER_SITES= SF/synce/SynCE/${PORTVERSION}
PKGNAMEPREFIX?= synce-
MAINTAINER= webmaster@kibab.com
diff --git a/palm/synce-librapi2/distinfo b/palm/synce-librapi2/distinfo
index 6da293e8894..617b76cbce8 100644
--- a/palm/synce-librapi2/distinfo
+++ b/palm/synce-librapi2/distinfo
@@ -1,3 +1,3 @@
-MD5 (librapi2-0.13.1.tar.gz) = f44ca31d8a8cd44e9eb517b35ed87419
-SHA256 (librapi2-0.13.1.tar.gz) = c3eac5062bcbe1896a74b33511fc050f9a9ad8ed48360a0f491006877079ea9c
-SIZE (librapi2-0.13.1.tar.gz) = 464141
+MD5 (librapi2-0.14.tar.gz) = cffa19b32817db211ee21e1ac7c7eb5f
+SHA256 (librapi2-0.14.tar.gz) = 0a747b6f5c14921e2fc7b55a74f192274ddeef53d00056a84729319d48fe20bf
+SIZE (librapi2-0.14.tar.gz) = 493763
diff --git a/palm/synce-librapi2/files/patch-rapi_context.c b/palm/synce-librapi2/files/patch-rapi_context.c
new file mode 100644
index 00000000000..414ca3c862a
--- /dev/null
+++ b/palm/synce-librapi2/files/patch-rapi_context.c
@@ -0,0 +1,24 @@
+--- src/support/rapi_context.c 2009-07-27 13:25:07.000000000 +0400
++++ src/support/rapi_context.c 2009-07-27 13:26:52.000000000 +0400
+@@ -513,13 +513,19 @@
+ /*
+ * odccm, synce-hal, or proxy ?
+ */
++#if ENABLE_ODCCM_SUPPORT
+ if (strcmp(transport, "odccm") == 0) {
+ synce_socket_take_descriptor(context->socket, get_connection_from_odccm(info));
+ }
+- else if (strcmp(transport, "hal") == 0) {
++ else
++#endif
++#if ENABLE_HAL_SUPPORT
++ if (strcmp(transport, "hal") == 0) {
+ synce_socket_take_descriptor(context->socket, get_connection_from_hal(info));
+ }
+- else if ( !synce_socket_connect_proxy(context->socket, synce_info_get_device_ip(info)) )
++ else
++#endif
++ if ( !synce_socket_connect_proxy(context->socket, synce_info_get_device_ip(info)) )
+ {
+ synce_error("failed to connect to proxy for %s", synce_info_get_device_ip(info));
+ goto fail;
diff --git a/palm/synce-librapi2/files/patch-src-rapi2-file_management2.c b/palm/synce-librapi2/files/patch-src-rapi2-file_management2.c
deleted file mode 100644
index b3ce2a7db61..00000000000
--- a/palm/synce-librapi2/files/patch-src-rapi2-file_management2.c
+++ /dev/null
@@ -1,19 +0,0 @@
---- src/rapi2/file_management2.c.orig Fri Jan 26 02:12:41 2007
-+++ src/rapi2/file_management2.c Fri Jan 26 02:13:40 2007
-@@ -40,6 +40,7 @@
- {
- RapiContext* context = rapi_context_current();
- uint32_t count = 0;
-+ uint32_t unknown;
-
- rapi_context_begin_command(context, 0x1a);
- rapi2_buffer_write_string(context->send_buffer, szPath);
-@@ -50,7 +51,7 @@
-
- /* TODO Don't know this two uint32_t fields */
- rapi_buffer_read_uint32(context->recv_buffer, &context->last_error);
-- uint32_t unknown;
-+
- rapi_buffer_read_uint32(context->recv_buffer, &unknown);
-
- rapi_buffer_read_uint32(context->recv_buffer, &count);
diff --git a/palm/synce-librapi2/files/patch-src_rapi_invoke.c b/palm/synce-librapi2/files/patch-src_rapi_invoke.c
deleted file mode 100644
index 929669891db..00000000000
--- a/palm/synce-librapi2/files/patch-src_rapi_invoke.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/rapi/invoke.c.orig Fri Jan 26 01:58:51 2007
-+++ src/rapi/invoke.c Fri Jan 26 01:59:15 2007
-@@ -1,6 +1,7 @@
- /* $Id: invoke.c 2355 2006-04-07 18:47:20Z voc $ */
- #include "rapi_api.h"
- #include "rapi_context.h"
-+#include <sys/socket.h>
- #include <assert.h>
- #include <stdlib.h>
-
diff --git a/palm/synce-librapi2/files/patch-tests-CeRapiInvoke-Makefile.in b/palm/synce-librapi2/files/patch-tests-CeRapiInvoke-Makefile.in
new file mode 100644
index 00000000000..9fff69d1b39
--- /dev/null
+++ b/palm/synce-librapi2/files/patch-tests-CeRapiInvoke-Makefile.in
@@ -0,0 +1,10 @@
+--- tests/CeRapiInvoke/Makefile.in 2009-07-16 13:44:55.000000000 +0400
++++ tests/CeRapiInvoke/Makefile.in 2009-07-27 15:17:24.000000000 +0400
+@@ -227,6 +227,7 @@
+ top_builddir = @top_builddir@
+ top_srcdir = @top_srcdir@
+ AM_CXXFLAGS = @LIBSYNCE_CFLAGS@ -Wall
++AM_CFLAGS= @LIBSYNCE_CFLAGS@ -Wall
+ AM_LDFLAGS = @LIBSYNCE_LIBS@
+ INCLUDES = -I$(top_srcdir)/src
+ CeRapiInvoke_SOURCES = CeRapiInvoke.cc ../../tools/pcommon.c
diff --git a/palm/synce-librapi2/pkg-plist b/palm/synce-librapi2/pkg-plist
index 4ba84f98383..0f18e9c697f 100644
--- a/palm/synce-librapi2/pkg-plist
+++ b/palm/synce-librapi2/pkg-plist
@@ -10,6 +10,7 @@ bin/psettime
bin/pshortcut
bin/pstatus
bin/rapiconfig
+bin/synce-database
bin/synce-install-cab
bin/synce-list-programs
bin/synce-registry