aboutsummaryrefslogtreecommitdiffstats
path: root/palm
diff options
context:
space:
mode:
authoradamw <adamw@FreeBSD.org>2003-09-16 04:51:26 +0800
committeradamw <adamw@FreeBSD.org>2003-09-16 04:51:26 +0800
commit6f1589e3301c6d255f22097b5a270db30b21fda6 (patch)
treeee69232080fb856b9b50bad65e19e969288af222 /palm
parent3707ae40c7ad0003db88d8ea1f7cc143e8b3e2d3 (diff)
downloadfreebsd-ports-graphics-6f1589e3301c6d255f22097b5a270db30b21fda6.tar.gz
freebsd-ports-graphics-6f1589e3301c6d255f22097b5a270db30b21fda6.tar.zst
freebsd-ports-graphics-6f1589e3301c6d255f22097b5a270db30b21fda6.zip
PERL => REINPLACE
Add a REINPLACE to prevent double-inclusion of ppmcmap.h. Submitted by: bento
Diffstat (limited to 'palm')
-rw-r--r--palm/ppmtoTbmp/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/palm/ppmtoTbmp/Makefile b/palm/ppmtoTbmp/Makefile
index 7a02c7e69e0..0826c3881d5 100644
--- a/palm/ppmtoTbmp/Makefile
+++ b/palm/ppmtoTbmp/Makefile
@@ -15,9 +15,12 @@ COMMENT= PPM to Pilot bitmap converter
LIB_DEPENDS= netpbm.1:${PORTSDIR}/graphics/netpbm
+USE_REINPLACE= yes
+
post-patch:
- ${PERL} -pi -e "s|^CFLAGS.+|CFLAGS += -I${LOCALBASE}/include|g; \
+ @${REINPLACE_CMD} -e "s|^CFLAGS =.*|CFLAGS += -I${LOCALBASE}/include|g; \
s|^LDLIBS =|LDLIBS = -L${LOCALBASE}/lib|g" ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e '/^#include "ppmcmap.h"/d' ${WRKSRC}/ppmtoTbmp.c
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/ppmtoTbmp ${WRKSRC}/Tbmptopnm \