aboutsummaryrefslogtreecommitdiffstats
path: root/polish/ekg2
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2006-04-02 09:01:20 +0800
committerpav <pav@FreeBSD.org>2006-04-02 09:01:20 +0800
commitb7477140ab5b2cc4e907b5a596db93a61c59ed15 (patch)
tree44eca64e31327feceeb6dae058bfa4e45ca1f071 /polish/ekg2
parentca627bfbb3dd54ffe819586d0586f4363a733f09 (diff)
downloadfreebsd-ports-graphics-b7477140ab5b2cc4e907b5a596db93a61c59ed15.tar.gz
freebsd-ports-graphics-b7477140ab5b2cc4e907b5a596db93a61c59ed15.tar.zst
freebsd-ports-graphics-b7477140ab5b2cc4e907b5a596db93a61c59ed15.zip
Text-based Gadu-Gadu (and other) client for Unix-like systems.
Gadu-Gadu is an ICQ-like messenger for polish language users. EKG2 is similar to EKG. It has many improvements like Jabber and IRC plugins. It is considered to be in its development stage, so use with care. WWW: http://ekg2.org/ PR: ports/95214 Submitted by: Aleksander Fafula <alex@bsdguru.org>
Diffstat (limited to 'polish/ekg2')
-rw-r--r--polish/ekg2/Makefile48
-rw-r--r--polish/ekg2/distinfo3
-rw-r--r--polish/ekg2/pkg-descr8
-rw-r--r--polish/ekg2/pkg-plist90
4 files changed, 149 insertions, 0 deletions
diff --git a/polish/ekg2/Makefile b/polish/ekg2/Makefile
new file mode 100644
index 00000000000..43b2d539627
--- /dev/null
+++ b/polish/ekg2/Makefile
@@ -0,0 +1,48 @@
+# Ports collection makefile for: ekg2
+# Date created: 27 Dec 2005
+# Whom: Aleksander Fafula <alex@bsdguru.org>
+#
+# $FreeBSD$
+
+PORTNAME= ekg2
+PORTVERSION= 20060318
+CATEGORIES= polish net-im
+MASTER_SITES= http://www.ekg2.org/archive/
+
+MAINTAINER= alex@bsdguru.org
+COMMENT= Text-mode Gadu-Gadu, Jabber and IRC client
+
+LIB_DEPENDS= gadu.3:${PORTSDIR}/polish/libgadu \
+ expat.6:${PORTSDIR}/textproc/expat2
+
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+USE_GNOME= gnomehack pkgconfig
+USE_GETTEXT= yes
+
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ARGS+= --enable-shared \
+ --disable-static \
+ --enable-dynamic \
+ --with-expat \
+ --without-aspell \
+ --without-gtk \
+ --without-libgsm \
+ --without-libxosd \
+ --without-perl \
+ --without-python \
+ --without-sqlite3 \
+ --without-sqlite \
+ --without-gpm-mouse \
+ --with-libgadu
+
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include" \
+ CFLAGS="${CFLAGS} -I${LOCALBASE}/include" \
+ LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib -lintl"
+MAKE_ENV= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include" \
+ CFLAGS="${CFLAGS} -I${LOCALBASE}/include" \
+ LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib"
+
+INSTALLS_SHLIB= yes
+
+.include <bsd.port.mk>
diff --git a/polish/ekg2/distinfo b/polish/ekg2/distinfo
new file mode 100644
index 00000000000..0c28ccd678f
--- /dev/null
+++ b/polish/ekg2/distinfo
@@ -0,0 +1,3 @@
+MD5 (ekg2-20060318.tar.gz) = a6c6678bcc4309f305b209cc4c1f8ce4
+SHA256 (ekg2-20060318.tar.gz) = 4c86af278018db9d41fb7ed23ebb6e9236a4f2a6332ef5c482fe0466e9f620c2
+SIZE (ekg2-20060318.tar.gz) = 893857
diff --git a/polish/ekg2/pkg-descr b/polish/ekg2/pkg-descr
new file mode 100644
index 00000000000..f804b6f48c7
--- /dev/null
+++ b/polish/ekg2/pkg-descr
@@ -0,0 +1,8 @@
+Text-based Gadu-Gadu (and other) client for Unix-like systems.
+Gadu-Gadu is an ICQ-like messenger for polish language users.
+
+EKG2 is similar to EKG. It has many improvements like Jabber
+and IRC plugins. It is considered to be in its development stage,
+so use with care.
+
+WWW: http://ekg2.org/
diff --git a/polish/ekg2/pkg-plist b/polish/ekg2/pkg-plist
new file mode 100644
index 00000000000..406963b9eba
--- /dev/null
+++ b/polish/ekg2/pkg-plist
@@ -0,0 +1,90 @@
+bin/ekg2
+bin/ekg2-config
+lib/ekg2/plugins/logs.so
+lib/ekg2/plugins/logs.la
+lib/ekg2/plugins/mail.so
+lib/ekg2/plugins/mail.la
+lib/ekg2/plugins/rc.so
+lib/ekg2/plugins/rc.la
+lib/ekg2/plugins/sms.so
+lib/ekg2/plugins/sms.la
+lib/ekg2/plugins/pcm.so
+lib/ekg2/plugins/pcm.la
+lib/ekg2/plugins/irc.so
+lib/ekg2/plugins/irc.la
+lib/ekg2/plugins/ioctld.so
+lib/ekg2/plugins/ioctld.la
+lib/ekg2/plugins/gg.so
+lib/ekg2/plugins/gg.la
+lib/ekg2/plugins/sim.so
+lib/ekg2/plugins/sim.la
+lib/ekg2/plugins/jabber.so
+lib/ekg2/plugins/jabber.la
+lib/ekg2/plugins/ncurses.so
+lib/ekg2/plugins/ncurses.la
+libexec/ioctld
+include/ekg2/audio.h
+include/ekg2/char.h
+include/ekg2/configfile.h
+include/ekg2/dynstuff.h
+include/ekg2/events.h
+include/ekg2/metacontacts.h
+include/ekg2/objects.h
+include/ekg2/protocol.h
+include/ekg2/sessions.h
+include/ekg2/themes.h
+include/ekg2/vars.h
+include/ekg2/xmalloc.h
+include/ekg2/commands.h
+include/ekg2/debug.h
+include/ekg2/emoticons.h
+include/ekg2/log.h
+include/ekg2/msgqueue.h
+include/ekg2/plugins.h
+include/ekg2/scripts.h
+include/ekg2/stuff.h
+include/ekg2/userlist.h
+include/ekg2/windows.h
+include/ekg2/gettext.h
+include/ekg2/ekg2-config.h
+share/locale/pl/LC_MESSAGES/ekg2.mo
+share/ekg2/plugins/logs/vars-pl.txt
+share/ekg2/plugins/rc/vars-pl.txt
+share/ekg2/plugins/sms/commands-pl.txt
+share/ekg2/plugins/sms/vars-pl.txt
+share/ekg2/plugins/irc/commands-pl.txt
+share/ekg2/plugins/irc/session-pl.txt
+share/ekg2/plugins/ioctld/commands-pl.txt
+share/ekg2/plugins/gg/vars-pl.txt
+share/ekg2/plugins/gg/vars-en.txt
+share/ekg2/plugins/gg/commands-pl.txt
+share/ekg2/plugins/gg/commands-en.txt
+share/ekg2/plugins/gg/session-pl.txt
+share/ekg2/plugins/gg/session-en.txt
+share/ekg2/plugins/sim/commands-pl.txt
+share/ekg2/plugins/sim/vars-pl.txt
+share/ekg2/plugins/jabber/commands-pl.txt
+share/ekg2/plugins/jabber/session-pl.txt
+share/ekg2/plugins/jabber/vars-pl.txt
+share/ekg2/plugins/jabber/commands-en.txt
+share/ekg2/plugins/jabber/session-en.txt
+share/ekg2/plugins/jabber/vars-en.txt
+share/ekg2/plugins/ncurses/vars-pl.txt
+share/ekg2/vars-pl.txt
+share/ekg2/commands-pl.txt
+@dirrm include/ekg2
+@dirrm share/ekg2/plugins/logs
+@dirrm share/ekg2/plugins/sms
+@dirrm share/ekg2/plugins/irc
+@dirrm share/ekg2/plugins/ioctld
+@dirrm share/ekg2/plugins/rc
+@dirrm share/ekg2/plugins/gg
+@dirrm share/ekg2/plugins/sim
+@dirrm share/ekg2/plugins/jabber
+@dirrm share/ekg2/plugins/ncurses
+@dirrm share/ekg2/plugins
+@dirrm share/ekg2
+@dirrm lib/ekg2/plugins
+@dirrm lib/ekg2
+@dirrmtry share/locale/pl/LC_MESSAGES
+@dirrmtry share/locale/pl