aboutsummaryrefslogtreecommitdiffstats
path: root/ports-mgmt/portlint
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2009-07-19 05:39:07 +0800
committermarcus <marcus@FreeBSD.org>2009-07-19 05:39:07 +0800
commit05f025c468645bfbda5f52e24c7e04c222203884 (patch)
tree03fc732c4b18c8702de93b6cd9023ae8e1c116d7 /ports-mgmt/portlint
parenta427c967c9fd0c7e0ce72055264060f74d7e659e (diff)
downloadfreebsd-ports-graphics-05f025c468645bfbda5f52e24c7e04c222203884.tar.gz
freebsd-ports-graphics-05f025c468645bfbda5f52e24c7e04c222203884.tar.zst
freebsd-ports-graphics-05f025c468645bfbda5f52e24c7e04c222203884.zip
Update to 2.12.1.
* Do not compare a string with undef. [1] * Remove the CONFIGURE_ARGS check for --prefix. This is not part of _LATE_CONFIGURE_ARGS, and thus will be set of all ports. [2] PR: 136657 [1] 136691 [2] Submitted by: glewis [1]
Diffstat (limited to 'ports-mgmt/portlint')
-rw-r--r--ports-mgmt/portlint/Makefile2
-rw-r--r--ports-mgmt/portlint/src/portlint.pl14
2 files changed, 8 insertions, 8 deletions
diff --git a/ports-mgmt/portlint/Makefile b/ports-mgmt/portlint/Makefile
index fdfa471bb51..82df303561f 100644
--- a/ports-mgmt/portlint/Makefile
+++ b/ports-mgmt/portlint/Makefile
@@ -8,7 +8,7 @@
#
PORTNAME= portlint
-PORTVERSION= 2.12.0
+PORTVERSION= 2.12.1
CATEGORIES= ports-mgmt
MASTER_SITES= # none
DISTFILES= # none
diff --git a/ports-mgmt/portlint/src/portlint.pl b/ports-mgmt/portlint/src/portlint.pl
index 2dd59f6ed7d..0b7c2897567 100644
--- a/ports-mgmt/portlint/src/portlint.pl
+++ b/ports-mgmt/portlint/src/portlint.pl
@@ -17,7 +17,7 @@
# OpenBSD and NetBSD will be accepted.
#
# $FreeBSD$
-# $MCom: portlint/portlint.pl,v 1.184 2009/07/09 00:59:29 marcus Exp $
+# $MCom: portlint/portlint.pl,v 1.187 2009/07/18 21:39:30 marcus Exp $
#
use strict;
@@ -50,7 +50,7 @@ $portdir = '.';
# version variables
my $major = 2;
my $minor = 12;
-my $micro = 0;
+my $micro = 1;
sub l { '[{(]'; }
sub r { '[)}]'; }
@@ -911,7 +911,7 @@ sub checkplist {
}
if ($_ =~ m#man/([^/]+/)?man([$manchapters])/([^\.]+\.[$manchapters])(\.gz)?$#) {
- if ($4 eq '') {
+ if (!$4) {
$plistman{$2} .= ' ' . $3;
if ($mancompress) {
&perror("FATAL", $file, $.,
@@ -928,7 +928,7 @@ sub checkplist {
}
}
$plistmanall{$2} .= ' ' . $3;
- if ($1 ne '') {
+ if ($1) {
$manlangs{substr($1, 0, length($1) - 1)}++;
}
}
@@ -1960,13 +1960,13 @@ ruby sed sh sort sysctl touch tr which xargs xmkmf
}
#
- # whole file: check for --build, --mandir, --infodir, and --prefix
+ # whole file: check for --build, --mandir, and --infodir
# when GNU_CONFIGURE
#
if (exists $makevar{GNU_CONFIGURE} &&
$makevar{GNU_CONFIGURE} ne '' &&
- $makevar{CONFIGURE_ARGS} =~ /--(prefix|build|(man|info)dir)/) {
- &perror("WARN", $file, -1, "--build, --mandir, --infodir and --prefix ".
+ $makevar{CONFIGURE_ARGS} =~ /--(build|(man|info)dir)/) {
+ &perror("WARN", $file, -1, "--build, --mandir, and --infodir ".
"are not needed in CONFIGURE_ARGS as they are already set in ".
"bsd.port.mk.");
}