aboutsummaryrefslogtreecommitdiffstats
path: root/ports-mgmt/portlint
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2005-10-25 12:48:06 +0800
committermarcus <marcus@FreeBSD.org>2005-10-25 12:48:06 +0800
commit0a921c617b5ff6f20401c915b241a04fb6cf0c81 (patch)
treec46638fd9c3dcff73930056220018dfd99fc961e /ports-mgmt/portlint
parent1bbab20fde51294ae8b911b4fd82bf659a69906e (diff)
downloadfreebsd-ports-graphics-0a921c617b5ff6f20401c915b241a04fb6cf0c81.tar.gz
freebsd-ports-graphics-0a921c617b5ff6f20401c915b241a04fb6cf0c81.tar.zst
freebsd-ports-graphics-0a921c617b5ff6f20401c915b241a04fb6cf0c81.zip
Correct compilation with perl 5.005.
Diffstat (limited to 'ports-mgmt/portlint')
-rw-r--r--ports-mgmt/portlint/Makefile1
-rw-r--r--ports-mgmt/portlint/src/portlint.pl4
2 files changed, 3 insertions, 2 deletions
diff --git a/ports-mgmt/portlint/Makefile b/ports-mgmt/portlint/Makefile
index 3f5da09594d..66ef339b282 100644
--- a/ports-mgmt/portlint/Makefile
+++ b/ports-mgmt/portlint/Makefile
@@ -9,6 +9,7 @@
PORTNAME= portlint
PORTVERSION= 2.7.5
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= # none
DISTFILES= # none
diff --git a/ports-mgmt/portlint/src/portlint.pl b/ports-mgmt/portlint/src/portlint.pl
index 20a32d269da..1216954960c 100644
--- a/ports-mgmt/portlint/src/portlint.pl
+++ b/ports-mgmt/portlint/src/portlint.pl
@@ -17,7 +17,7 @@
# OpenBSD and NetBSD will be accepted.
#
# $FreeBSD$
-# $MCom: portlint/portlint.pl,v 1.89 2005/10/22 19:43:02 marcus Exp $
+# $MCom: portlint/portlint.pl,v 1.90 2005/10/25 04:46:34 marcus Exp $
#
use vars qw/ $opt_a $opt_A $opt_b $opt_C $opt_c $opt_h $opt_t $opt_v $opt_M $opt_N $opt_B $opt_V /;
@@ -1191,7 +1191,7 @@ sub checkmakefile {
# whole file: BROKEN et al.
#
my($var);
- foreach $var qw(BROKEN FORBIDDEN MANUAL_PACKAGE_BUILD NO_CDROM NO_PACKAGE RESTRICTED) {
+ foreach $var (qw(BROKEN FORBIDDEN MANUAL_PACKAGE_BUILD NO_CDROM NO_PACKAGE RESTRICTED)) {
print "OK: checking ${var}.\n" if ($verbose);
if ($whole =~ /\n${var}[+?]?=[ \t]?[^"]+\w+/) {
my $lineno = &linenumber($`);