aboutsummaryrefslogtreecommitdiffstats
path: root/ports-mgmt/portlint
diff options
context:
space:
mode:
authorade <ade@FreeBSD.org>2010-12-04 15:34:27 +0800
committerade <ade@FreeBSD.org>2010-12-04 15:34:27 +0800
commita44c192a2f5c31ae449c6b008b8a42bcc7ee099d (patch)
tree14d9392b22ced431dae442dd74506f7e26011de3 /ports-mgmt/portlint
parentdb3ee9b87911306ae5e8d8b79d43c0e4c925954d (diff)
downloadfreebsd-ports-graphics-a44c192a2f5c31ae449c6b008b8a42bcc7ee099d.tar.gz
freebsd-ports-graphics-a44c192a2f5c31ae449c6b008b8a42bcc7ee099d.tar.zst
freebsd-ports-graphics-a44c192a2f5c31ae449c6b008b8a42bcc7ee099d.zip
Sync to new bsd.autotools.mk
Diffstat (limited to 'ports-mgmt/portlint')
-rw-r--r--ports-mgmt/portlint/src/portlint.pl22
1 files changed, 1 insertions, 21 deletions
diff --git a/ports-mgmt/portlint/src/portlint.pl b/ports-mgmt/portlint/src/portlint.pl
index 52677de8cb4..db57916ab69 100644
--- a/ports-mgmt/portlint/src/portlint.pl
+++ b/ports-mgmt/portlint/src/portlint.pl
@@ -1339,7 +1339,6 @@ sub checkmakefile {
my(@mopt, @oopt);
my($pkg_version, $versiondir, $versionfile) = ('', '', '');
my $useindex = 0;
- my %autotools_deprecated = ();
my %deprecated = ();
my @deplist = ();
my %autocmdnames = ();
@@ -1736,25 +1735,6 @@ sub checkmakefile {
# whole file: check for deprecated commands
#
print "OK: checking for deprecated macros.\n" if $verbose;
- %autotools_deprecated = (
- USE_LIBTOOL => 'USE_AUTOTOOLS',
- USE_AUTOCONF => 'USE_AUTOTOOLS',
- USE_AUTOMAKE => 'USE_AUTOTOOLS',
- WANT_LIBTOOL => 'USE_AUTOTOOLS',
- WANT_AUTOCONF => 'USE_AUTOTOOLS',
- WANT_AUTOMAKE => 'USE_AUTOTOOLS',
- USE_LIBLTDL => 'USE_AUTOTOOLS',
- USE_LIBTOOL_VER => 'USE_AUTOTOOLS',
- WANT_LIBTOOL_VER => 'USE_AUTOTOOLS',
- USE_INC_LIBTOOL_VER => 'USE_AUTOTOOLS',
- WANT_AUTOMAKE_VER => 'USE_AUTOTOOLS',
- USE_AUTOMAKE_VER => 'USE_AUTOTOOLS',
- USE_ACLOCAL_VER => 'USE_AUTOTOOLS',
- USE_AUTOHEADER_VER => 'USE_AUTOTOOLS',
- USE_AUTOCONF_VER => 'USE_AUTOTOOLS',
- WANT_AUTOCONF_VER => 'USE_AUTOTOOLS',
- __HELP__ => 'http://www.freebsd.org/doc/en_US.ISO8859-1/books/porters-handbook/using-autotools.html',
- );
%deprecated = (
USE_MESA => 'USE_GL',
@@ -1763,7 +1743,7 @@ sub checkmakefile {
APACHE_COMPAT => 'USE_APACHE',
);
- @deplist = (\%autotools_deprecated, \%deprecated);
+ @deplist = (\%deprecated);
for my $dlst (@deplist) {
my $hurl = $dlst->{'__HELP__'};