aboutsummaryrefslogtreecommitdiffstats
path: root/ports-mgmt/portmanager/Makefile
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2005-01-19 21:26:56 +0800
committerpav <pav@FreeBSD.org>2005-01-19 21:26:56 +0800
commita3bdc56e8e95f07bbe31a88240eb2f9276a872b2 (patch)
treed9ab303d4f9200f8c63a1401967d7afe40a0073e /ports-mgmt/portmanager/Makefile
parent3bc264f1df313eaac27413f2e09b36c0855a32f5 (diff)
downloadfreebsd-ports-graphics-a3bdc56e8e95f07bbe31a88240eb2f9276a872b2.tar.gz
freebsd-ports-graphics-a3bdc56e8e95f07bbe31a88240eb2f9276a872b2.tar.zst
freebsd-ports-graphics-a3bdc56e8e95f07bbe31a88240eb2f9276a872b2.zip
- Update to 0.2.3
PR: ports/76453 Submitted by: Michael C. Shultz <reso3w83@verizon.net> (maintainer)
Diffstat (limited to 'ports-mgmt/portmanager/Makefile')
-rw-r--r--ports-mgmt/portmanager/Makefile20
1 files changed, 11 insertions, 9 deletions
diff --git a/ports-mgmt/portmanager/Makefile b/ports-mgmt/portmanager/Makefile
index e8f1ce18856..2b088d09a49 100644
--- a/ports-mgmt/portmanager/Makefile
+++ b/ports-mgmt/portmanager/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= portmanager
-PORTVERSION= 0.2.2
+PORTVERSION= 0.2.3
PORTREVISION= 0
#-----------------------------------------
#for local use, remove before submitting PR
@@ -14,8 +14,9 @@ CATEGORIES= sysutils
#CATEGORIES= local/sysutils
#VALID_CATEGORIES+= ${CATEGORIES} # for FreeBSD to accept our local category
#-----------------------------------------
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= portmanager
+#MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+#MASTER_SITE_SUBDIR= portmanager
+MASTER_SITES= http://www.pkix.net/mirror/sf.net/
MAINTAINER= reso3w83@verizon.net
COMMENT= FreeBSD port management software
@@ -27,6 +28,11 @@ BUILD_DEPENDS= autoheader259:${PORTSDIR}/devel/autoconf259 \
.endif
MAN1= portmanager.1
+MAN3= libMG.3 \
+ MGdbCreate.3 \
+ MGdbGetRecordQty.3 \
+ MGdbGoTop.3 \
+ MGdbSeek.3
USE_GMAKE= yes
GNU_CONFIGURE= yes
@@ -34,18 +40,14 @@ CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
INSTALLS_SHLIB= yes
USE_REINPLACE= yes
# Need INSTALL_TARGET to install /usr/local/etc/portmanager/pm-020.conf.SAMPLE
-INSTALL_TARGET= install info
+INSTALL_TARGET= install info
post-patch:
@${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g ; \
- s|0.2.2|${PORTVERSION}_${PORTREVISION}|g ; \
+ s|0.2.3|${PORTVERSION}_${PORTREVISION}|g ; \
s|%%PORTSDIR%%|${PORTSDIR}|g ; \
s|%%PKG_DBDIR%%|${PKG_DBDIR}|g' ${WRKSRC}/libPMGR/src/libPMGR.h
- @${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g ; \
- s|%%PORTSDIR%%|${PORTSDIR}|g ; \
- s|%%PKG_DBDIR%%|${PKG_DBDIR}|g' ${WRKSRC}/libPMGR/src/PMGRrMakeDescribe.c
-
# Only way to get WITH_DEBUG build dependencies handled prior to reconfiguring
# is to use post-configure <sigh>
post-configure: