aboutsummaryrefslogtreecommitdiffstats
path: root/ports-mgmt/portmanager/Makefile
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2005-02-09 20:48:10 +0800
committerpav <pav@FreeBSD.org>2005-02-09 20:48:10 +0800
commitd731881d0bbc1859707b9a9a432113d20d8dd3f9 (patch)
tree0f2dcaf8e97a0a1eb195cbf09208c813e02d2ff7 /ports-mgmt/portmanager/Makefile
parent5616b89fc93b317a3b166293d8cdfa3e26d16b1d (diff)
downloadfreebsd-ports-graphics-d731881d0bbc1859707b9a9a432113d20d8dd3f9.tar.gz
freebsd-ports-graphics-d731881d0bbc1859707b9a9a432113d20d8dd3f9.tar.zst
freebsd-ports-graphics-d731881d0bbc1859707b9a9a432113d20d8dd3f9.zip
- Update to 0.2.6_2:
There may be a bug in edge cases where a port name originates from multiple usr/ports directories. Patch allows printing of useful information if this happens and hopefully traps the bug with assert statements. PR: ports/77276 Submitted by: Michael C. Shultz <reso3w83@verizon.net> (maintainer)
Diffstat (limited to 'ports-mgmt/portmanager/Makefile')
-rw-r--r--ports-mgmt/portmanager/Makefile29
1 files changed, 21 insertions, 8 deletions
diff --git a/ports-mgmt/portmanager/Makefile b/ports-mgmt/portmanager/Makefile
index aa8ea4929e4..013f51e0440 100644
--- a/ports-mgmt/portmanager/Makefile
+++ b/ports-mgmt/portmanager/Makefile
@@ -7,7 +7,7 @@
PORTNAME= portmanager
PORTVERSION= 0.2.6
-PORTREVISION= 1
+PORTREVISION= 2
#-----------------------------------------
#for local use, remove before submitting PR
CATEGORIES= sysutils
@@ -41,18 +41,31 @@ CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
#CONFIGURE_ARGS= --with-debug=yes
#.endif
-#CONFIGURE_ARGS= --with-prefix=${PREFIX} \
-# --with-bindir=/bin \
-# --with-etcdir=${PREFIX}/etc/portmanager \
-# --with-pkgdbdir=${PKG_DBDIR} \
-# --with-portsdir=${PORTSDIR} \
-# --with-sharedir=${DATADIR} \
-# --with-tempdir=/tmp
+#
+# if --with-bin=something then withvar=${PREFIX} + something
+# else defaults to withvar=${PREFIX} + /bin
+#
+# so --with-bindir=/bin will become ${PREFIX}/bin at configure
+# time.
+#
+CONFIGURE_ARGS= --with-prefix=${PREFIX} \
+ --with-bindir=/bin \
+ --with-etcdir=/etc/portmanager \
+ --with-pkgdbdir=/var/db/pkg \
+ --with-portsdir=${PORTSDIR} \
+ --with-sharedir=/share/portmanager \
+ --with-tempdir=/tmp
INSTALLS_SHLIB= yes
+USE_REINPLACE= yes
# Need INSTALL_TARGET to install ${PREFIX}/etc/portmanager/pm-020.conf.SAMPLE
INSTALL_TARGET= install info
+post-configure:
+ @${REINPLACE_CMD} -e \
+ 's|VERSION "${PORTVERSION}"|VERSION "${PORTVERSION}_${PORTREVISION}"|g' \
+ ${WRKSRC}/externVars.h
+
post-install:
@${ECHO} "***********************************************************************"
@${ECHO} "* portmanager *"