aboutsummaryrefslogtreecommitdiffstats
path: root/ports-mgmt/portupgrade-devel/Makefile
diff options
context:
space:
mode:
authorsem <sem@FreeBSD.org>2006-11-07 03:51:14 +0800
committersem <sem@FreeBSD.org>2006-11-07 03:51:14 +0800
commit7c3f9900d34d491f760f2ed4ecd539ce7eb21715 (patch)
treeb9c2ed3e0392c13243f87cc22a4cc5ad920155f0 /ports-mgmt/portupgrade-devel/Makefile
parent2170608af7fd2b546434055877e1c4bb1df92ca6 (diff)
downloadfreebsd-ports-graphics-7c3f9900d34d491f760f2ed4ecd539ce7eb21715.tar.gz
freebsd-ports-graphics-7c3f9900d34d491f760f2ed4ecd539ce7eb21715.tar.zst
freebsd-ports-graphics-7c3f9900d34d491f760f2ed4ecd539ce7eb21715.zip
- Update to 2.2.0
* Respect INDEXDIR after fetching INDEX (Andrew Pantyukhin <sat@FreeBSD.org>) * Add --batch opition. * Add --without-env-upgrade option. * Remove -DPACKAGE_BUILDING (it was in fetch-only mode) because it's only for build cluster, not users. (Pointed out by kris@FreeBSD.org) * Add detection of stale lock files. They can stay if one of tools suddenly terminated. * Improve pkgdb -F - respect OPTIONS and pkgtools.conf settings.
Diffstat (limited to 'ports-mgmt/portupgrade-devel/Makefile')
-rw-r--r--ports-mgmt/portupgrade-devel/Makefile12
1 files changed, 7 insertions, 5 deletions
diff --git a/ports-mgmt/portupgrade-devel/Makefile b/ports-mgmt/portupgrade-devel/Makefile
index 53e85171c9e..b46f18f17e5 100644
--- a/ports-mgmt/portupgrade-devel/Makefile
+++ b/ports-mgmt/portupgrade-devel/Makefile
@@ -6,10 +6,9 @@
#
PORTNAME= portupgrade-devel
-PORTVERSION= 2.1.7
+PORTVERSION= 2.2.0
CATEGORIES= sysutils
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
- http://sunner.elcomnet.ru/~sem/
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= portupgrade
DISTNAME= pkgtools-${DISTVERSION}
@@ -25,8 +24,8 @@ USE_BZIP2= yes
USE_RUBY= yes
USE_RUBY_FEATURES= optparse ruby18
USE_PERL5_RUN= yes
-
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= ${PREFIX}/lib/compat/pkg
+LDCONFIG_DIRS= %%PREFIX%%/lib/compat/pkg
MAKE_ARGS= PREFIX="${PREFIX}" RUBY="${RUBY}"
@@ -46,6 +45,9 @@ MLINKS= pkgdb.1 pkg_which.1 \
portsdb.1 ports_glob.1
MANCOMPRESSED= maybe
+EXAMPLESDIR= ${PREFIX}/share/examples/pkgtools
+DOCSDIR= ${PREFIX}/share/doc/pkgtools
+
INSTALL_TARGET= install
.if !defined(NOPORTDOCS)
INSTALL_TARGET+= install-doc