aboutsummaryrefslogtreecommitdiffstats
path: root/ports-mgmt
diff options
context:
space:
mode:
authoritetcu <itetcu@FreeBSD.org>2006-06-12 06:24:10 +0800
committeritetcu <itetcu@FreeBSD.org>2006-06-12 06:24:10 +0800
commit0e29799fc91b99c489eb12a30e4f70ca6985efcf (patch)
treef5391ae49524200ef7c6052f11a86f4d9dc7674e /ports-mgmt
parent450d42fdbf0b937f69b99b5073a69fa30c17c5ef (diff)
downloadfreebsd-ports-graphics-0e29799fc91b99c489eb12a30e4f70ca6985efcf.tar.gz
freebsd-ports-graphics-0e29799fc91b99c489eb12a30e4f70ca6985efcf.tar.zst
freebsd-ports-graphics-0e29799fc91b99c489eb12a30e4f70ca6985efcf.zip
- Fix OPTION checking [1]
- allow to depend on csup (default) or cvsup [2] - default database is now mysql [2] This port still needs a lot of work and it would be great if one of the wizards that know tindy's insides would take maintainership (current maintainer seem to be gone, no feedback rom him for > 1 month). PR: ports/97433 [1] Submitted by: Shaun Amott <shaun@inerd.com> [1] itetrcu (me) Approved by: lawrance (mentor)
Diffstat (limited to 'ports-mgmt')
-rw-r--r--ports-mgmt/tinderbox-devel/Makefile31
-rw-r--r--ports-mgmt/tinderbox-devel/distinfo6
-rw-r--r--ports-mgmt/tinderbox-devel/pkg-plist2
-rw-r--r--ports-mgmt/tinderbox/Makefile31
-rw-r--r--ports-mgmt/tinderbox/distinfo6
-rw-r--r--ports-mgmt/tinderbox/pkg-plist2
6 files changed, 54 insertions, 24 deletions
diff --git a/ports-mgmt/tinderbox-devel/Makefile b/ports-mgmt/tinderbox-devel/Makefile
index 57f2fbc24af..fc5b776993b 100644
--- a/ports-mgmt/tinderbox-devel/Makefile
+++ b/ports-mgmt/tinderbox-devel/Makefile
@@ -5,8 +5,7 @@
# $FreeBSD$
PORTNAME= tinderbox
-PORTVERSION= 2.3.0
-PORTREVISION= 2
+PORTVERSION= 2.3.1
CATEGORIES= misc
MASTER_SITES= http://tinderbox.marcuscom.com/
@@ -16,20 +15,24 @@ COMMENT= Port build tinderbox system
RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5 \
${SITE_PERL}/Net/SMTP.pm:${PORTSDIR}/net/p5-Net \
${LOCALBASE}/share/pear/DB.php:${PORTSDIR}/databases/pear-DB \
- cvsup:${PORTSDIR}/net/cvsup-without-gui
-OPTIONS= PGSQL "With pgsql" On \
- MYSQL "With mysql" Off
+OPTIONS= PGSQL "With pgsql" Off \
+ MYSQL "With mysql" On \
+ CSUP "Use csup for updates" On \
+ CVSUP "Use cvsup for updates" Off
NO_BUILD= yes
USE_APACHE= 1.3+
SUB_FILES= pkg-message
PKGMESSAGE= ${WRKDIR}/pkg-message
+MAN1= tc-configCcache.1 tc-configDistfile.1 tc-configGet.1 \
+ tc-configJail.1 tc-configTinderd.1 tc-init.1
+
.include <bsd.port.pre.mk>
.if defined(WITHOUT_PGSQL) && defined(WITHOUT_MYSQL)
-BROKEN= Tinderbox is useless without a database. Please (re)run 'make config' and choose one of PGSQL and MYSQL
+IGNORE= is useless without a database. Please (re)run 'make config' and choose one of PGSQL and MYSQL
.endif
USE_PHP= session
@@ -40,12 +43,20 @@ USE_PHP+= pgsql
RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBD/Pg.pm:${PORTSDIR}/databases/p5-DBD-Pg
.endif
-.if defined(WITH_MYSQL)
+.if !defined(WITHOUT_MYSQL)
USE_PHP+= mysql
USE_MYSQL= yes
RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBD/mysql.pm:${PORTSDIR}/databases/p5-DBD-mysql${MYSQL_VER}
.endif
+.if defined(WITH_CSUP)
+RUN_DEPENDS+= csup:${PORTSDIR}/net/csup
+.endif
+
+.if defined(WITH_CVSUP)
+RUN_DEPENDS+= cvsup:${PORTSDIR}/net/cvsup-without-gui
+.endif
+
.include "${PORTSDIR}/Mk/bsd.php.mk"
post-extract:
@@ -55,9 +66,10 @@ post-extract:
post-patch:
.if defined(WITH_MYSQL)
- ${REINPLACE_CMD} \
+ @${REINPLACE_CMD} \
-e 's,DB_MAN_PREREQS=.*,DB_MAN_PREREQS="databases/p5-DBD-mysql${MYSQL_VER} databases/mysql${MYSQL_VER}-client",' \
${WRKSRC}/lib/setup-mysql.sh
+ @${RM} ${WRKSRC}/lib/setup-mysql.sh.bak
.endif
do-install:
@@ -65,6 +77,7 @@ do-install:
${CP} -R ${WRKSRC}/* ${PREFIX}/tinderbox/scripts
post-install:
- ${CAT} ${PKGMESSAGE}
+ cd ${WRKSRC}/man/man1 && ${INSTALL_MAN} ${MAN1} ${MAN1PREFIX}/man/man1
+ @${CAT} ${PKGMESSAGE}
.include <bsd.port.post.mk>
diff --git a/ports-mgmt/tinderbox-devel/distinfo b/ports-mgmt/tinderbox-devel/distinfo
index fefebbeedd7..6c1a8e80946 100644
--- a/ports-mgmt/tinderbox-devel/distinfo
+++ b/ports-mgmt/tinderbox-devel/distinfo
@@ -1,3 +1,3 @@
-MD5 (tinderbox-2.3.0.tar.gz) = 4bd33a1ac8a31ec3e62b42f5307a587d
-SHA256 (tinderbox-2.3.0.tar.gz) = a3062b98688ac50ac3c50c94f1f3a27334bfb2479f8d83cabb0f8b263dc7fba7
-SIZE (tinderbox-2.3.0.tar.gz) = 118046
+MD5 (tinderbox-2.3.1.tar.gz) = f92ff04fa6fef815b6238e164e019752
+SHA256 (tinderbox-2.3.1.tar.gz) = fbeb316c039196c4509231dce374759476a7aa836be333dc8c1656fed71e87b0
+SIZE (tinderbox-2.3.1.tar.gz) = 120573
diff --git a/ports-mgmt/tinderbox-devel/pkg-plist b/ports-mgmt/tinderbox-devel/pkg-plist
index 7b5386940c5..5b7e87d504c 100644
--- a/ports-mgmt/tinderbox-devel/pkg-plist
+++ b/ports-mgmt/tinderbox-devel/pkg-plist
@@ -48,8 +48,10 @@ tinderbox/scripts/upgrade/mig_mysql_tinderbox-2.0.0_to_2.1.0.sql
tinderbox/scripts/upgrade/mig_mysql_tinderbox-2.1.0_to_2.1.1.sql
tinderbox/scripts/upgrade/mig_mysql_tinderbox-2.1.1_to_2.2.0.sql
tinderbox/scripts/upgrade/mig_mysql_tinderbox-2.2.0_to_2.3.0.sql
+tinderbox/scripts/upgrade/mig_mysql_tinderbox-2.3.0_to_2.3.1.sql
tinderbox/scripts/upgrade/mig_pgsql_tinderbox-2.1.1_to_2.2.0.sql
tinderbox/scripts/upgrade/mig_pgsql_tinderbox-2.2.0_to_2.3.0.sql
+tinderbox/scripts/upgrade/mig_pgsql_tinderbox-2.3.0_to_2.3.1.sql
tinderbox/scripts/upgrade/mig_shlib.sh
tinderbox/scripts/www-exp/core/Build.php
tinderbox/scripts/www-exp/core/BuildPortsQueue.php
diff --git a/ports-mgmt/tinderbox/Makefile b/ports-mgmt/tinderbox/Makefile
index 57f2fbc24af..fc5b776993b 100644
--- a/ports-mgmt/tinderbox/Makefile
+++ b/ports-mgmt/tinderbox/Makefile
@@ -5,8 +5,7 @@
# $FreeBSD$
PORTNAME= tinderbox
-PORTVERSION= 2.3.0
-PORTREVISION= 2
+PORTVERSION= 2.3.1
CATEGORIES= misc
MASTER_SITES= http://tinderbox.marcuscom.com/
@@ -16,20 +15,24 @@ COMMENT= Port build tinderbox system
RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5 \
${SITE_PERL}/Net/SMTP.pm:${PORTSDIR}/net/p5-Net \
${LOCALBASE}/share/pear/DB.php:${PORTSDIR}/databases/pear-DB \
- cvsup:${PORTSDIR}/net/cvsup-without-gui
-OPTIONS= PGSQL "With pgsql" On \
- MYSQL "With mysql" Off
+OPTIONS= PGSQL "With pgsql" Off \
+ MYSQL "With mysql" On \
+ CSUP "Use csup for updates" On \
+ CVSUP "Use cvsup for updates" Off
NO_BUILD= yes
USE_APACHE= 1.3+
SUB_FILES= pkg-message
PKGMESSAGE= ${WRKDIR}/pkg-message
+MAN1= tc-configCcache.1 tc-configDistfile.1 tc-configGet.1 \
+ tc-configJail.1 tc-configTinderd.1 tc-init.1
+
.include <bsd.port.pre.mk>
.if defined(WITHOUT_PGSQL) && defined(WITHOUT_MYSQL)
-BROKEN= Tinderbox is useless without a database. Please (re)run 'make config' and choose one of PGSQL and MYSQL
+IGNORE= is useless without a database. Please (re)run 'make config' and choose one of PGSQL and MYSQL
.endif
USE_PHP= session
@@ -40,12 +43,20 @@ USE_PHP+= pgsql
RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBD/Pg.pm:${PORTSDIR}/databases/p5-DBD-Pg
.endif
-.if defined(WITH_MYSQL)
+.if !defined(WITHOUT_MYSQL)
USE_PHP+= mysql
USE_MYSQL= yes
RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBD/mysql.pm:${PORTSDIR}/databases/p5-DBD-mysql${MYSQL_VER}
.endif
+.if defined(WITH_CSUP)
+RUN_DEPENDS+= csup:${PORTSDIR}/net/csup
+.endif
+
+.if defined(WITH_CVSUP)
+RUN_DEPENDS+= cvsup:${PORTSDIR}/net/cvsup-without-gui
+.endif
+
.include "${PORTSDIR}/Mk/bsd.php.mk"
post-extract:
@@ -55,9 +66,10 @@ post-extract:
post-patch:
.if defined(WITH_MYSQL)
- ${REINPLACE_CMD} \
+ @${REINPLACE_CMD} \
-e 's,DB_MAN_PREREQS=.*,DB_MAN_PREREQS="databases/p5-DBD-mysql${MYSQL_VER} databases/mysql${MYSQL_VER}-client",' \
${WRKSRC}/lib/setup-mysql.sh
+ @${RM} ${WRKSRC}/lib/setup-mysql.sh.bak
.endif
do-install:
@@ -65,6 +77,7 @@ do-install:
${CP} -R ${WRKSRC}/* ${PREFIX}/tinderbox/scripts
post-install:
- ${CAT} ${PKGMESSAGE}
+ cd ${WRKSRC}/man/man1 && ${INSTALL_MAN} ${MAN1} ${MAN1PREFIX}/man/man1
+ @${CAT} ${PKGMESSAGE}
.include <bsd.port.post.mk>
diff --git a/ports-mgmt/tinderbox/distinfo b/ports-mgmt/tinderbox/distinfo
index fefebbeedd7..6c1a8e80946 100644
--- a/ports-mgmt/tinderbox/distinfo
+++ b/ports-mgmt/tinderbox/distinfo
@@ -1,3 +1,3 @@
-MD5 (tinderbox-2.3.0.tar.gz) = 4bd33a1ac8a31ec3e62b42f5307a587d
-SHA256 (tinderbox-2.3.0.tar.gz) = a3062b98688ac50ac3c50c94f1f3a27334bfb2479f8d83cabb0f8b263dc7fba7
-SIZE (tinderbox-2.3.0.tar.gz) = 118046
+MD5 (tinderbox-2.3.1.tar.gz) = f92ff04fa6fef815b6238e164e019752
+SHA256 (tinderbox-2.3.1.tar.gz) = fbeb316c039196c4509231dce374759476a7aa836be333dc8c1656fed71e87b0
+SIZE (tinderbox-2.3.1.tar.gz) = 120573
diff --git a/ports-mgmt/tinderbox/pkg-plist b/ports-mgmt/tinderbox/pkg-plist
index 7b5386940c5..5b7e87d504c 100644
--- a/ports-mgmt/tinderbox/pkg-plist
+++ b/ports-mgmt/tinderbox/pkg-plist
@@ -48,8 +48,10 @@ tinderbox/scripts/upgrade/mig_mysql_tinderbox-2.0.0_to_2.1.0.sql
tinderbox/scripts/upgrade/mig_mysql_tinderbox-2.1.0_to_2.1.1.sql
tinderbox/scripts/upgrade/mig_mysql_tinderbox-2.1.1_to_2.2.0.sql
tinderbox/scripts/upgrade/mig_mysql_tinderbox-2.2.0_to_2.3.0.sql
+tinderbox/scripts/upgrade/mig_mysql_tinderbox-2.3.0_to_2.3.1.sql
tinderbox/scripts/upgrade/mig_pgsql_tinderbox-2.1.1_to_2.2.0.sql
tinderbox/scripts/upgrade/mig_pgsql_tinderbox-2.2.0_to_2.3.0.sql
+tinderbox/scripts/upgrade/mig_pgsql_tinderbox-2.3.0_to_2.3.1.sql
tinderbox/scripts/upgrade/mig_shlib.sh
tinderbox/scripts/www-exp/core/Build.php
tinderbox/scripts/www-exp/core/BuildPortsQueue.php