aboutsummaryrefslogtreecommitdiffstats
path: root/ports-mgmt
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2012-03-30 15:34:00 +0800
committerbapt <bapt@FreeBSD.org>2012-03-30 15:34:00 +0800
commit7a84425fc42558043b627acfd0125f7b8bf7ea58 (patch)
treeac8a6162938a1e0f8db07559e42e67f25956a319 /ports-mgmt
parente5e6a8fde60eb6a7754a440a5f007b63232efe3d (diff)
downloadfreebsd-ports-graphics-7a84425fc42558043b627acfd0125f7b8bf7ea58.tar.gz
freebsd-ports-graphics-7a84425fc42558043b627acfd0125f7b8bf7ea58.tar.zst
freebsd-ports-graphics-7a84425fc42558043b627acfd0125f7b8bf7ea58.zip
- update to 1.0-beta9
- changes: * query -f has been replaced by query -F when querying a package (file) for consistency with pkg info * fix autoremove recursion * pkg set -o oldorigin:neworigin allow the user to modify the origin of a packages (useful for MOVED) * several fixes on powerpc * pkg query evaluation expression now accept != * pkg2ng is now able to migrate a local database without needed the ports tree * speed up pkg check by only loading the informations needed for the operation it will do * code cleanup in the library * fix uname/gname lookup when creating packages * new periodic script for pkg audit * new keyword shlib, pkgng is able to load information about the needed shlibs for a package (disable by default) * pkg info act as pkg info -a by default * new install timestamp in the package database, available using pkg query "%t" * pkg updating can now take a port name as argument to only show related UPDATING informations) * -q (quiet) for install, delete, upgrade, update and autoremove * new ABI detection string Concerning the new ABI, to be able to determine which package can be installed on which destination, pkgng couldn't rely on the simple: os version/machine, because some arches have incompatible ABIs. Can compute on its own the ABI, the string is the followin: OSNAME:OSMAJORVERSION:OSARCH:OSCLASS(:...) ... means the arch specific extensions. which means on: * amd64: freebsd:9:x86:64 * i386: freebsd:9:x86 * arm: freebsd:9:arm:eb:oabi:softvp etc Be careful all the packages (.txz) files have to be rebuilt!!! When binary upgradeing from pkg beta8, on amd64 do the following: UNAME_m=freebsd:9:x86:64 pkg install -f pkg on i386 UNAME_m=freebsd:9:x86:32 pkg install -f pkg Bonus when run on a chroot/jail where ABI is different from the host, pkgng will dynamically determine the destination ABI. Feature safe: yes
Diffstat (limited to 'ports-mgmt')
-rw-r--r--ports-mgmt/pkg/Makefile15
-rw-r--r--ports-mgmt/pkg/distinfo4
-rw-r--r--ports-mgmt/pkg/pkg-plist10
3 files changed, 17 insertions, 12 deletions
diff --git a/ports-mgmt/pkg/Makefile b/ports-mgmt/pkg/Makefile
index 36941bfc1af..aec467d81aa 100644
--- a/ports-mgmt/pkg/Makefile
+++ b/ports-mgmt/pkg/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= pkg
-DISTVERSION= 1.0-beta8
+DISTVERSION= 1.0-beta9
CATEGORIES= ports-mgmt
MASTER_SITES= LOCAL/portmgr \
http://files.etoilebsd.net/pkg/
@@ -16,7 +16,7 @@ COMMENT= New generation package manager
LICENSE= BSD
-USE_BZIP2= yes
+USE_XZ= yes
USE_LDCONFIG= yes
MANCOMPRESSED= yes
@@ -43,14 +43,6 @@ MAN8= pkg.8 \
pkg-which.8
MAN5= pkg.conf.5
-PLIST_FILES= sbin/pkg \
- sbin/pkg-static \
- sbin/pkg2ng \
- include/pkg.h \
- lib/libpkg.so.0 \
- lib/libpkg.so \
- lib/libpkg.a
-
.include <bsd.port.pre.mk>
#define PKG_DEPENDS to nothing to avoid infinite loop looking for pkg :)
@@ -67,6 +59,9 @@ IGNORE= not supported on 7.x or early 8.0
.endif
post-install:
+ @${REINPLACE_CMD} -e 's|/usr/local|${PREFIX}|g' ${WRKSRC}/scripts/periodic/410.pkg-audit
+ @${MKDIR} ${PREFIX}/etc/periodic/security
+ @${INSTALL_SCRIPT} ${WRKSRC}/scripts/periodic/410.pkg-audit ${PREFIX}/etc/periodic/security
@${INSTALL_SCRIPT} ${WRKSRC}/ports/pkg2ng ${PREFIX}/sbin
@${CAT} ${PKGMESSAGE}
diff --git a/ports-mgmt/pkg/distinfo b/ports-mgmt/pkg/distinfo
index 49358171878..44e4676de44 100644
--- a/ports-mgmt/pkg/distinfo
+++ b/ports-mgmt/pkg/distinfo
@@ -1,2 +1,2 @@
-SHA256 (pkg-1.0-beta8.tar.bz2) = 3b772dcdb99af385e54ed5a4bbca631ae54e005c3c6d5afeda03119c367d6860
-SIZE (pkg-1.0-beta8.tar.bz2) = 1477364
+SHA256 (pkg-1.0-beta9.tar.xz) = acf1e8db9a0921009f0fdec0365b76f823b0483fabf2c2eeed4015c21955588f
+SIZE (pkg-1.0-beta9.tar.xz) = 1298464
diff --git a/ports-mgmt/pkg/pkg-plist b/ports-mgmt/pkg/pkg-plist
new file mode 100644
index 00000000000..07132dc2ebf
--- /dev/null
+++ b/ports-mgmt/pkg/pkg-plist
@@ -0,0 +1,10 @@
+sbin/pkg
+sbin/pkg-static
+sbin/pkg2ng
+include/pkg.h
+lib/libpkg.so.0
+lib/libpkg.so
+lib/libpkg.a
+etc/periodic/security/410.pkg-audit
+@dirrmtry etc/periodic/security
+@dirrmtry etc/periodic