aboutsummaryrefslogtreecommitdiffstats
path: root/ports-mgmt
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2009-02-13 00:46:23 +0800
committerpav <pav@FreeBSD.org>2009-02-13 00:46:23 +0800
commitdd54e702b369ec8748da6a90659acb155d74504f (patch)
treed85287a4386722791bf91220cd77174b84ddfe89 /ports-mgmt
parente4f1e0d91d16bfd24a5076b1194603e8aebf73aa (diff)
downloadfreebsd-ports-graphics-dd54e702b369ec8748da6a90659acb155d74504f.tar.gz
freebsd-ports-graphics-dd54e702b369ec8748da6a90659acb155d74504f.tar.zst
freebsd-ports-graphics-dd54e702b369ec8748da6a90659acb155d74504f.zip
- Simplify ldconfig handling
Diffstat (limited to 'ports-mgmt')
-rw-r--r--ports-mgmt/portupgrade-devel/Makefile4
-rw-r--r--ports-mgmt/portupgrade/Makefile4
2 files changed, 2 insertions, 6 deletions
diff --git a/ports-mgmt/portupgrade-devel/Makefile b/ports-mgmt/portupgrade-devel/Makefile
index 8131c536495..4a6d28c6560 100644
--- a/ports-mgmt/portupgrade-devel/Makefile
+++ b/ports-mgmt/portupgrade-devel/Makefile
@@ -25,7 +25,6 @@ USE_RUBY= yes
USE_RUBY_FEATURES= optparse ruby18
USE_LDCONFIG= ${PREFIX}/lib/compat/pkg
-LDCONFIG_DIRS= %%PREFIX%%/lib/compat/pkg
MAKE_ARGS= PREFIX="${PREFIX}" RUBY="${RUBY}"
@@ -55,7 +54,6 @@ INSTALL_TARGET+= install-doc
.endif
.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/misc/ldconfig_compat/bsd.ldconfig.mk"
.if defined(WITH_BDB4)
# For PKG_DBDRIVER={bdb_btree,bdb_hash}
@@ -84,7 +82,7 @@ pre-extract:
@exit 1
.endif
-post-install: install-ldconfig-file
+post-install:
if [ ! -f ${PREFIX}/etc/pkgtools.conf ]; then \
${CP} -p ${PREFIX}/etc/pkgtools.conf.sample ${PREFIX}/etc/pkgtools.conf; \
fi
diff --git a/ports-mgmt/portupgrade/Makefile b/ports-mgmt/portupgrade/Makefile
index 549455c220e..db0dfd94575 100644
--- a/ports-mgmt/portupgrade/Makefile
+++ b/ports-mgmt/portupgrade/Makefile
@@ -26,7 +26,6 @@ USE_RUBY= yes
USE_RUBY_FEATURES= optparse ruby18
USE_LDCONFIG= ${PREFIX}/lib/compat/pkg
-LDCONFIG_DIRS= %%PREFIX%%/lib/compat/pkg
MAKE_ARGS= PREFIX="${PREFIX}" RUBY="${RUBY}"
@@ -56,7 +55,6 @@ INSTALL_TARGET+= install-doc
.endif
.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/misc/ldconfig_compat/bsd.ldconfig.mk"
.if defined(WITH_BDB4)
# For PKG_DBDRIVER={bdb_btree,bdb_hash}
@@ -85,7 +83,7 @@ pre-extract:
@exit 1
.endif
-post-install: install-ldconfig-file
+post-install:
if [ ! -f ${PREFIX}/etc/pkgtools.conf ]; then \
${CP} -p ${PREFIX}/etc/pkgtools.conf.sample ${PREFIX}/etc/pkgtools.conf; \
fi