aboutsummaryrefslogtreecommitdiffstats
path: root/print/font2svg/Makefile
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2003-08-31 09:01:14 +0800
committeredwin <edwin@FreeBSD.org>2003-08-31 09:01:14 +0800
commit95ea42d8f6d2da301345e8bbc2efb2e1c9a12682 (patch)
treec00e1cda2dd3e1d4d14324fc28bd500f48d004c2 /print/font2svg/Makefile
parent0a95deb114721eb6291526a3dfefd5b8a79c2d81 (diff)
downloadfreebsd-ports-graphics-95ea42d8f6d2da301345e8bbc2efb2e1c9a12682.tar.gz
freebsd-ports-graphics-95ea42d8f6d2da301345e8bbc2efb2e1c9a12682.tar.zst
freebsd-ports-graphics-95ea42d8f6d2da301345e8bbc2efb2e1c9a12682.zip
[PATCH] print/font2svg: enable choose of ghostscript interpreter
This patch allows the admin of the machine to choose either print/ghostscript-gnu or print/ghostscript-afp1 PR: ports/54940 Submitted by: Jens Rehsack <rehsack@liwing.de>
Diffstat (limited to 'print/font2svg/Makefile')
-rw-r--r--print/font2svg/Makefile16
1 files changed, 15 insertions, 1 deletions
diff --git a/print/font2svg/Makefile b/print/font2svg/Makefile
index 97ed703d3d5..e2b492d1c38 100644
--- a/print/font2svg/Makefile
+++ b/print/font2svg/Makefile
@@ -15,12 +15,26 @@ MASTER_SITES= http://www.gdv.uni-hannover.de/~peinecke/font2svg/
MAINTAINER= ports@FreeBSD.org
COMMENT= All font to svg-font converter
+.if defined(WITH_GHOSTSCRIPT_AFPL) && ${WITH_GHOSTSCRIPT_AFPL} == yes
+GSPORT?= print/ghostscript-afpl
+.else
+GSPORT?= print/ghostscript-gnu
+.endif
+
RUN_DEPENDS= bash:${PORTSDIR}/shells/bash2 \
- gs:${PORTSDIR}/print/ghostscript-gnu
+ gs:${PORTSDIR}/${GSPORT}
USE_REINPLACE= yes
NO_BUILD= yes
+pre-fetch:
+.if !defined(WITH_GHOSTSCRIPT_AFPL) || ${WITH_GHOSTSCRIPT_AFPL} != yes
+ @${ECHO} ""
+ @${ECHO} " Define WITH_GHOSTSCRIPT_AFPL=yes to use"
+ @${ECHO} " AFPL Postscript interpreter instead of GNU one"
+ @${ECHO} ""
+.endif
+
post-patch:
@${REINPLACE_CMD} -e "s|/bin/bash|${LOCALBASE}/bin/bash|" \
-e "s|/home/peinecke/cprog/font2svg|${DATADIR}|" \