aboutsummaryrefslogtreecommitdiffstats
path: root/print/gfontview/Makefile
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2001-07-27 02:57:57 +0800
committerijliao <ijliao@FreeBSD.org>2001-07-27 02:57:57 +0800
commitbf5c0e4563908eed7ea01636266f56fe979e793a (patch)
tree95bbdc09103f09b8d74e4a24d68696b25eb086ef /print/gfontview/Makefile
parent6d7088309c9f8d450939d483cf371ef9fe339878 (diff)
downloadfreebsd-ports-graphics-bf5c0e4563908eed7ea01636266f56fe979e793a.tar.gz
freebsd-ports-graphics-bf5c0e4563908eed7ea01636266f56fe979e793a.tar.zst
freebsd-ports-graphics-bf5c0e4563908eed7ea01636266f56fe979e793a.zip
add gfontview
An outline font viewer
Diffstat (limited to 'print/gfontview/Makefile')
-rw-r--r--print/gfontview/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/print/gfontview/Makefile b/print/gfontview/Makefile
new file mode 100644
index 00000000000..5d2a77ef35e
--- /dev/null
+++ b/print/gfontview/Makefile
@@ -0,0 +1,34 @@
+# ex:ts=8
+# New ports collection makefile for: gfontview
+# Date created: Jul 9, 2001
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= gfontview
+PORTVERSION= 0.5.0
+CATEGORIES= print
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= ports@FreeBSD.org
+
+LIB_DEPENDS= t1:${PORTSDIR}/devel/t1lib \
+ ungif:${PORTSDIR}/graphics/libungif \
+ intl:${PORTSDIR}/devel/gettext
+
+USE_X_PREFIX= yes
+USE_FREETYPE= yes
+USE_GTK= yes
+USE_GNOME= yes
+USE_AUTOCONF= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CFLAGS="${CFLAGS} -I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+CONFIGURE_ARGS= --with-libungif
+
+post-patch:
+ @${PERL} -pi -e "s,%%LOCALBASE%%,${LOCALBASE},g" ${WRKSRC}/Makefile.in
+
+.include <bsd.port.mk>