aboutsummaryrefslogtreecommitdiffstats
path: root/print/ghostscript8/scripts
diff options
context:
space:
mode:
authorandreas <andreas@FreeBSD.org>2001-01-17 06:57:24 +0800
committerandreas <andreas@FreeBSD.org>2001-01-17 06:57:24 +0800
commitc1e70783314f026ca355cbcb4c5363fe3b1d6c00 (patch)
tree35eb97431241bcff444468ffccea0ee4163aa432 /print/ghostscript8/scripts
parent2cc2905730c04605e348ebc552d1caa9d8d77fbf (diff)
downloadfreebsd-ports-graphics-c1e70783314f026ca355cbcb4c5363fe3b1d6c00.tar.gz
freebsd-ports-graphics-c1e70783314f026ca355cbcb4c5363fe3b1d6c00.tar.zst
freebsd-ports-graphics-c1e70783314f026ca355cbcb4c5363fe3b1d6c00.zip
update to ghostscript v 6.50
- removed port revision, because of new version - added PCL3 driver (hpdj successor) from Martin Lottermoser *both* driver, HPDJ and PCL3, are now compiled in reason: PCL3 is still flagged as BETA and author didn't get much response Although Martin says, its definitively not ALPHA, its safer to have the old drivers around, if things fail for some reason. Martin confirmed, that its possible to have both in one gs binary !!! - disable configure script temporarily, since dialog needs a driver update but I don't want to hold back that port any longer. - enabled as many gs driver as possible - reorganized MASTER_SITES - added mirrors - add a note, that russion mirror isn't up to date, so don't add it - optimized downloading from 6 different sources by special ordering - reorganized Makefile completely - put only ${GS_SOURCES} into EXTRACT_ONLY variable unpacking other 3rd party src's is handled in post-extract target - directory creating, patching, unpacking and install actions are now handeled within the proper make target. This makes port maintenance much easier, i.e.: if you enter make extract, then only extraction of things happen, but makefiles are still not patched. Before this cleanup, things were not so structured and not easy to maintain. Maybe we get a configure script later, to choose between different 3rd party driver options, then this "sorting" and documenting will support the migration process... - silence port by hiding actions with "@" - insert many informational echoes. This makes port maintenance and troubleshooting easier - put more unique comments in front of the different 3rd party modules - document things better - use as many environment variables as necessary, so that "numerical" changes only have to happen on some places and not withing make targets - use gs version number also in docu directory - properly install runtime, info and doc files from 3rd party drivers - put not needed stuff into "NOPORTDOCS" section - keep old font names to avoid fetching unnecessary things - updated patches as necessary - added new patch from Nartin Lottermoser - removed 2 patches that have been incorporated into gs 6.50 - added needed manual pages - updated pkg-plist - finally tested port and package building as well as port removal new port passes all disciplines ;-)
Diffstat (limited to 'print/ghostscript8/scripts')
-rw-r--r--print/ghostscript8/scripts/configure15
-rw-r--r--print/ghostscript8/scripts/configure.batch5
2 files changed, 13 insertions, 7 deletions
diff --git a/print/ghostscript8/scripts/configure b/print/ghostscript8/scripts/configure
index 70c6d30b514..0c5d6259654 100644
--- a/print/ghostscript8/scripts/configure
+++ b/print/ghostscript8/scripts/configure
@@ -1,5 +1,13 @@
#! /bin/sh
+# configure - gs driver preconfiguration, manual driver selection
+# by Andreas Klemm <andreas@FreeBSD.org>
+
+#
+# XXX - needs some rework for gs v 6.50,
+# therefore currently disabled in Makefile
+#
+
# driverselection
/usr/bin/dialog --title "Ghostscript 6 driver configuration" --clear \
--checklist "\n\
@@ -45,12 +53,7 @@ Have fun with this new configuration style ! -andreas \n\n\
"cdjmono" "HP DeskJet 500/510/520/540C b/w printing" ON \
"cdj500" "HP DeskJet 500/540C (same as cdjcolor)" OFF \
"cdj550" "HP DeskJet 550C/560C/660C/660Cse" ON \
- "cdj670" "HP DeskJet 670/690" OFF \
- "cdj850" "HP DeskJet 850/855/870/1100" OFF \
- "cdj880" "HP DeskJet 812/815/832/880/882/895/932/970 C (experimental)" OFF \
- "cdj890" "HP DeskJet 890" OFF \
"cdj970" "HP DeskJet 970, 3rd party" ON \
- "cdj1600" "HP DeskJet 1600" OFF \
"laserjet" "HP LaserJet" ON \
"ljetplus" "HP LaserJet Plus" ON \
"ljet2p" "HP LaserJet IId/IIp/III* with TIFF compression" ON \
@@ -71,7 +74,7 @@ Have fun with this new configuration style ! -andreas \n\n\
"pjxl300" "HP PaintJet XL300, DeskJet 1200C color printer, HP CopyJet" ON \
"pxlmono" "HP PCL XL black-and-white printers (LaserJet 5 and 6 family)" ON \
"pxlcolor" "HP PCL XL color printers (none available yet)" ON \
- "hpdj" "HP PCL 3+ (DeskJet 500/500C/510/520/540/550C/560C/850C/855C)" ON \
+ "pcl3" "HP PCL 3+ (DeskJet 500/500C/510/520/540/550C/560C/850C/855C)" ON \
"ibmpro" "IBM 9-pin Proprinter" OFF \
"jetp3852" "IBM Jetprinter ink-jet color (Model #3852)" OFF \
"imagen" "Imagen ImPress printers" OFF \
diff --git a/print/ghostscript8/scripts/configure.batch b/print/ghostscript8/scripts/configure.batch
index cf7d289fbf7..cd01400f68a 100644
--- a/print/ghostscript8/scripts/configure.batch
+++ b/print/ghostscript8/scripts/configure.batch
@@ -1,7 +1,10 @@
#! /bin/sh
+# configure.batch - gs driver preconfiguration, batch mode
+# by Andreas Klemm <andreas@FreeBSD.org>
+
cat - > ${WRKSRC}/src/unix-gcc.mak.new << !EOT
-DEVICE_DEVS=\$(DD)appledmp.dev \$(DD)iwhi.dev \$(DD)iwlo.dev \$(DD)iwlq.dev \$(DD)hl7x0.dev \$(DD)bj10e.dev \$(DD)bj200.dev \$(DD)bjc600.dev \$(DD)bjc800.dev \$(DD)lbp8.dev \$(DD)lips3.dev \$(DD)m8510.dev \$(DD)coslw2p.dev \$(DD)coslwxl.dev \$(DD)uniprint.dev \$(DD)lj250.dev \$(DD)declj250.dev \$(DD)ap3250.dev \$(DD)epson.dev \$(DD)eps9mid.dev \$(DD)eps9high.dev \$(DD)lp8000.dev \$(DD)lq850.dev \$(DD)epsonc.dev \$(DD)st800.dev \$(DD)stcolor.dev \$(DD)lp2563.dev \$(DD)dnj650c.dev \$(DD)deskjet.dev \$(DD)djet500.dev \$(DD)cdeskjet.dev \$(DD)djet500c.dev \$(DD)cdjcolor.dev \$(DD)cdjmono.dev \$(DD)cdj500.dev \$(DD)cdj550.dev \$(DD)cdj670.dev \$(DD)cdj850.dev \$(DD)cdj880.dev \$(DD)cdj890.dev \$(DD)cdj1600.dev \$(DD)laserjet.dev \$(DD)ljetplus.dev \$(DD)ljet2p.dev \$(DD)ljet3.dev \$(DD)ljet3d.dev \$(DD)ljet4.dev \$(DD)ljet4d.dev \$(DD)lj4dith.dev \$(DD)cljet5.dev \$(DD)cljet5c.dev \$(DD)cljet5pr.dev \$(DD)lj5mono.dev \$(DD)lj5gray.dev \$(DD)pj.dev \$(DD)pjetxl.dev \$(DD)pjxl.dev \$(DD)paintjet.dev \$(DD)pjxl300.dev \$(DD)pxlmono.dev \$(DD)pxlcolor.dev \$(DD)ibmpro.dev \$(DD)jetp3852.dev \$(DD)imagen.dev \$(DD)fs600.dev \$(DD)lxm5700m.dev \$(DD)cp50.dev \$(DD)necp6.dev \$(DD)oce9050.dev \$(DD)oki182.dev \$(DD)okiibm.dev \$(DD)r4081.dev \$(DD)sj48.dev \$(DD)bmpmono.dev \$(DD)bmpgray.dev \$(DD)bmp16.dev \$(DD)bmp256.dev \$(DD)bmp16m.dev \$(DD)bmp32b.dev \$(DD)bmpsep1.dev \$(DD)bmpsep8.dev \$(DD)ccr.dev \$(DD)cgmmono.dev \$(DD)cgm8.dev \$(DD)cgm24.dev \$(DD)cif.dev \$(DD)dfaxhigh.dev \$(DD)dfaxlow.dev \$(DD)faxg3.dev \$(DD)faxg32d.dev \$(DD)faxg4.dev \$(DD)miff24.dev \$(DD)inferno.dev \$(DD)jpeg.dev \$(DD)jpeggray.dev \$(DD)mgrmono.dev \$(DD)mgrgray2.dev \$(DD)mgrgray4.dev \$(DD)mgrgray8.dev \$(DD)mgr4.dev \$(DD)mgr8.dev \$(DD)pcxmono.dev \$(DD)pcxgray.dev \$(DD)pcx16.dev \$(DD)pcx256.dev \$(DD)pcx24b.dev \$(DD)pcxcmyk.dev \$(DD)pdfwrite.dev \$(DD)bit.dev \$(DD)bitrgb.dev \$(DD)bitcmyk.dev \$(DD)plan9bm.dev \$(DD)pbm.dev \$(DD)pbmraw.dev \$(DD)pgm.dev \$(DD)pgmraw.dev \$(DD)pgnm.dev \$(DD)pgnmraw.dev \$(DD)pnm.dev \$(DD)pnmraw.dev \$(DD)ppm.dev \$(DD)ppmraw.dev \$(DD)pkm.dev \$(DD)pkmraw.dev \$(DD)pksm.dev \$(DD)pksmraw.dev \$(DD)pngmono.dev \$(DD)pnggray.dev \$(DD)png16.dev \$(DD)png256.dev \$(DD)png16m.dev \$(DD)psmono.dev \$(DD)psgray.dev \$(DD)psrgb.dev \$(DD)pswrite.dev \$(DD)epswrite.dev \$(DD)sgirgb.dev \$(DD)sunhmono.dev \$(DD)t4693d2.dev \$(DD)t4693d4.dev \$(DD)t4693d8.dev \$(DD)tek4696.dev \$(DD)tiffcrle.dev \$(DD)tiffg3.dev \$(DD)tiffg32d.dev \$(DD)tiffg4.dev \$(DD)tiff12nc.dev \$(DD)tiff24nc.dev \$(DD)tifflzw.dev \$(DD)tiffpack.dev \$(DD)x11.dev \$(DD)x11alpha.dev \$(DD)x11cmyk.dev \$(DD)x11cmyk2.dev \$(DD)x11cmyk4.dev \$(DD)x11cmyk8.dev \$(DD)x11gray2.dev \$(DD)x11gray4.dev \$(DD)x11mono.dev \$(DD)x11rg16x.dev \$(DD)x11rg32x.dev \$(DD)hpdj.dev \$(DD)cdj970.dev
+DEVICE_DEVS=\$(DD)x11.dev \$(DD)x11alpha.dev \$(DD)x11cmyk.dev \$(DD)x11cmyk2.dev \$(DD)x11cmyk4.dev \$(DD)x11cmyk8.dev \$(DD)x11gray2.dev \$(DD)x11gray4.dev \$(DD)x11mono.dev \$(DD)x11rg16x.dev \$(DD)x11rg32x.dev \$(DD)atx23.dev \$(DD)atx24.dev \$(DD)atx38.dev \$(DD)deskjet.dev \$(DD)djet500.dev \$(DD)fs600.dev \$(DD)laserjet.dev \$(DD)ljetplus.dev \$(DD)ljet2p.dev \$(DD)ljet3.dev \$(DD)ljet3d.dev \$(DD)ljet4.dev \$(DD)ljet4d.dev \$(DD)lp2563.dev \$(DD)oce9050.dev \$(DD)lj5mono.dev \$(DD)lj5gray.dev \$(DD)psdf.dev \$(DD)epswrite.dev \$(DD)pswrite.dev \$(DD)pdfwrite.dev \$(DD)pxlmono.dev \$(DD)pxlcolor.dev \$(DD)bit.dev \$(DD)bitrgb.dev \$(DD)bitcmyk.dev \$(DD)bmpmono.dev \$(DD)bmpgray.dev \$(DD)bmpsep1.dev \$(DD)bmpsep8.dev \$(DD)bmp16.dev \$(DD)bmp256.dev \$(DD)bmp16m.dev \$(DD)bmp32b.dev \$(DD)cgmmono.dev \$(DD)cgm8.dev \$(DD)cgm24.dev \$(DD)jpeg.dev \$(DD)jpeggray.dev \$(DD)miff24.dev \$(DD)pcxmono.dev \$(DD)pcxgray.dev \$(DD)pcx16.dev \$(DD)pcx256.dev \$(DD)pcx24b.dev \$(DD)pcxcmyk.dev \$(DD)pcx2up.dev \$(DD)pbm.dev \$(DD)pbmraw.dev \$(DD)pgm.dev \$(DD)pgmraw.dev \$(DD)pgnm.dev \$(DD)pgnmraw.dev \$(DD)ppm.dev \$(DD)ppmraw.dev \$(DD)pnm.dev \$(DD)pnmraw.dev \$(DD)pkm.dev \$(DD)pkmraw.dev \$(DD)pksm.dev \$(DD)pksmraw.dev \$(DD)plan9bm.dev \$(DD)pngmono.dev \$(DD)pnggray.dev \$(DD)png16.dev \$(DD)png256.dev \$(DD)png16m.dev \$(DD)psmono.dev \$(DD)psgray.dev \$(DD)psrgb.dev \$(DD)fax.dev \$(DD)faxg3.dev \$(DD)faxg32d.dev \$(DD)faxg4.dev \$(DD)tfax.dev \$(DD)tiffs.dev \$(DD)tiffcrle.dev \$(DD)tiffg3.dev \$(DD)tiffg32d.dev \$(DD)tiffg4.dev \$(DD)tifflzw.dev \$(DD)tiffpack.dev \$(DD)tiff12nc.dev \$(DD)tiff24nc.dev \$(DD)appledmp.dev \$(DD)iwhi.dev \$(DD)iwlo.dev \$(DD)iwlq.dev \$(DD)bj10e.dev \$(DD)bj200.dev \$(DD)ccr.dev \$(DD)cdeskjet.dev \$(DD)cdjcolor.dev \$(DD)cdjmono.dev \$(DD)cdj500.dev \$(DD)cdj550.dev \$(DD)declj250.dev \$(DD)dnj650c.dev \$(DD)lj4dith.dev \$(DD)pj.dev \$(DD)pjxl.dev \$(DD)pjxl300.dev \$(DD)bjc600.dev \$(DD)bjc800.dev \$(DD)escp.dev \$(DD)djet500c.dev \$(DD)cljet5.dev \$(DD)cljet5pr.dev \$(DD)cljet5c.dev \$(DD)lj3100sw.dev \$(DD)coslw2p.dev \$(DD)coslwxl.dev \$(DD)cp50.dev \$(DD)epson.dev \$(DD)eps9mid.dev \$(DD)eps9high.dev \$(DD)ibmpro.dev \$(DD)epsonc.dev \$(DD)ap3250.dev \$(DD)st800.dev \$(DD)stcolor.dev \$(DD)uniprint.dev \$(DD)lj250.dev \$(DD)paintjet.dev \$(DD)pjetxl.dev \$(DD)hl7x0.dev \$(DD)imagen.dev \$(DD)jetp3852.dev \$(DD)lbp8.dev \$(DD)lips3.dev \$(DD)lp8000.dev \$(DD)m8510.dev \$(DD)necp6.dev \$(DD)lq850.dev \$(DD)lxm5700m.dev \$(DD)oki182.dev \$(DD)okiibm.dev \$(DD)photoex.dev \$(DD)sj48.dev \$(DD)t4693d2.dev \$(DD)t4693d4.dev \$(DD)t4693d8.dev \$(DD)tek4696.dev \$(DD)cfax.dev \$(DD)dfaxlow.dev \$(DD)dfaxhigh.dev \$(DD)cif.dev \$(DD)inferno.dev \$(DD)mgrmono.dev \$(DD)mgrgray2.dev \$(DD)mgrgray4.dev \$(DD)mgrgray8.dev \$(DD)mgr4.dev \$(DD)mgr8.dev \$(DD)sgirgb.dev \$(DD)sunhmono.dev \$(DD)hpdj.dev \$(DD)pcl3.dev \$(DD)hpdjplus.dev \$(DD)hpdjportable.dev \$(DD)hpdj310.dev \$(DD)hpdj320.dev \$(DD)hpdj340.dev \$(DD)hpdj400.dev \$(DD)hpdj500.dev \$(DD)hpdj500c.dev \$(DD)hpdj510.dev \$(DD)hpdj520.dev \$(DD)hpdj540.dev \$(DD)hpdj550c.dev \$(DD)hpdj560c.dev \$(DD)hpdj600.dev \$(DD)hpdj660c.dev \$(DD)hpdj670c.dev \$(DD)hpdj680c.dev \$(DD)hpdj690c.dev \$(DD)hpdj850c.dev \$(DD)hpdj855c.dev \$(DD)hpdj870c.dev \$(DD)hpdj890c.dev \$(DD)hpdj1120c.dev \$(DD)cdj970.dev
!EOT
# create one new Makefile, where DEVICE_DEVS contains all wanted devices