aboutsummaryrefslogtreecommitdiffstats
path: root/print/pdftk
diff options
context:
space:
mode:
authorthierry <thierry@FreeBSD.org>2004-11-27 23:24:11 +0800
committerthierry <thierry@FreeBSD.org>2004-11-27 23:24:11 +0800
commit4ac9057cd6ac943e5eed660d8ddead18ac0936f5 (patch)
tree832203fd8cd4db583f436bf83d80c4db5bff2e83 /print/pdftk
parenta7ffbafc4f59090d3a4870f49232e2b29b852420 (diff)
downloadfreebsd-ports-graphics-4ac9057cd6ac943e5eed660d8ddead18ac0936f5.tar.gz
freebsd-ports-graphics-4ac9057cd6ac943e5eed660d8ddead18ac0936f5.tar.zst
freebsd-ports-graphics-4ac9057cd6ac943e5eed660d8ddead18ac0936f5.zip
AMD64's gcc34 port does not build gcj.
This make pdftk cannot compile on amd64. PR: ports/74400 Submitted by: maintainer.
Diffstat (limited to 'print/pdftk')
-rw-r--r--print/pdftk/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/print/pdftk/Makefile b/print/pdftk/Makefile
index 99f08e3b870..1c5a8f596c4 100644
--- a/print/pdftk/Makefile
+++ b/print/pdftk/Makefile
@@ -16,12 +16,12 @@ MAINTAINER= patrick_dkt@yahoo.com.hk
COMMENT= A simple tool for doing everyday things with PDF documents
# needs gcj
-BUILD_DEPENDS= gcj34:${PORTSDIR}/lang/gcc34
+BUILD_DEPENDS= gcj33:${PORTSDIR}/lang/gcc33
# gcj don't exist on
NOT_FOR_ARCHS= ia64 sparc64
-USE_GCC= 3.4
+USE_GCC= 3.3
USE_GMAKE= yes
USE_ICONV= yes
USE_REINPLACE= yes
@@ -29,14 +29,14 @@ USE_REINPLACE= yes
WRKSRC= ${WRKDIR}/${DISTNAME}/${PORTNAME}
MAKEFILE= Makefile.Generic
-MAKE_ENV= CXX=g++34 GCJ=gcj34 GCJH=gcjh34
+MAKE_ENV= CXX=g++33 GCJ=gcj33 GCJH=gcjh33
MAN1= ${PORTNAME}.1
PLIST_FILES= bin/pdftk
post-extract:
@${REINPLACE_CMD} -e "s|TOOLPATH=|TOOLPATH=${LOCALBASE}/bin/|g" ${WRKSRC}/Makefile.Generic
- @${REINPLACE_CMD} -e "s|VERSUFF=|VERSUFF=34|g" ${WRKSRC}/Makefile.Generic
+ @${REINPLACE_CMD} -e "s|VERSUFF=|VERSUFF=33|g" ${WRKSRC}/Makefile.Generic
@${REINPLACE_CMD} -e "s|CXXFLAGS= -lgcj|CXXFLAGS= -lgcj ${PTHREAD_CFLAGS} ${PTHREAD_LIBS} -liconv -lz|g" ${WRKSRC}/Makefile.Generic
do-install: