aboutsummaryrefslogtreecommitdiffstats
path: root/print/py-cups
diff options
context:
space:
mode:
authordhn <dhn@FreeBSD.org>2009-06-21 03:42:12 +0800
committerdhn <dhn@FreeBSD.org>2009-06-21 03:42:12 +0800
commit4c4c7b6b4a097fa0f0e94427421cb4bc17b8e19d (patch)
tree3c977594d08f6e8c492c77014ed29a8ca3aa185f /print/py-cups
parent7de7295b78e6f59d2869a98c13074616baf0b2ef (diff)
downloadfreebsd-ports-graphics-4c4c7b6b4a097fa0f0e94427421cb4bc17b8e19d.tar.gz
freebsd-ports-graphics-4c4c7b6b4a097fa0f0e94427421cb4bc17b8e19d.tar.zst
freebsd-ports-graphics-4c4c7b6b4a097fa0f0e94427421cb4bc17b8e19d.zip
- Fix build with custom LOCALBASE.
PR: ports/135675 Submitted by: kmoore@ Approved by: ahze@
Diffstat (limited to 'print/py-cups')
-rw-r--r--print/py-cups/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/print/py-cups/Makefile b/print/py-cups/Makefile
index 69c9a7bed46..ae21a19839b 100644
--- a/print/py-cups/Makefile
+++ b/print/py-cups/Makefile
@@ -28,4 +28,8 @@ MAKE_ENV= LDFLAGS="${LDFLAGS}"
PYDISTUTILS_EGGINFO=${PORTNAME}-1.0-py${PYTHON_VER}.egg-info
PLIST_FILES= %%PYTHON_SITELIBDIR%%/cups.so
+pre-configure:
+ ${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|g' \
+ ${WRKSRC}/cupsconnection.c
+
.include <bsd.port.mk>