aboutsummaryrefslogtreecommitdiffstats
path: root/print/scribus/Makefile
diff options
context:
space:
mode:
authorkrion <krion@FreeBSD.org>2005-01-13 03:39:54 +0800
committerkrion <krion@FreeBSD.org>2005-01-13 03:39:54 +0800
commiteae3e9f6d95ad665563c07925f94c095cbf4e6d6 (patch)
treed9123545129a1fd5740d8ff90646faeafb4ef75c /print/scribus/Makefile
parent86125a0d27fd60de6e0b90d7c743151afd96b06a (diff)
downloadfreebsd-ports-graphics-eae3e9f6d95ad665563c07925f94c095cbf4e6d6.tar.gz
freebsd-ports-graphics-eae3e9f6d95ad665563c07925f94c095cbf4e6d6.tar.zst
freebsd-ports-graphics-eae3e9f6d95ad665563c07925f94c095cbf4e6d6.zip
Update to version 1.2.1
PR: ports/76163 Submitted by: Ports Fury
Diffstat (limited to 'print/scribus/Makefile')
-rw-r--r--print/scribus/Makefile32
1 files changed, 17 insertions, 15 deletions
diff --git a/print/scribus/Makefile b/print/scribus/Makefile
index 9e53b98b5a2..f9567b447b5 100644
--- a/print/scribus/Makefile
+++ b/print/scribus/Makefile
@@ -7,16 +7,10 @@
#
PORTNAME= scribus
-PORTVERSION= 1.2
+PORTVERSION= 1.2.1
CATEGORIES= print editors
-MASTER_SITES= ${MASTER_SITE_SUNSITE} \
- http://scribus.planetmirror.com/ \
- http://www.scribus.org.uk/downloads/${PORTVERSION}/ \
- http://docs.scribus.net/releases/${PORTVERSION}/ \
- http://web2.altmuehlnet.de/fschmid/ \
- http://ahnews.music.salford.ac.uk/scribus/downloads/ \
- http://mirrors.ntua.gr/Scribus/
-MASTER_SITE_SUBDIR= apps/office
+MASTER_SITES= http://www.scribus.org.uk/downloads/%SUBDIR%/
+MASTER_SITE_SUBDIR= ${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= A comprehensive desktop publishing program
@@ -30,17 +24,23 @@ RUN_DEPENDS= ${PYTHON_SITELIBDIR}/_tkinter.so:${PORTSDIR}/x11-toolkits/py-tkinte
USE_BZIP2= yes
USE_QT_VER= 3
-USE_GNOME= libartlgpl2 gnometarget
+USE_GNOME= gnometarget libartlgpl2 libxml2
USE_GHOSTSCRIPT_RUN= yes
USE_PYTHON= yes
USE_REINPLACE= yes
USE_GMAKE= yes
-GNU_CONFIGURE= yes
-INSTALLS_SHLIB= yes
-LDCONFIG_DIRS= %%PREFIX%%/lib/scribus/libs \
- %%PREFIX%%/lib/scribus/plugins
+USE_LIBTOOL_VER= 15
CONFIGURE_ARGS= --x-libraries=${X11BASE}/lib --x-includes=${X11BASE}/include
+MAN1= scribus.1
+MANLANG= "" pl
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500035
+CXXFLAGS+= -fpermissive
+.endif
+
pre-everything::
.if !defined(WITH_GHOSTSCRIPT_AFPL) || ${WITH_GHOSTSCRIPT_AFPL} != yes
@${ECHO_MSG} ""
@@ -54,5 +54,7 @@ post-patch:
s|-O2||g ; \
s|2\.3|${PYTHON_VERSION:S/^python//}|g ; \
s|python2_3|${PYTHON_VERSION:S/./_/}|g' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e \
+ 's|/share/man|/man|g' ${WRKSRC}/scribus/manpages/Makefile.in
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>