aboutsummaryrefslogtreecommitdiffstats
path: root/print
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2002-05-14 01:04:49 +0800
committerijliao <ijliao@FreeBSD.org>2002-05-14 01:04:49 +0800
commit5563f5afc5541d0d1701b551c6e0415da86a3feb (patch)
treef6d149d318bfecb273b78e6e64e51cf6a5d5f143 /print
parent74403b6b161f661f1e2ccc949c8ccc30964a521f (diff)
downloadfreebsd-ports-graphics-5563f5afc5541d0d1701b551c6e0415da86a3feb.tar.gz
freebsd-ports-graphics-5563f5afc5541d0d1701b551c6e0415da86a3feb.tar.zst
freebsd-ports-graphics-5563f5afc5541d0d1701b551c6e0415da86a3feb.zip
add axpoint 1.21
XML Based Presentations
Diffstat (limited to 'print')
-rw-r--r--print/Makefile1
-rw-r--r--print/axpoint/Makefile31
-rw-r--r--print/axpoint/distinfo1
-rw-r--r--print/axpoint/pkg-comment1
-rw-r--r--print/axpoint/pkg-descr18
-rw-r--r--print/axpoint/pkg-plist8
6 files changed, 60 insertions, 0 deletions
diff --git a/print/Makefile b/print/Makefile
index 0a20e8f7dee..ecef0961470 100644
--- a/print/Makefile
+++ b/print/Makefile
@@ -15,6 +15,7 @@
SUBDIR += apsfilter
SUBDIR += asprint
SUBDIR += auctex
+ SUBDIR += axpoint
SUBDIR += bibcard
SUBDIR += bibview
SUBDIR += bjfilter360
diff --git a/print/axpoint/Makefile b/print/axpoint/Makefile
new file mode 100644
index 00000000000..2fb84cec4a3
--- /dev/null
+++ b/print/axpoint/Makefile
@@ -0,0 +1,31 @@
+# ex:ts=8
+# Ports collection makefile for: axpoint
+# Date created: May 13, 2002
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= axpoint
+PORTVERSION= 1.21
+CATEGORIES= print perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= XML
+DISTNAME= XML-Handler-AxPoint-${PORTVERSION}
+
+MAINTAINER= ports@FreeBSD.org
+
+BUILD_DEPENDS= ${PERL_SITELIBDIR}/XML/SAX.pm:${PORTSDIR}/textproc/p5-XML-SAX \
+ ${PERL_SITELIBDIR}/XML/SAX/Writer.pm:${PORTSDIR}/textproc/p5-XML-SAX-Writer \
+ ${PERL_SITELIBDIR}/PDFLib.pm:${PORTSDIR}/print/p5-PDFLib
+LIB_DEPENDS= pdf.4:${PORTSDIR}/print/pdflib
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_SITELIBDIR= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}
+USE_PERL5= yes
+PERL_CONFIGURE= yes
+
+MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= XML::Handler::AxPoint.3
+
+.include <bsd.port.mk>
diff --git a/print/axpoint/distinfo b/print/axpoint/distinfo
new file mode 100644
index 00000000000..eb57a6dfc55
--- /dev/null
+++ b/print/axpoint/distinfo
@@ -0,0 +1 @@
+MD5 (XML-Handler-AxPoint-1.21.tar.gz) = 78bf79bc457f23ec3a3306a4b205fd14
diff --git a/print/axpoint/pkg-comment b/print/axpoint/pkg-comment
new file mode 100644
index 00000000000..149dd9cbdbb
--- /dev/null
+++ b/print/axpoint/pkg-comment
@@ -0,0 +1 @@
+XML Based Presentations
diff --git a/print/axpoint/pkg-descr b/print/axpoint/pkg-descr
new file mode 100644
index 00000000000..3e4975e975d
--- /dev/null
+++ b/print/axpoint/pkg-descr
@@ -0,0 +1,18 @@
+AxPoint is a Perl module that uses the PDFLib module and the pdflib library
+to generate PDF based presentations from XML data sources.
+It has the following features:
+ - Ability to create slideshows with your choice of background image
+ - Slideshows break down into slidesets, or not at your choice.
+ - Slides can show bullet points, source code (fixed font), or images.
+ - Slides can have transition effects (dissolve, box, wipe, etc)
+ - All elements of a slide can transition in too.
+ - Text on slides supports bold, italics, and colours. Colours can be any
+ one of the 16 HTML colours, or defined as hex RGB values.
+ - Output uses the standard XML::SAX::Writer consumer classes, allowing you
+ to output direct to a file, or to a string, or however you need to. Very
+ useful for dynamic web based presentations.
+ - PDF bookmarks allow direct navigation to any slide.
+ - Using PDF allows you to go "Full Screen", even on Linux
+ - Image formats supported include GIF, JPEG, PNG and TIFF
+
+WWW: http://axpoint.axkit.org/
diff --git a/print/axpoint/pkg-plist b/print/axpoint/pkg-plist
new file mode 100644
index 00000000000..ce3c3a98852
--- /dev/null
+++ b/print/axpoint/pkg-plist
@@ -0,0 +1,8 @@
+bin/axpoint
+lib/perl5/site_perl/%%PERL_VER%%/XML/Handler/AxPoint.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/XML/Handler/AxPoint/.packlist
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/XML/Handler 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/XML 2>/dev/null || true
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/XML/Handler/AxPoint
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/XML/Handler 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/XML 2>/dev/null || true