aboutsummaryrefslogtreecommitdiffstats
path: root/print
diff options
context:
space:
mode:
authorkris <kris@FreeBSD.org>2003-06-27 12:01:53 +0800
committerkris <kris@FreeBSD.org>2003-06-27 12:01:53 +0800
commit587fba1f57cbf6726427f0ffe62d74a9ce5b3df0 (patch)
tree8b5275edf5e9f79b40d12c6b17f26310213a1fc0 /print
parentb8950c4cddc497c0941d40512ad2000345af0021 (diff)
downloadfreebsd-ports-graphics-587fba1f57cbf6726427f0ffe62d74a9ce5b3df0.tar.gz
freebsd-ports-graphics-587fba1f57cbf6726427f0ffe62d74a9ce5b3df0.tar.zst
freebsd-ports-graphics-587fba1f57cbf6726427f0ffe62d74a9ce5b3df0.zip
Patch an fgets overflow and bump PORTREVISION.
Obtained from: OpenBSD
Diffstat (limited to 'print')
-rw-r--r--print/lgrind/Makefile1
-rw-r--r--print/lgrind/files/patch-lgutil_c12
2 files changed, 13 insertions, 0 deletions
diff --git a/print/lgrind/Makefile b/print/lgrind/Makefile
index 339edacad80..ca962471667 100644
--- a/print/lgrind/Makefile
+++ b/print/lgrind/Makefile
@@ -7,6 +7,7 @@
PORTNAME= lgrind
PORTVERSION= 3.67
+PORTREVISION= 1
CATEGORIES= print
#MASTER_SITES= ftp://ftp.dante.de/tex-archive/support/ \
MASTER_SITES= ${MASTER_SITE_TEX_CTAN}
diff --git a/print/lgrind/files/patch-lgutil_c b/print/lgrind/files/patch-lgutil_c
new file mode 100644
index 00000000000..08ce9386b6a
--- /dev/null
+++ b/print/lgrind/files/patch-lgutil_c
@@ -0,0 +1,12 @@
+$OpenBSD: patch-lgutil_c,v 1.1 2003/05/01 11:54:15 avsm Exp $
+--- source/lgutil.c.orig Tue Apr 15 22:55:24 2003
++++ source/lgutil.c Tue Apr 15 22:56:21 2003
+@@ -113,7 +113,7 @@ void Internal_Help_Language_List()
+ check=0;
+ if (*config=='\n' || config[strlen(config)-2]!='\\')
+ check=1;
+- if (fgets(config, BUFFERSIZE, tf)==NULL) break;
++ if (fgets(config, sizeof config, tf)==NULL) break;
+ if (check!=0) AddToLList(config, &currlch, &llch);
+ } while (strcmp((*currlch).name, "EndOfLanguageDefinitions")!=0);
+ rch=lch;