aboutsummaryrefslogtreecommitdiffstats
path: root/print
diff options
context:
space:
mode:
authorale <ale@FreeBSD.org>2012-06-12 21:29:09 +0800
committerale <ale@FreeBSD.org>2012-06-12 21:29:09 +0800
commit747e06f4b6435ad837d3c8f53e0aacf764b2bccd (patch)
tree7608558831ca407d7a55e4dc62d51a5fc36d3c55 /print
parent4aca39322b6d46141b65535e41577d2383765e6a (diff)
downloadfreebsd-ports-graphics-747e06f4b6435ad837d3c8f53e0aacf764b2bccd.tar.gz
freebsd-ports-graphics-747e06f4b6435ad837d3c8f53e0aacf764b2bccd.tar.zst
freebsd-ports-graphics-747e06f4b6435ad837d3c8f53e0aacf764b2bccd.zip
Update to 2.1.9 release.
Diffstat (limited to 'print')
-rw-r--r--print/pecl-pdflib/Makefile3
-rw-r--r--print/pecl-pdflib/distinfo4
-rw-r--r--print/pecl-pdflib/files/patch-pdf.c17
-rw-r--r--print/pecl-pdflib/files/patch-pdf7.c28
4 files changed, 3 insertions, 49 deletions
diff --git a/print/pecl-pdflib/Makefile b/print/pecl-pdflib/Makefile
index bd565447b85..84237cbe345 100644
--- a/print/pecl-pdflib/Makefile
+++ b/print/pecl-pdflib/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= pdflib
-PORTVERSION= 2.1.8
-PORTREVISION= 1
+PORTVERSION= 2.1.9
CATEGORIES= print pear
MASTER_SITES= http://pecl.php.net/get/
PKGNAMEPREFIX= pecl-
diff --git a/print/pecl-pdflib/distinfo b/print/pecl-pdflib/distinfo
index 6bd7be6d43e..f6c9e9e965f 100644
--- a/print/pecl-pdflib/distinfo
+++ b/print/pecl-pdflib/distinfo
@@ -1,2 +1,2 @@
-SHA256 (PECL/pdflib-2.1.8.tgz) = 410f8b1a9691705e4e70a03eb6468e735232f3871c3e63a4cf164250bd25b5bc
-SIZE (PECL/pdflib-2.1.8.tgz) = 55797
+SHA256 (PECL/pdflib-2.1.9.tgz) = a842e04cfa3ca051c2f053210dea9c40ecaa12cb22b5de39b3bcce5bf347e778
+SIZE (PECL/pdflib-2.1.9.tgz) = 55899
diff --git a/print/pecl-pdflib/files/patch-pdf.c b/print/pecl-pdflib/files/patch-pdf.c
deleted file mode 100644
index 07deabf53bd..00000000000
--- a/print/pecl-pdflib/files/patch-pdf.c
+++ /dev/null
@@ -1,17 +0,0 @@
---- pdf.c 2010/04/28 12:17:58 298698
-+++ pdf.c 2012/01/28 03:05:18 322900
-@@ -766,10 +766,14 @@
-
- ALLOC_HASHTABLE(intern->std.properties);
- zend_hash_init(intern->std.properties, 0, NULL, ZVAL_PTR_DTOR, 0);
-+#if PHP_VERSION_ID < 50399
- zend_hash_copy(intern->std.properties,
- &class_type->default_properties,
- (copy_ctor_func_t) zval_add_ref,
- (void *) &tmp, sizeof(zval *));
-+#else
-+ object_properties_init( (zend_object*)intern, class_type );
-+#endif
-
- retval.handle = zend_objects_store_put(intern, NULL,
- (zend_objects_free_object_storage_t)pdflib_object_dtor,
diff --git a/print/pecl-pdflib/files/patch-pdf7.c b/print/pecl-pdflib/files/patch-pdf7.c
deleted file mode 100644
index a3e768b0dfd..00000000000
--- a/print/pecl-pdflib/files/patch-pdf7.c
+++ /dev/null
@@ -1,28 +0,0 @@
---- pdf7.c 2010/04/28 12:17:58 298698
-+++ pdf7.c 2012/02/25 12:27:38 323503
-@@ -322,8 +322,9 @@
- {
- zend_object_value retval;
- pdflib_object *intern;
-+#if PHP_VERSION_ID < 50399
- zval *tmp;
--
-+#endif
-
- intern = emalloc(sizeof(pdflib_object));
- memset(intern, 0, sizeof(pdflib_object));
-@@ -332,10 +333,14 @@
-
- ALLOC_HASHTABLE(intern->std.properties);
- zend_hash_init(intern->std.properties, 0, NULL, ZVAL_PTR_DTOR, 0);
-+#if PHP_VERSION_ID < 50399
- zend_hash_copy(intern->std.properties,
- &class_type->default_properties,
- (copy_ctor_func_t) zval_add_ref,
- (void *) &tmp, sizeof(zval *));
-+#else
-+ object_properties_init( (zend_object*)intern, class_type );
-+#endif
-
- retval.handle = zend_objects_store_put(intern, NULL,
- (zend_objects_free_object_storage_t)pdflib_object_dtor,