aboutsummaryrefslogtreecommitdiffstats
path: root/print
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2009-12-05 13:57:21 +0800
committerdinoex <dinoex@FreeBSD.org>2009-12-05 13:57:21 +0800
commit861b990757c478f0fa77edfd416d25357e35c78b (patch)
treee425ab95d3f13cedd102eeb2273dffcd2e1a2bfa /print
parentf875d37f4ab5f6bd133f63b75197efafcc65a338 (diff)
downloadfreebsd-ports-graphics-861b990757c478f0fa77edfd416d25357e35c78b.tar.gz
freebsd-ports-graphics-861b990757c478f0fa77edfd416d25357e35c78b.tar.zst
freebsd-ports-graphics-861b990757c478f0fa77edfd416d25357e35c78b.zip
- add missing option WITH_LIBUSB
Reported by: Bruce Simpson
Diffstat (limited to 'print')
-rw-r--r--print/cups-base/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/print/cups-base/Makefile b/print/cups-base/Makefile
index 60caf7b60e5..7be17a2cec9 100644
--- a/print/cups-base/Makefile
+++ b/print/cups-base/Makefile
@@ -46,6 +46,7 @@ OPTIONS?= GNUTLS "Build with GNUTLS library" on \
PAM "Build with PAM support" off \
LDAP "Build with LDAP support" off \
DBUS "Build with DBUS support" off \
+ LIBUSB "Build with USB support" off \
GHOSTSCRIPT "Build pdftps with GHOSTSCRIPT" on \
XDG_OPEN "Build with XDG_OPEN as browser" off
@@ -172,6 +173,10 @@ CONFIGURE_ARGS+= --disable-dbus
RUN_DEPENDS+= xdg-open:${PORTSDIR}/devel/xdg-utils
.endif
+.if !defined(CUPS_CLIENT) && !defined(CUPS_IMAGE) && defined(WITH_LIBUSB)
+LIB_DEPENDS+= usb:${PORTSDIR}/devel/libusb
+.endif
+
.if defined(CUPS_CLIENT)
MAN1= cups-config.1
.elif defined(CUPS_IMAGE)