aboutsummaryrefslogtreecommitdiffstats
path: root/print
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2012-03-20 02:21:45 +0800
committerdinoex <dinoex@FreeBSD.org>2012-03-20 02:21:45 +0800
commitff032400b39cbd469764570487958c84cac38427 (patch)
tree608ba54b1716ba984d1fad54a11b1da531f37365 /print
parentaca0a4a17d460b6bc8232281f201be997608a930 (diff)
downloadfreebsd-ports-graphics-ff032400b39cbd469764570487958c84cac38427.tar.gz
freebsd-ports-graphics-ff032400b39cbd469764570487958c84cac38427.tar.zst
freebsd-ports-graphics-ff032400b39cbd469764570487958c84cac38427.zip
- rename broken option DNSSD to AVAHI
- new option MDNSRESPONDER PR: 165206 Suggested by: Matthieu Volat Feature safe: yes
Diffstat (limited to 'print')
-rw-r--r--print/cups-base/Makefile20
-rw-r--r--print/cups-base/pkg-plist2
2 files changed, 17 insertions, 5 deletions
diff --git a/print/cups-base/Makefile b/print/cups-base/Makefile
index 7c8aa52b9ed..397040686c9 100644
--- a/print/cups-base/Makefile
+++ b/print/cups-base/Makefile
@@ -45,7 +45,8 @@ OPTIONS?= GNUTLS "Build with GNUTLS instead of OpenSSL" off \
PHP "Build PHP support" off \
PYTHON "Build PYTHON support" off \
LIBPAPER "Build with libpaper support" off \
- DNSSD "Build with DNS_SD (avahi) support" off \
+ AVAHI "Build with avahi support" off \
+ MDNSRESPONDER "Build with mDNSResponder support" off \
PAM "Build with PAM support" off \
LDAP "Build with LDAP support" off \
DBUS "Build with DBUS support" off \
@@ -90,7 +91,6 @@ CONFLICTS+= cupsddk-*
WITH_OPENSSL_PORT?= yes
.endif
-
.if defined(CUPS_CLIENT)
COMMENT2= Library cups
INSTALL_WRKSRC= ${WRKSRC}/cups
@@ -183,14 +183,24 @@ CONFIGURE_ARGS+= --enable-libpaper
LIB_DEPENDS+= paper.2:${PORTSDIR}/print/libpaper
.endif
-.if !defined(CUPS_CLIENT) && !defined(CUPS_IMAGE) && defined(WITH_DNSSD)
+.if !defined(CUPS_CLIENT) && !defined(CUPS_IMAGE) && ( defined(WITH_AVAHI) || defined(WITH_MDNSRESPONDER) )
CONFIGURE_ARGS+= --enable-dnssd \
- --with-dnssd-libs=${LOCALBASE}/lib/ \
- --with-dnssd-includes=${LOCALBASE}/include/avahi-compat-libdns_sd/
+ --with-dnssd-libs=${LOCALBASE}/lib/
+.if defined(WITH_MDNSRESPONDER)
+LIB_DEPENDS+= dns_sd:${PORTSDIR}/net/mDNSResponder
+CONFIGURE_ARGS+= --with-dnssd-includes=${LOCALBASE}/include
+PLIST_SUB+= WITH_MDNSRESPONDER=""
+.if defined(WITH_AVAHI)
+IGNORE= You can only have one dns_sd provider: AHAVI or MDNSRESPONDER
+.endif
+.else
LIB_DEPENDS+= dns_sd:${PORTSDIR}/net/avahi-libdns
+CONFIGURE_ARGS+= --with-dnssd-includes=${LOCALBASE}/include/avahi-compat-libdns_sd/
BROKEN= missing function, see http://www.avahi.org/ticket/303
+.endif
.else
CONFIGURE_ARGS+= --disable-dnssd
+PLIST_SUB+= WITH_MDNSRESPONDER="@comment "
.endif
.if !defined(CUPS_CLIENT) && !defined(CUPS_IMAGE) && defined(WITH_PAM)
diff --git a/print/cups-base/pkg-plist b/print/cups-base/pkg-plist
index 924b57d4765..f76df63099a 100644
--- a/print/cups-base/pkg-plist
+++ b/print/cups-base/pkg-plist
@@ -83,6 +83,8 @@ libexec/cups/backend/serial
libexec/cups/backend/snmp
libexec/cups/backend/socket
libexec/cups/backend/usb
+%%WITH_MDNSRESPONDER%%libexec/cups/backend/dnssd
+%%WITH_MDNSRESPONDER%%libexec/cups/backend/mdns
libexec/cups/cgi-bin/admin.cgi
libexec/cups/cgi-bin/classes.cgi
libexec/cups/cgi-bin/help.cgi