aboutsummaryrefslogtreecommitdiffstats
path: root/science/2dhf/Makefile
diff options
context:
space:
mode:
authormaho <maho@FreeBSD.org>2003-07-24 17:50:24 +0800
committermaho <maho@FreeBSD.org>2003-07-24 17:50:24 +0800
commit501808dc7b61aa0b2ae3bdf7eda2335569580849 (patch)
tree6e87e470bdf7c939f39d6c25c3c3de546f0f4efb /science/2dhf/Makefile
parent8df2a3f7074183f206bf18958f6ec66eb5a9d57f (diff)
downloadfreebsd-ports-graphics-501808dc7b61aa0b2ae3bdf7eda2335569580849.tar.gz
freebsd-ports-graphics-501808dc7b61aa0b2ae3bdf7eda2335569580849.tar.zst
freebsd-ports-graphics-501808dc7b61aa0b2ae3bdf7eda2335569580849.zip
Added a Numerical Hartree-Fock Program for Diatomic Molecules.
This program package calcluates virtually exact solution of the Hartree-Fock and Hartree-Fock-Salter equations for diatomic molecules (distributed under GPL).
Diffstat (limited to 'science/2dhf/Makefile')
-rw-r--r--science/2dhf/Makefile63
1 files changed, 63 insertions, 0 deletions
diff --git a/science/2dhf/Makefile b/science/2dhf/Makefile
new file mode 100644
index 00000000000..bb16469d899
--- /dev/null
+++ b/science/2dhf/Makefile
@@ -0,0 +1,63 @@
+# New ports collection makefile for: 2dhf
+# Date created: 24 July 2003
+# Whom: NAKATA, Maho <maho@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= 2dhf
+PORTVERSION= 2003.02
+CATEGORIES= science
+MASTER_SITES= http://staff.csc.fi/~laaksone/2d/admin/
+DISTNAME= ${PORTNAME}_02.03
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= maho@FreeBSD.org
+COMMENT= A Numerical Hartree-Fock Program for Diatomic Molecules
+
+LIB_DEPENDS= lapack:${PORTSDIR}/math/lapack \
+ atlas:${PORTSDIR}/math/atlas
+
+.if defined(WITH_OPTIMIZED_FLAGS)
+FFLAGS+= -O3 -ffast-math -finline-functions -fomit-frame-pointer -funroll-loops -fexpensive-optimizations -malign-double
+.if (${MACHINE_ARCH} == "i386")
+FFLAGS+= -mfancy-math-387
+.endif # i386
+.endif
+
+pre-everything::
+ @${ECHO_CMD} "You can optimize by setting WITH_OPTIMIZED_FLAGS=yes."
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+USE_GMAKE= yes
+USE_REINPLACE= yes
+
+do-extract:
+ ${MKDIR} ${WRKSRC}
+ @(cd ${WRKSRC} ; ${TAR} xfz ${DISTDIR}/${DISTNAME}${EXTRACT_SUFX})
+
+post-patch:
+ @${REINPLACE_CMD} -e 's,%%FC%%,${FC},g ; \
+ s,%%FFLAGS%%,${FFLAGS},g ; \
+ s,%%CC%%,${CC},g ; \
+ s,%%CFLAGS%%,${CFLAGS},g ; \
+ s,%%LOCALBASE%%,${LOCALBASE},g' \
+ ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e 's,%%PREFIX%%,${PREFIX},g' \
+ ${WRKSRC}/bin/xhf
+do-build:
+ @${MKDIR} ${WRKSRC}/obj ; cd ${WRKSRC} ; ${GMAKE}
+
+do-install:
+ @cd ${WRKSRC} ; ${INSTALL_PROGRAM} bin/x2dhf ${PREFIX}/bin/x2dhf
+ @cd ${WRKSRC} ; ${INSTALL_SCRIPT} bin/xhf ${PREFIX}/bin/xhf
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ @cd ${WRKSRC}/doc ; ${INSTALL_DATA} 2dhf.pdf users_guide.pdf ${DOCSDIR}
+ @${MKDIR} ${DOCSDIR}/users_guide
+ @cd ${WRKSRC}/doc/users_guide ; ${INSTALL_DATA} * ${DOCSDIR}/users_guide
+ @${MKDIR} ${EXAMPLESDIR}
+ @cd ${WRKSRC}/examples/ ; ${TAR} -chf - . | \
+ ${TAR} -xf - -C ${EXAMPLESDIR}
+.endif
+.include <bsd.port.mk>
and x11-toolkits/linux-f10-tk85;bsam2009-06-031-1/+2 * . add CONFLICTS to linux-f8 infrastructure ports;bsam2009-06-036-0/+18 * Here are new Linux Fedora 10 infrastructure ports.bsam2009-06-0218-497/+487 * - Resolve LATEST_LINK conflictpav2009-06-013-2/+3 * - Update to 1.9.25nivit2009-05-312-5/+5 * Update to 2.16.2.marcus2009-05-316-10/+10 * - Update to 0.85miwi2009-05-292-5/+5 * 2009-05-22 misc/sonytv: tcl8.3 support is going to be droppedmiwi2009-05-296-81/+0 * Update to 0.20.3.kwm2009-05-272-4/+4 * - Update to 0.18.5anray2009-05-258-149/+22 * Assign maintainership to anray who already maintains the sawfish port. Hemarcus2009-05-251-1/+1 * - These ports needs libcups.so to build.araujo2009-05-203-0/+3 * - Update to 0.91amdmi32009-05-202-4/+4 * - fix BUILD_DEPENDSdinoex2009-05-201-1/+1 * Update to 2.26.2.kwm2009-05-203-5/+10 * Fix the CUPS dependency.marcus2009-05-192-2/+2 * - use cups-client as depencydinoex2009-05-182-2/+2 * Update to 2.26.0.kwm2009-05-172-9/+5 * - Update to 0.90miwi2009-05-172-5/+23 * - Update to 0.43miwi2009-05-173-16/+4 * Update to 2.6.2.kwm2009-05-172-4/+4 * - use cups-clientdinoex2009-05-171-1/+1 * - Fix build on 64-bit platformsgahr2009-05-143-5/+44 * Chase libgmp and bump PORTREVISION.ale2009-05-134-6/+8 * Sort pkg-plist and remove stale dependency.bsam2009-05-132-4/+2 * Update to version 2.3.2 for Linux Fedora 8.bsam2009-05-123-25/+22 * Update to 0.10.23.kwm2009-05-111-1/+1 * When use libxul, make sure it does build and install the module. Bump themezz2009-05-111-2/+2 * bin/pango-view is now installed even if X11 support is disabled.marcus2009-05-101-1/+1 * - Update to 1.78miwi2009-05-092-4/+4 * - New port: x11-toolkits/gambas2-gb-gtkacm2009-05-093-0/+33 * - New port: x11-toolkits/gambas2-gb-qtacm2009-05-094-0/+52 * - Fix WITHOUT_NLSchinsan2009-05-091-2/+4 * also install libGiGiOgrePlugin_OIS.sooliver2009-05-072-2/+4 * update xfce to 4.6.1oliver2009-05-063-8/+6 * Update to 0.20.2.marcus2009-05-063-9/+9 * Update to 1.24.2.marcus2009-05-062-4/+4 * update to 0.6.0.729oliver2009-05-065-44/+54 * - Update to 2.2.4acm2009-05-044-55/+5 * - Update to 8.5.7mm2009-04-264-26/+25 * Presenting GNOME 2.26.1 for FreeBSD.kwm2009-04-247-16/+19 * - Update 0.14miwi2009-04-243-9/+8 * Update to 2.6.1.marcus2009-04-133-4/+10 * Update to 2.26.1.marcus2009-04-132-4/+4 * Add support for libxul.marcus2009-04-131-2/+7 * Remove seamonkey from the list of supported Gecko providers.marcus2009-04-131-1/+1 * - Update to 0.05chinsan2009-04-132-4/+4 * - Gnomepanel support doesn't work with the current version of Gnome.stas2009-04-121-8/+8 * Actually remove the obsolete patch.marcus2009-04-122-266/+0 * Update to 2.16.1.marcus2009-04-124-8/+8 * - Update to 2.12.0.stas2009-04-123-46/+52 * Update to 3.5M6rnoland2009-04-102-10/+9 * Presenting GNOME 2.26 for FreeBSD. Seemarcus2009-04-1062-370/+1122 * Fix plist with -DNOPORT*.itetcu2009-04-083-11/+7 * - Update to 0.7.0lwhsu2009-04-073-10/+24 * Add linux-f8-tk84 8.4.17, graphical toolkit for TCL (Linux Fedora 8).bsam2009-04-067-0/+491 * - Mark BROKEN: does not compilepav2009-04-061-0/+2 * - Update to 0.7.2.araujo2009-04-052-5/+4 * Add %%PORTDOCS%% to the static plist items.marcus2009-04-051-4/+4 * Add %%PORTDOCS%% to the static plist items.marcus2009-04-052-8/+8 * Fix the NOPORTDOCS cases.marcus2009-04-053-0/+6 * - Lib updated FOX16.araujo2009-04-052-2/+2 * - Update to 1.6.36.araujo2009-04-052-4/+4 * update devel/physfs to 2.0.0oliver2009-04-042-4/+4 * - Fix build on HEADmiwi2009-04-022-3/+10 * Here are new Linux Fedora 8 infrastructure ports.bsam2009-04-0133-652/+1047 * Finish repocopies of new linux-f8 infrastructure ports:bsam2009-04-015-4/+15 * - Convert to USE_TK and allow on any tk (changes default package to use tk85)pav2009-03-312-5/+4 * disable MAKE_JOBS_SAFE temporary to fix build on tbmakc2009-03-302-2/+0 * Update to 5.2.0makc2009-03-3010-504/+146 * - Mark BROKEN on HEAD, does not like new USB stackpav2009-03-261-1/+7 * - Update to 0.4.4chinsan2009-03-252-6/+5 * bump PORTREVISION after cmake updatemakc2009-03-252-1/+2 * 2009-03-22 emulators/dlx: unmaintained, does not work with current versions o...miwi2009-03-2411-492/+0 * - Update to 2.12.8pav2009-03-232-4/+4 * - Fix build after wxgtk2 updatemiwi2009-03-222-0/+12 * Update to 2.8.10.fjoe2009-03-2028-158/+150 * Welcome to the new linux ports infrastructure which allows usingbsam2009-03-2015-63/+24 * Release these ports into wild. I don't have time for these ports anymore. I ammezz2009-03-196-6/+6 * - Chase graphviz updatepav2009-03-191-1/+2 * - Update to version 0.81amdmi32009-03-182-4/+4 * Switch to use Qt4.makc2009-03-183-15/+28 * wxPerl is an extension module allowing the creation of GUI (Graphicalmiwi2009-03-165-0/+186 * This module provides the STDOUT, STDERR and exit codes of asynchronously runningmiwi2009-03-165-0/+43 * Alien::wxWidgets can be used to detect and get configurationmiwi2009-03-165-0/+60 * Update to 2.6.4.fjoe2009-03-1514-105/+48 * Free most of my ports, since they aren't being maintained to ashaun2009-03-141-1/+1 * - Update to r6671miwi2009-03-143-5/+14 * - Update to 0.10.0pgj2009-03-124-54/+196 * 2009-02-11 x11-toolkits/inti-gconf: not maintain by upstream for more than fi...miwi2009-03-1019-313/+0 * Update to 2.24.1.marcus2009-03-083-4/+13 * Update to 2.24.1.marcus2009-03-082-4/+4 * Update to 2.18.4.marcus2009-03-083-4/+7 * Update to 2.14.1.marcus2009-03-083-6/+25 * - Remove x11-toolkits/xg. It expired on 2007-10-28.wxs2009-03-078-156/+0 * - Use my FreeBSD address on the ports I maintaindhn2009-03-071-1/+1 * - Remove x11-toolkits/scx: Version branch long since retired. This portwxs2009-03-075-96/+0 * - Port was replaced by x11-toolkits/p5-Tcl-Tkmm2009-03-051-4/+4 * mark BROKENoliver2009-03-031-0/+1 * - Unbreak INDEX (the port will most likely need an update to work with 4.6)pav2009-03-031-1/+0 * Add patch to fix crash in qt painting engine (KDE bugs/174065)makc2009-03-032-1/+41 * update Xfce to 4.6oliver2009-03-033-13/+115 * - Drop maintainership of the following ports:alepulver2009-02-281-1/+1 * Mark BROKEN: does not build.erwin2009-02-271-1/+7 * - Unbreak if WITH_*_MAN setmm2009-02-272-2/+2 * - Unbreak install if WITH_*_MAN setmm2009-02-271-1/+1 * Correct CATEGORIES.kwm2009-02-271-1/+1 * - Disable install of function manpages by defaultmm2009-02-269-83/+116 * Fix a bug with applications not behaving correctly after XRandR events.marcus2009-02-264-2/+34 * Depend on gtk20.kwm2009-02-241-1/+1 * - Update to 0.14nivit2009-02-244-174/+181 * - Change default Tcl/Tk version to 8.5mm2009-02-237-4/+7 * Add unique.kwm2009-02-235-0/+77 * - take maintainershipdinoex2009-02-222-8/+2 * Use my @FreeBSD.org email for the rest of my portsmakc2009-02-213-3/+3 * - Update to 0.80miwi2009-02-212-14/+17 * - Chase devil shlib bumpmiwi2009-02-211-2/+2 * - Update to 0.8.0miwi2009-02-213-27/+35 * Update to 3.5m5rnoland2009-02-193-32/+54 * - Fix a bug in in QGraphicsProxyWidget that is responsible for manymarkus2009-02-192-1/+16 * PyQwt is a set of Python bindings for the Qwt C++ class library whichmiwi2009-02-176-0/+168 * - Update to 0.7.5beech2009-02-163-7/+5 * Fix installation when NOPORTDOCS is defined. Also, honor EXAMPLESDIR.marcus2009-02-162-567/+569 * - Fix pkg-plist.stas2009-02-151-3/+28 * - Change USE_TK from YES to 84 due to planned default tcl changemm2009-02-151-1/+1 * Update PyQt4 ports to 4.4.4, new ports:makc2009-02-158-201/+206 * - Switch to USE_TK.stas2009-02-151-17/+7 * - Deprecate due to planned end of support for tcl/tk 83 on 2009-05-22mm2009-02-141-0/+3 * - Deprecate due to planned end of tcl/tk 82 support on 2009-04-22mm2009-02-141-0/+3 * - Deprecate due to planned end of tcl/tk 80 support on 2009-03-22mm2009-02-141-0/+3 * - Does not build with tcl/tk 8.5 and highermm2009-02-141-1/+1 * - Add tcl86 to unsupported tcl versionsmm2009-02-141-1/+1 * - Update to 0.8.2mm2009-02-144-19/+62 * - Update to 1.9.24nivit2009-02-123-371/+14 * Update to 2.6.3.marcus2009-02-122-4/+4 * - Update lang/mono to 2.0.1.flz2009-02-0923-296/+308 * - Lib updated Fox16.araujo2009-02-082-2/+2 * - Update to 1.6.35.araujo2009-02-082-4/+4 * - Add missing entries for tcl86,tk86,tcl86-thread,tk86-threadmm2009-02-081-0/+2 * Reset maintainership. Thanks for your good work!bsam2009-02-061-1/+1 * - Fix pkg-plist if manpages/demos are to be installedmm2009-02-042-21/+23 * - Cosmetic fix: b1 suffix for package providemm2009-02-042-2/+2 * - Add Tcl/Tk 8.6mm2009-02-045-15/+19 * - Update to 2.3.3chinsan2009-02-023-5/+6 * - Use GNOME macro instead of ${MASTER_SITE_GNOME}, removearaujo2009-02-02