aboutsummaryrefslogtreecommitdiffstats
path: root/science
diff options
context:
space:
mode:
authormakc <makc@FreeBSD.org>2013-10-23 21:08:41 +0800
committermakc <makc@FreeBSD.org>2013-10-23 21:08:41 +0800
commit257d95e619d504625a3dd72269614d7fe350704c (patch)
tree902ae1e48303d70f1045908f9eb477d7722924c8 /science
parent4db462c2d32f9526ce9940e28a4b22915d0982f5 (diff)
downloadfreebsd-ports-graphics-257d95e619d504625a3dd72269614d7fe350704c.tar.gz
freebsd-ports-graphics-257d95e619d504625a3dd72269614d7fe350704c.tar.zst
freebsd-ports-graphics-257d95e619d504625a3dd72269614d7fe350704c.zip
- Support staging
- Use new LIB_DEPENDS syntax - Use options helpers - Convert to USES - Minor changes/fixes
Diffstat (limited to 'science')
-rw-r--r--science/kst2/Makefile10
-rw-r--r--science/kst2/pkg-plist1
-rw-r--r--science/pyteomics.biolccc/Makefile1
-rw-r--r--science/pyteomics/Makefile1
4 files changed, 5 insertions, 8 deletions
diff --git a/science/kst2/Makefile b/science/kst2/Makefile
index fb508c7ae2c..76abe3a168c 100644
--- a/science/kst2/Makefile
+++ b/science/kst2/Makefile
@@ -10,7 +10,7 @@ MASTER_SITES= SF/${PORTNAME}/Kst%20${DISTVERSION:C/-r.*//}/
MAINTAINER= makc@FreeBSD.org
COMMENT= Data viewing and plotting tool
-LIB_DEPENDS= gsl:${PORTSDIR}/math/gsl
+LIB_DEPENDS= libgsl.so:${PORTSDIR}/math/gsl
USES= cmake
USE_QT4= gui xml designer svg opengl \
@@ -18,12 +18,13 @@ USE_QT4= gui xml designer svg opengl \
USE_LDCONFIG= yes
CMAKE_SOURCE_PATH= ${WRKSRC}/cmake
-CMAKE_ARGS+= -Dkst_install_prefix=${PREFIX}
+CMAKE_ARGS+= -Dkst_install_prefix=${PREFIX} \
+ -Dkst_pch=off
-MAN1= kst2.1
PLIST_SUB= SHLIB_VER=${PORTVERSION}
OPTIONS_DEFINE= FITS MATLAB NETCDF
+OPTIONS_SUB= yes
FITS_DESC= Support for data in FITS format
FITS_LIB_DEPENDS= libcfitsio.so:${PORTSDIR}/astro/cfitsio
@@ -34,9 +35,6 @@ MATLAB_BUILD_DEPENDS= ${LOCALBASE}/lib/libmatio.a:${PORTSDIR}/math/matio
NETCDF_DESC= Support for data in NetCDF format
NETCDF_LIB_DEPENDS= libnetcdf.so:${PORTSDIR}/science/netcdf
-OPTIONS_SUB= yes
-
-NO_STAGE= yes
.include <bsd.port.options.mk>
post-patch:
diff --git a/science/kst2/pkg-plist b/science/kst2/pkg-plist
index c887541ae05..5a4b9371e2b 100644
--- a/science/kst2/pkg-plist
+++ b/science/kst2/pkg-plist
@@ -61,6 +61,7 @@ lib/libkst2math.so.%%SHLIB_VER%%
lib/libkst2widgets.so
lib/libkst2widgets.so.2
lib/libkst2widgets.so.%%SHLIB_VER%%
+man/man1/kst2.1.gz
share/applications/kst2.desktop
share/icons/hicolor/128x128/apps/application-x-kst.png
share/icons/hicolor/128x128/apps/kst.png
diff --git a/science/pyteomics.biolccc/Makefile b/science/pyteomics.biolccc/Makefile
index 9dcc3e71bcf..e0ca72d7ce2 100644
--- a/science/pyteomics.biolccc/Makefile
+++ b/science/pyteomics.biolccc/Makefile
@@ -12,5 +12,4 @@ COMMENT= Python bindings for BioLCCC
USE_PYTHON= yes
USE_PYDISTUTILS= yes
-NO_STAGE= yes
.include <bsd.port.mk>
diff --git a/science/pyteomics/Makefile b/science/pyteomics/Makefile
index 5c066ea92d1..191fc79afb5 100644
--- a/science/pyteomics/Makefile
+++ b/science/pyteomics/Makefile
@@ -16,5 +16,4 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}lxml>=0:${PORTSDIR}/devel/py-lxml \
USE_PYTHON= yes
USE_PYDISTUTILS= yes
-NO_STAGE= yes
.include <bsd.port.mk>