aboutsummaryrefslogtreecommitdiffstats
path: root/science
diff options
context:
space:
mode:
authorthierry <thierry@FreeBSD.org>2016-01-08 04:48:42 +0800
committerthierry <thierry@FreeBSD.org>2016-01-08 04:48:42 +0800
commit285dd5223b9477e04f51a644026b8b4468e3f765 (patch)
treec18518a3739b289c1a1588085fb57a27cdb42b1d /science
parent650618dab508be38e3a297645c0d15948237c3b3 (diff)
downloadfreebsd-ports-graphics-285dd5223b9477e04f51a644026b8b4468e3f765.tar.gz
freebsd-ports-graphics-285dd5223b9477e04f51a644026b8b4468e3f765.tar.zst
freebsd-ports-graphics-285dd5223b9477e04f51a644026b8b4468e3f765.zip
Upgrade to 0.9.6v2.
Changelog at <https://sourceforge.net/projects/gnudatalanguage/files/gdl/0.9.6/#readme>
Diffstat (limited to 'science')
-rw-r--r--science/gnudatalanguage/Makefile18
-rw-r--r--science/gnudatalanguage/distinfo4
-rw-r--r--science/gnudatalanguage/files/patch-CMakeModules_FindPlplot.cmake13
-rw-r--r--science/gnudatalanguage/files/patch-src__base64.hpp38
-rw-r--r--science/gnudatalanguage/files/patch-src__basic_fun.cpp38
-rw-r--r--science/gnudatalanguage/files/patch-src__file.cpp15
-rw-r--r--science/gnudatalanguage/files/patch-src__gsl_fun.cpp11
-rw-r--r--science/gnudatalanguage/files/patch-src__str.cpp38
-rw-r--r--science/gnudatalanguage/files/patch-src_plotting__contour.cpp75
-rw-r--r--science/gnudatalanguage/pkg-plist39
10 files changed, 85 insertions, 204 deletions
diff --git a/science/gnudatalanguage/Makefile b/science/gnudatalanguage/Makefile
index f310e8d3533..daae60a528b 100644
--- a/science/gnudatalanguage/Makefile
+++ b/science/gnudatalanguage/Makefile
@@ -2,10 +2,9 @@
# $FreeBSD$
PORTNAME= gnudatalanguage
-DISTVERSION= 0.9.5
-PORTREVISION= 7
+DISTVERSION= 0.9.6v2
CATEGORIES= science lang
-MASTER_SITES= SF/${PORTNAME}/gdl/${DISTVERSION}
+MASTER_SITES= SF/${PORTNAME}/gdl/${PORTVERSION:R}
.if defined(BUILD_PYTHON_MODULE)
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
.endif
@@ -22,9 +21,8 @@ LIB_DEPENDS+= libplplot.so:${PORTSDIR}/math/plplot \
libgsl.so:${PORTSDIR}/math/gsl
USE_WX= 2.8
-WX_UNICODE= yes
USE_XORG= x11 sm ice xext
-USES= cmake:outsource compiler:gcc-c++11-lib dos2unix ncurses pkgconfig readline
+USES= cmake:outsource compiler:gcc-c++11-lib dos2unix ncurses pkgconfig readline tar:tgz
# Disable ncurses and readline from ports
# Disable ImageMagick (does'nt work with plplot because dynamic drivers
@@ -34,8 +32,9 @@ CMAKE_ARGS= -DREADLINEDIR:STRING="/usr" \
-DNCURSESDIR:STRING="/usr" \
-DMPICH:BOOL=NO \
-DMAGICK:BOOL=NO
-CPPFLAGS+= ${CFLAGS} -fno-inline
+CPPFLAGS+= ${CFLAGS} -fno-inline -DNPY_NO_DEPRECATED_API -DNPY_1_7_API_VERSION
LDFLAGS+= -lpthread -L${LOCALBASE}/lib
+WRKSRC= ${WRKDIR}/gdl-${PORTVERSION:R}
SLAVEDIRS= science/py-gnudatalanguage
@@ -52,6 +51,7 @@ FFTW_LIB_DEPENDS= libfftw3.so:${PORTSDIR}/math/fftw3 \
FFTW_CMAKE_ON= -DFFTW:BOOL=YES
FFTW_CMAKE_OFF= -DFFTW:BOOL=NO
+GRAPHICSMAGICK_DESC= Support GraphicsMagick
GRAPHICSMAGICK_LIB_DEPENDS= libGraphicsMagick.so:${PORTSDIR}/graphics/GraphicsMagick
GRAPHICSMAGICK_CMAKE_ON= -DGRAPHICSMAGICK:BOOL=YES
GRAPHICSMAGICK_CMAKE_OFF= -DGRAPHICSMAGICK:BOOL=NO
@@ -85,6 +85,12 @@ PYTHON_RUN_DEPENDS= ${PYNUMPY} \
PYTHON_CMAKE_ON= -DPYTHON:BOOL=YES -DPYTHONVERSION:STRING="${PYTHON_VER}"
PYTHON_CMAKE_OFF= -DPYTHON:BOOL=NO
+# math/qhull conflicts with math/plplot
+#QHULL_DESC= Enable Qhull support
+#QHULL_LIB_DEPENDS= libqhull.so:${PORTSDIR}/math/qhull
+#QHULL_CMAKE_ON= -DQHULL:BOOL=YES
+#QHULL_CMAKE_OFF= -DQHULL:BOOL=NO
+
UDUNITS_LIB_DEPENDS= libudunits2.so:${PORTSDIR}/science/udunits
UDUNITS_CMAKE_ON= -DUDUNITS:BOOL=YES
UDUNITS_CMAKE_OFF= -DUDUNITS:BOOL=NO
diff --git a/science/gnudatalanguage/distinfo b/science/gnudatalanguage/distinfo
index 66ace7c9701..6019d478ecf 100644
--- a/science/gnudatalanguage/distinfo
+++ b/science/gnudatalanguage/distinfo
@@ -1,2 +1,2 @@
-SHA256 (gdl-0.9.5.tar.gz) = cc9635e836b5ea456cad93f8a07d589aed8649668fbd14c4aad22091991137e2
-SIZE (gdl-0.9.5.tar.gz) = 2341992
+SHA256 (gdl-0.9.6v2.tgz) = cfb005ee1d9c843b26cc474618225ce68a1f0bfaeddcd45bf63a0a8fb62eedb4
+SIZE (gdl-0.9.6v2.tgz) = 1777167
diff --git a/science/gnudatalanguage/files/patch-CMakeModules_FindPlplot.cmake b/science/gnudatalanguage/files/patch-CMakeModules_FindPlplot.cmake
deleted file mode 100644
index f90320de36d..00000000000
--- a/science/gnudatalanguage/files/patch-CMakeModules_FindPlplot.cmake
+++ /dev/null
@@ -1,13 +0,0 @@
---- CMakeModules/FindPlplot.cmake.orig 2015-04-22 19:37:22 UTC
-+++ CMakeModules/FindPlplot.cmake
-@@ -9,8 +9,8 @@
- #
-
-
--find_library(PLPLOT_LIBRARY NAMES plplotd)
--find_library(PLPLOTCXX_LIBRARY NAMES plplotcxxd)
-+find_library(PLPLOT_LIBRARY NAMES plplot)
-+find_library(PLPLOTCXX_LIBRARY NAMES plplotcxx)
- set(PLPLOT_LIBRARIES ${PLPLOT_LIBRARY} ${PLPLOTCXX_LIBRARY})
- find_path(PLPLOT_INCLUDE_DIR NAMES plplot/plplot.h)
- include(FindPackageHandleStandardArgs)
diff --git a/science/gnudatalanguage/files/patch-src__base64.hpp b/science/gnudatalanguage/files/patch-src__base64.hpp
deleted file mode 100644
index 7e8cfa99c12..00000000000
--- a/science/gnudatalanguage/files/patch-src__base64.hpp
+++ /dev/null
@@ -1,38 +0,0 @@
---- src/base64.hpp.orig 2015-04-22 19:37:22 UTC
-+++ src/base64.hpp
-@@ -147,7 +147,7 @@ namespace base64 {
- Warning("base64 decode error: unexpected fill char -- offset read?");
- return false;
- }
-- if(!(isspace(data[i-1]))) {
-+ if(!(std::isspace(data[i-1]))) {
- //cerr << "base 64 decode error: illegal character '" << data[i-1] << "' (0x" << std::hex << (int)data[i-1] << std::dec << ")" << endl;
- Warning("base 64 decode error: illegal character");
- return false;
-@@ -165,7 +165,7 @@ namespace base64 {
- Warning("base64 decode error: unexpected fill char -- offset read?");
- return false;
- }
-- if(!(isspace(data[i-1]))) {
-+ if(!(std::isspace(data[i-1]))) {
- //cerr << "base 64 decode error: illegal character '" << data[i-1] << '\'' << endl;
- Warning("base 64 decode error: illegal character");
- return false;
-@@ -190,7 +190,7 @@ namespace base64 {
- if(fillchar == data[i-1]) {
- return true;
- }
-- if((!isspace(data[i-1]))) {
-+ if((!std::isspace(data[i-1]))) {
- //cerr << "base 64 decode error: illegal character '" << data[i-1] << '\'' << endl;
- Warning("base 64 decode error: illegal character");
- return false;
-@@ -215,7 +215,7 @@ namespace base64 {
- if(fillchar == data[i-1]) {
- return true;
- }
-- if(!(isspace(data[i-1]))) {
-+ if(!(std::isspace(data[i-1]))) {
- //cerr << "base 64 decode error: illegal character '" << data[i-1] << '\'' << endl;
- Warning("base 64 decode error: illegal character");
- return false;
diff --git a/science/gnudatalanguage/files/patch-src__basic_fun.cpp b/science/gnudatalanguage/files/patch-src__basic_fun.cpp
index 91629e47921..600136ae289 100644
--- a/science/gnudatalanguage/files/patch-src__basic_fun.cpp
+++ b/science/gnudatalanguage/files/patch-src__basic_fun.cpp
@@ -1,20 +1,20 @@
---- src/basic_fun.cpp.orig 2015-04-22 19:37:22 UTC
+--- src/basic_fun.cpp.orig 2016-01-04 19:52:38 UTC
+++ src/basic_fun.cpp
-@@ -6483,7 +6483,7 @@ BaseGDL* strtok_fun(EnvT* e) {
- while (p < e)
- {
- // scheme = 1*[ lowalpha | digit | "+" | "-" | "." ]
-- if (!(isalpha(*p)) && !(isdigit(*p)) && (*p != '+') && (*p != '.') && (*p != '-'))
-+ if (!(std::isalpha(*p)) && !(std::isdigit(*p)) && (*p != '+') && (*p != '.') && (*p != '-'))
- {
- if (e + 1 < ue) goto parse_port;
- else goto just_path;
-@@ -6501,7 +6501,7 @@ BaseGDL* strtok_fun(EnvT* e) {
- {
- // check if the data we get is a port this allows us to correctly parse things like a.com:80
- p = e + 1;
-- while (isdigit(*p)) p++;
-+ while (std::isdigit(*p)) p++;
- if ((*p == '\0' || *p == '/') && (p - e) < 7) goto parse_port;
- urlstru->InitTag("SCHEME", DStringGDL(string(s, (e - s))));
- length -= ++e - s;
+@@ -6523,7 +6523,7 @@ namespace lib {
+ {
+ // check if the data we get is a port this allows us to correctly parse things like a.com:80
+ p = e + 1;
+- while (isdigit(*p)) p++;
++ while (std::isdigit(*p)) p++;
+ if ((*p == '\0' || *p == '/') && (p - e) < 7) goto parse_port;
+ urlstru->InitTag("SCHEME", DStringGDL(string(s, (e - s))));
+ length -= ++e - s;
+@@ -6574,7 +6574,7 @@ namespace lib {
+ parse_port:
+ p = e + 1;
+ pp = p;
+- while (pp-p < 6 && isdigit(*pp)) pp++;
++ while (pp-p < 6 && std::isdigit(*pp)) pp++;
+ if (pp-p < 6 && (*pp == '/' || *pp == '\0'))
+ {
+ memcpy(port_buf, p, (pp-p));
diff --git a/science/gnudatalanguage/files/patch-src__file.cpp b/science/gnudatalanguage/files/patch-src__file.cpp
new file mode 100644
index 00000000000..68cfcee311a
--- /dev/null
+++ b/science/gnudatalanguage/files/patch-src__file.cpp
@@ -0,0 +1,15 @@
+--- src/file.cpp.orig 2016-01-04 20:50:45 UTC
++++ src/file.cpp
+@@ -242,10 +242,11 @@ extern "C"
+ #endif
+ #define NTEST_SEARCH 7
+
+-#ifdef __CYGWIN__
++#if defined(__CYGWIN__) || defined(__FreeBSD__)
+ #define stat64 stat
+ #define lstat64 lstat
+ // for religious reasons, CYGWIN doesn't do lstat64
++// FreeBSD doesn't do lstat64 because there is no need for it
+ #endif
+
+ namespace lib {
diff --git a/science/gnudatalanguage/files/patch-src__gsl_fun.cpp b/science/gnudatalanguage/files/patch-src__gsl_fun.cpp
deleted file mode 100644
index dd41d0e405c..00000000000
--- a/science/gnudatalanguage/files/patch-src__gsl_fun.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/gsl_fun.cpp.orig 2015-04-22 19:37:22 UTC
-+++ src/gsl_fun.cpp
-@@ -3183,7 +3183,7 @@ namespace lib {
- e->AssureScalarPar<DStringGDL>(0, tmpname);
- name.reserve(tmpname.length());
- for (string::iterator it = tmpname.begin(); it < tmpname.end(); it++)
-- if (*it != ' ' && *it != '_') name.append(1, (char)tolower(*it));
-+ if (*it != ' ' && *it != '_') name.append(1, (char)std::tolower(*it));
- }
-
- #ifdef USE_UDUNITS
diff --git a/science/gnudatalanguage/files/patch-src__str.cpp b/science/gnudatalanguage/files/patch-src__str.cpp
deleted file mode 100644
index 17337dfafc7..00000000000
--- a/science/gnudatalanguage/files/patch-src__str.cpp
+++ /dev/null
@@ -1,38 +0,0 @@
---- src/str.cpp.orig 2015-04-22 19:37:22 UTC
-+++ src/str.cpp
-@@ -178,7 +178,7 @@ string StrUpCase(const string& s)
- ArrayGuard<char> guard( r);
- r[len]=0;
- for(unsigned i=0;i<len;i++)
-- r[i]=toupper(sCStr[i]);
-+ r[i]=std::toupper(sCStr[i]);
- return string(r);
- }
- void StrUpCaseInplace( string& s)
-@@ -189,7 +189,7 @@ void StrUpCaseInplace( string& s)
- // ArrayGuard<char> guard( r);
- // r[len]=0;
- for(unsigned i=0;i<len;i++)
-- s[i]=toupper(s[i]);
-+ s[i]=std::toupper(s[i]);
- // return string(r);
- }
-
-@@ -201,7 +201,7 @@ string StrLowCase(const string& s)
- ArrayGuard<char> guard( r);
- r[len]=0;
- for(unsigned i=0;i<len;i++)
-- r[i]=tolower(sCStr[i]);
-+ r[i]=std::tolower(sCStr[i]);
- return string(r);
- }
- void StrLowCaseInplace(string& s)
-@@ -209,7 +209,7 @@ void StrLowCaseInplace(string& s)
- unsigned len=s.length();
- // char const *sCStr=s.c_str();
- for(unsigned i=0;i<len;i++)
-- s[i]=tolower(s[i]);
-+ s[i]=std::tolower(s[i]);
- // s[i]=tolower(sCStr[i]);
- }
-
diff --git a/science/gnudatalanguage/files/patch-src_plotting__contour.cpp b/science/gnudatalanguage/files/patch-src_plotting__contour.cpp
deleted file mode 100644
index 06d9c9e26fc..00000000000
--- a/science/gnudatalanguage/files/patch-src_plotting__contour.cpp
+++ /dev/null
@@ -1,75 +0,0 @@
---- src/plotting_contour.cpp.orig 2015-04-22 19:37:22 UTC
-+++ src/plotting_contour.cpp
-@@ -789,8 +789,8 @@ namespace lib
- 1, value,
- static_cast<PLFLT>(( *thick )[i%thick->N_Elements()]),
- 0,0,0,0,
-- (plstream::fill), (oneDim),
-- (oneDim)?(plstream::tr1):(plstream::tr2), (oneDim)?(void *)&cgrid1:(void *)&cgrid2);
-+ (plcallback::fill), (oneDim),
-+ (oneDim)?(plcallback::tr1):(plcallback::tr2), (oneDim)?(void *)&cgrid1:(void *)&cgrid2);
- }
- actStream->psty(0);
- // if (docolors) gdlSetGraphicsForegroundColorFromKw( e, actStream );
-@@ -808,8 +808,8 @@ namespace lib
- clevel[i], maxmax,
- 1,value,
- 0,0,0,0,0,
-- plstream::fill, (oneDim), //Onedim is accelerator since rectangles are kept rectangles see plplot doc
-- (oneDim)?(plstream::tr1):(plstream::tr2), (oneDim)?(void *)&cgrid1:(void *)&cgrid2);
-+ plcallback::fill, (oneDim), //Onedim is accelerator since rectangles are kept rectangles see plplot doc
-+ (oneDim)?(plcallback::tr1):(plcallback::tr2), (oneDim)?(void *)&cgrid1:(void *)&cgrid2);
- }
- } else { //every other case of fill
- // note that plshades is not protected against 1 level (color formula is
-@@ -818,8 +818,8 @@ namespace lib
- if (nlevel>2 && !(docolors)) { //acceleration with shades when no c_colors are given. use continuous table1, decomposed or not.
- //acceleration is most sensible when a (x,y) transform (rotate, stretch) is in place since plplot does not recompute the map.
- actStream->shades( map, xEl, yEl, isLog?doIt:NULL, xStart, xEnd, yStart, yEnd,
-- clevel, nlevel, 1, 0, 0, plstream::fill, (oneDim),
-- (oneDim)?(plstream::tr1):(plstream::tr2),
-+ clevel, nlevel, 1, 0, 0, plcallback::fill, (oneDim),
-+ (oneDim)?(plcallback::tr1):(plcallback::tr2),
- (oneDim)?(void *)&cgrid1:(void *)&cgrid2);
- }
- else { //fill with colors defined with c_colors or n<=2
-@@ -832,8 +832,8 @@ namespace lib
- clevel[i], maxmax,
- 1,value,
- 0,0,0,0,0,
-- plstream::fill, (oneDim), //Onedim is accelerator since rectangles are kept rectangles see plplot doc
-- (oneDim)?(plstream::tr1):(plstream::tr2), (oneDim)?(void *)&cgrid1:(void *)&cgrid2);
-+ plcallback::fill, (oneDim), //Onedim is accelerator since rectangles are kept rectangles see plplot doc
-+ (oneDim)?(plcallback::tr1):(plcallback::tr2), (oneDim)?(void *)&cgrid1:(void *)&cgrid2);
- } else
- printf(" Problem, sorry! plplot doesn't like to FILL with a single level!");
- }
-@@ -854,7 +854,7 @@ namespace lib
- if (doT3d) { //no label in T3D , bug in plplot...
- actStream->setcontlabelparam ( LABELOFFSET, (PLFLT) label_size, LABELSPACING, 0 );
- actStream->cont ( map, xEl, yEl, 1, xEl, 1, yEl, &( clevel[i] ), 1,
-- (oneDim)?(plstream::tr1):(plstream::tr2), (oneDim)?(void *)&cgrid1:(void *)&cgrid2);
-+ (oneDim)?(plcallback::tr1):(plcallback::tr2), (oneDim)?(void *)&cgrid1:(void *)&cgrid2);
- } else {
- if (dolabels && i<labels->N_Elements())
- {
-@@ -862,16 +862,16 @@ namespace lib
- //else (lables thicker than contours) impossible with plplot...
- actStream->setcontlabelparam ( LABELOFFSET, (PLFLT) label_size, LABELSPACING, 0 );
- actStream->cont ( map, xEl, yEl, 1, xEl, 1, yEl, &( clevel[i] ), 1,
-- (oneDim)?(plstream::tr1):(plstream::tr2), (oneDim)?(void *)&cgrid1:(void *)&cgrid2); //thick contours, no label
-+ (oneDim)?(plcallback::tr1):(plcallback::tr2), (oneDim)?(void *)&cgrid1:(void *)&cgrid2); //thick contours, no label
- actStream->Thick(label_thick);
- }
- actStream->setcontlabelparam ( LABELOFFSET, (PLFLT) label_size, LABELSPACING*sqrt(label_size),(PLINT)(*labels)[i] );
- actStream->cont ( map, xEl, yEl, 1, xEl, 1, yEl, &( clevel[i] ), 1,
-- (oneDim)?(plstream::tr1):(plstream::tr2), (oneDim)?(void *)&cgrid1:(void *)&cgrid2);
-+ (oneDim)?(plcallback::tr1):(plcallback::tr2), (oneDim)?(void *)&cgrid1:(void *)&cgrid2);
- if (!dothick) gdlSetPenThickness(e, actStream);
- } else {
- actStream->cont ( map, xEl, yEl, 1, xEl, 1, yEl, &( clevel[i] ), 1,
-- (oneDim)?(plstream::tr1):(plstream::tr2), (oneDim)?(void *)&cgrid1:(void *)&cgrid2);
-+ (oneDim)?(plcallback::tr1):(plcallback::tr2), (oneDim)?(void *)&cgrid1:(void *)&cgrid2);
- }
- }
- }
diff --git a/science/gnudatalanguage/pkg-plist b/science/gnudatalanguage/pkg-plist
index 0ba43fc9f67..b71a180d34c 100644
--- a/science/gnudatalanguage/pkg-plist
+++ b/science/gnudatalanguage/pkg-plist
@@ -4,13 +4,18 @@ man/man1/gdl.1.gz
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/Makefile.am
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/README
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/Saturn.jpg
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/add_error.pro
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/banner_for_testsuite.pro
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/benchmark/bench_matrix_multiply.pro
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/checks
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/demo_graphics1.pro
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/demo_graphics2.pro
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/demo_graphics3.pro
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/demo_widgets.pro
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/example.grib
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/formats.idl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/gdl_idl_fl.pro
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/idl.xdr
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/image_test.pro
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/launchtest.c
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/libtest_ce.cpp
@@ -19,13 +24,14 @@ man/man1/gdl.1.gz
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test-read_ascii.txt
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test-swap_endian.pro
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test-total.pro
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_MathFunctionsDim.pro
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_angles.pro
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_array_equal.pro
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_array_indices.pro
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_axis.pro
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_base64.pro
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_besel.pro
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_binfmt.pro
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_bits_per_pix.pro
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_brain.pro
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_bug_1779553.pro
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_bug_2555865.pro
@@ -79,6 +85,9 @@ man/man1/gdl.1.gz
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_bug_3559291.pro
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_bug_3572473.pro
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_bug_3595172.pro
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_bug_635.dat
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_bug_635.f90
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_bug_635.pro
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_bug_n000542.pro
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_bug_n000580.pro
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_bug_n000581.pro
@@ -123,13 +132,17 @@ man/man1/gdl.1.gz
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_file_copy.pro
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_file_delete.pro
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_file_dirname.pro
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_file_info.pro
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_file_move.pro
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_file_search.pro
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_file_test.pro
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_file_which.pro
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_finite.pro
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_fix.pro
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_fixprint.pro
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_float2string.pro
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_format.pro
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_formats.pro
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_fx_root.pro
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_fz_roots.pro
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_gammas.pro
@@ -150,14 +163,18 @@ man/man1/gdl.1.gz
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_interpolate_missing.pro
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_invert_matrix.pro
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_isa.pro
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_ishft.pro
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_jd_op_tut.pro
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_known_bugs.pro
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_la_least_squares.pro
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_levels.pro
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_list.pro
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_ludc_lusol.pro
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_map.pro
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_math_function_dim.pro
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_matrix_multiply.pro
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_memory.pro
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_message.pro
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_minmax.pro
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_modulo.pro
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_moment.pro
@@ -177,9 +194,11 @@ man/man1/gdl.1.gz
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_plot_inf_nan.pro
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_plot_info.pro
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_plot_linestyle.pro
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_plot_oo.pro
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_plotting_misc.pro
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_plotting_ranges.pro
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_pmulti.pro
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_pmulti_basic.pro
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_point_lun.pro
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_poly2d.pro
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_postscript.pro
@@ -196,6 +215,7 @@ man/man1/gdl.1.gz
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_read_jpeg.pro
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_read_standard_images.pro
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_readf.pro
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_reads.pro
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_rebin.pro
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_restore.pro
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_rk4.pro
@@ -235,6 +255,8 @@ man/man1/gdl.1.gz
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_wavelet.pro
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_where.pro
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_widgets.pro
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_window_background.pro
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_xdr.pro
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_zeropoly.pro
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_zip.pro
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/try
@@ -248,7 +270,6 @@ man/man1/gdl.1.gz
%%DATADIR%%/lib/calendar.pro
%%DATADIR%%/lib/congrid.pro
%%DATADIR%%/lib/correlate.pro
-%%DATADIR%%/lib/cw_bgroup.pro
%%DATADIR%%/lib/delvar.pro
%%DATADIR%%/lib/deriv.pro
%%DATADIR%%/lib/diag_matrix.pro
@@ -277,11 +298,16 @@ man/man1/gdl.1.gz
%%DATADIR%%/lib/file_dirname_old.pro
%%DATADIR%%/lib/file_expand_path.pro
%%DATADIR%%/lib/file_lines.pro
+%%DATADIR%%/lib/file_move.pro
%%DATADIR%%/lib/file_which.pro
%%DATADIR%%/lib/filepath.pro
%%DATADIR%%/lib/findex.pro
%%DATADIR%%/lib/findfile.pro
%%DATADIR%%/lib/get_login_info.pro
+%%DATADIR%%/lib/handle_create.pro
+%%DATADIR%%/lib/handle_free.pro
+%%DATADIR%%/lib/handle_info.pro
+%%DATADIR%%/lib/handle_value.pro
%%DATADIR%%/lib/helpform.pro
%%DATADIR%%/lib/hist_2d.pro
%%DATADIR%%/lib/hist_equal.pro
@@ -298,6 +324,7 @@ man/man1/gdl.1.gz
%%DATADIR%%/lib/last_item.pro
%%DATADIR%%/lib/lmgr.pro
%%DATADIR%%/lib/loadct.pro
+%%DATADIR%%/lib/make_dll.pro
%%DATADIR%%/lib/map_clip_set.pro
%%DATADIR%%/lib/matrix_multiply.pro
%%DATADIR%%/lib/mean.pro
@@ -310,6 +337,7 @@ man/man1/gdl.1.gz
%%DATADIR%%/lib/ploterr.pro
%%DATADIR%%/lib/poly.pro
%%DATADIR%%/lib/poly_area.pro
+%%DATADIR%%/lib/polywarp.pro
%%DATADIR%%/lib/popd.pro
%%DATADIR%%/lib/primes.pro
%%DATADIR%%/lib/printd.pro
@@ -338,6 +366,7 @@ man/man1/gdl.1.gz
%%DATADIR%%/lib/read_tiff.pro
%%DATADIR%%/lib/read_xwd.pro
%%DATADIR%%/lib/real_part.pro
+%%DATADIR%%/lib/resolve_all.pro
%%DATADIR%%/lib/restore.pro
%%DATADIR%%/lib/rot.pro
%%DATADIR%%/lib/rstrpos.pro
@@ -353,6 +382,7 @@ man/man1/gdl.1.gz
%%DATADIR%%/lib/str_sep.pro
%%DATADIR%%/lib/strmatch.pro
%%DATADIR%%/lib/strsplit.pro
+%%DATADIR%%/lib/svsol.pro
%%DATADIR%%/lib/swap_endian.pro
%%DATADIR%%/lib/swap_endian_inplace.pro
%%DATADIR%%/lib/template.pro
@@ -362,8 +392,10 @@ man/man1/gdl.1.gz
%%DATADIR%%/lib/trace.pro
%%DATADIR%%/lib/tvscl.pro
%%DATADIR%%/lib/uniq.pro
+%%DATADIR%%/lib/unxregister.pro
%%DATADIR%%/lib/value_locate.pro
%%DATADIR%%/lib/variance.pro
+%%DATADIR%%/lib/widget_message.pro
%%DATADIR%%/lib/wmenu.pro
%%DATADIR%%/lib/write_bmp.pro
%%DATADIR%%/lib/write_gif.pro
@@ -371,5 +403,8 @@ man/man1/gdl.1.gz
%%DATADIR%%/lib/write_jpeg.pro
%%DATADIR%%/lib/write_pict.pro
%%DATADIR%%/lib/write_png.pro
+%%DATADIR%%/lib/write_tiff.pro
+%%DATADIR%%/lib/xdisplayfile.pro
%%DATADIR%%/lib/xmanager.pro
+%%DATADIR%%/lib/xregistered.pro
%%DATADIR%%/lib/zenity_check.pro